unknown

asked Jul 30, 2000 at 11:03pm
Unknown Printer

Sharp JX9500 - Developer Unit problem

I've an old Sharp JX9500 laser printer which has separate Developer and Toner replacement kits. When prompted to do so recently I replaced both. But the printer is still saying
"REPL DEVELOPER" and won't let me print.

Any ideas?

Bob

There is a micro fuse 1/20 amp on each unit that goes into the Sharp. They blow when you power up the unit and reset the toner/developer/drum count to zero. If you put it in with power on, the fuse will blow and not reset anything. There is a way to reset it through the control panel. Haven't done one for a while so I'll give it a shot from memory, although it would be easier if I had one in front of me. There are 4 blue buttons. Turn printer off and press the left 2, turn power on, hold for a while and let go. It should put you in service mode where you can reset the developer counter by playing with the buttons. If that doesn't work, try the right 2 buttons. In any case, after you get the page count reset, insert a piece of paper into the manual feed and hit the form feed button. You should get a confirmation beep and it will be reset. If you have problems, try going on the Genicom site. They have reset procedures there. I don't know about the 9500 one, but I know the 9600 one is useless.
by moe on Jul 31, 2000 at 9:03pm Add comment
: There is a micro fuse 1/20 amp on each unit that goes into the Sharp. They blow when you power up the unit and reset the toner/developer/drum count to zero. If you put it in with power on, the fuse will blow and not reset anything. There is a way to reset it through the control panel. Haven't done one for a while so I'll give it a shot from memory, although it would be easier if I had one in front of me. There are 4 blue buttons. Turn printer off and press the left 2, turn power on, hold for a while and let go. It should put you in service mode where you can reset the developer counter by playing with the buttons. If that doesn't work, try the right 2 buttons. In any case, after you get the page count reset, insert a piece of paper into the manual feed and hit the form feed button. You should get a confirmation beep and it will be reset. If you have problems, try going on the Genicom site. They have reset procedures there. I don't know about the 9500 one, but I know the 9600 one is useless.

This is for the TI Microlaser (Sharp 9500 enging) so shud work same. FUSE FLAG RESET...press SELECT & PRINTER SETUP while turning on printer. "PCU Diag Mode X" will appear. Press UP arrow & PREVIOUS keys simultaneously until message "Fuse Flag Reset" appears. (3 sec) Release and "PCU Diag Mode X" reappears. Press SELECT repeatedly until "Diag Exit" appears. Press FORM FEED to exit diagnostic mode and you shud be in business.

- KenC
I've tried both these methods but it still doesn't want to play. Keeps on saying
"REPL DEVELOPER". Guess it's time to get a new one! Thanks for your help anyway - much appreciated.

Bob

- unknown