asked May 27, 2011 at 2:04pm
Xerox Xerox Phaser 8560

xerox 8560 ram error

Hi, we had a storm, couldn't get to my printer before the power went off, now it has a ram error message. Did the power off and wait...did the remove and replace of the ram...even bought new ram...nothing is working. Anyone have any ideas please? I run a small non profit and we rely on this printer for everything.


Skye's Spirit Wildlife Rehabilitation Center
Sounds like the storm blew the power supply/engine control module

by unknown on Jun 1, 2011 at 8:51am Add comment
THanks Brett, I found a download of the repair manual and I'm hoping that I can get one to replace this one and pray it works. We just can't afford a repairman to come out.

Thanks so much!!

by skyespirit on Jun 1, 2011 at 9:59am Add comment
Well, it seems I have the exact same issue. Worked fine before we lost power (and went to generator power) Now there are no sounds, fans, clicks, nothing. RAM ERROR in the display. Pulled the ram module out. Nothing. Replaced the module with a new one. No difference. I took the unit apart and found 3 fuses on the power board in the electronics module. All tested good. There are two lights on the side of the electronics module where the AC cord plugs in, PE and PS. Page 3-3 of the service manual

Shows the PE LED and PS LED to indicate "Boot loader memory test failure. Ensure the printers RAM
chips are properly seated and that the correct RAM type for
this printer is installed."

I bought the same RAM (by specs) at Staples except it was a 512m module. (There is a 256 in there now. In the lower slot). No difference.

Xerox ram modules are $600. Xerox electronics module is $350.

Anyone else have any thoughts? I may just part this unit out and get an HP.

by pjw73nh on Nov 10, 2011 at 11:36am Add comment