asked Dec 23, 2010 at 2:42pm
Hp HP Photosmart C7280

HP c7280 - Pump Motor Stalled Error

My hp c7280 printer keeps getting a pump motor stalled error. Does anyone know how to help me go about fixing that.

I have already tried resetting the hardware through the system configuration menu and retrying to print a test page, but that does not work.

Many thanks.
I have tried everything I have read to try to get the printer working. Nothing has been successful.
by unknown on Aug 29, 2011 at 10:19pm Add comment
- Have a C7280.

- Forget error code (sorry...) but it was one of those stated above. Probably the worst one (my karma). Followed HP procedure stated at the beginning of this forum post: http://www.fixyourownprinter.com/forums/printer/50063. I tried it about 10 times to try to resolve the issue, but to no avail every time... No amount of key sequencing, code clearing, resetting, unplugging, waiting and replugging did any good.

- All levels showed correctly in HP Solution Center. Yellow ink level was low.

--> Solution found: Replaced yellow cartridge but also, ENERGETICALLY removed and reinserted each and every of the 6 cartridges several times. ENERGETICALLY as in I've got nothing left to lose at the epitomy of frustration kinda jerking to and fro movement under the lid. Picture it...

After closing the lid, the printer did it's "initialization" sequence once more and it didn't sound any better than before: the now all too familiar grinding sound like "I didn't press the clutch enough and shoved the stick into gear anyway" started it off followed by the pulley humping belt tug of war... Usually THE CODE would appear not long after. BUT WAIT ! Whats's this ?! A new warning appeared: CLEAR PAPER JAM. There was none... Pressed Ok. And waited some more. The test was f***ing endless. But finally, it rolled to a stop. No more crash code. I printed a test page, a diagnostic page and a sample page. Everything works fine now.

I know it sounds too damned simple but, it worked for me: ENERGETIC CARTRIDGE REPLACEMENT. Who would of thought...

My sincerest thank you's to every one who participated here and the other forum mentioned above. My cheeriest hi-five to those for whom my solution would work and my most heartfelt sympathies to you who tried yet another solution - mine - only to have it also utterly fail...
by unknown on Sep 23, 2011 at 6:03pm Add comment
I fixed mine in about 10 minutes.

1. Remove the left side white panel.

Use a T10 screw driver (star shaped).
Remove 1 screw on the back near the panel.
Remove 2 screws under the ink cover near the left edge.
Push down on the dark plastic tab and pull the top of the white panel.
The the back will release along the top edge, but the front will be stuck.
Pull up on the dark plastic near the front edge. This will release the off white panel.

2. Manually actuate the ink pump.

The ink pump has a belt running over a 1.25" (ish) gear near the front of the printer.
It is a peristalsis pump with 6 hoses running over it. Turn the large gear counter clockwise several times. This will free the pump.

3. Check the operation.

The motor should start the pump during the power up sequence.

4. Replace the cover.
by unknown on Feb 22, 2013 at 12:33pm Add comment
Followed your 10 minute fix and it worked. Don't have to buy a new printer, thank God. - loviejoy
Thank you so much for posting this solution, especially with the careful details on how to remove the cover. Thought my printer was a goner when I got another error message, this one faulting the pump.

The time estimate is correct, took me about ten minutes once I found the star screwdriver bit in my husband's drill kit.

I still get ink system failure messages if I leave the printer on for any length of time, but as long as I use it and shut it off right away it works fine.
by unknown on May 21, 2013 at 5:38am Add comment
Thank you so much for these instructions for fixing my printer. I was ready to buy another one when I found these instructions.
by mrdan on Jun 10, 2013 at 10:39am Add comment
thanks. the 10 minute procedure by JLD fixed my issue with the "pump motor stalled" message. very much appreciated.
by unknown on Jan 12, 2014 at 4:13pm Add comment
Got it fixed. Followed the 10 minute fix and got her done. - loviejoy
This has happened to mine several times. Every time it happened, I had to replace an expired ink cartridge and then it worked fine. It did not matter how much ink was in the cartridge...just that it had expired. Check the expiration date on each one.
by shoggatt on Apr 30, 2014 at 8:38pm Add comment
ten minute fix stopped me from offing myself over this @#*^##/ printer....been futzing with it for weeks....thanks.
by unknown on May 21, 2014 at 10:14am Add comment
JLD - you are a god amongst men - I am yet another person whom you have saved the cost of a printer.
by unknown on Jul 11, 2014 at 10:49am Add comment

JLD- I am testing this now, but in either case the instructions were to the T. In fact it took less than ten minutes. (after trying to replace the cartridges 4 or 5 times with no change), So now for the results.....ok so no success but it sounds like it is trying. assuming I may not have turn counter clock wise enough....after a few more turns appears to be stuck in a loop. I will say at this time I am not unhappy I tried it. currently shaking cartridges and moving print head arm in attermpt to get it started. ok for a lst ditch effort, ( I know you shouldn't) I am unplugging the unit and giving it a few minutes. and no change.

by Dendig on Dec 27, 2015 at 10:53am Add comment

this worked and saved the printer from the scrap heap!!! many thank

by phil170 on Dec 12, 2016 at 6:23am Add comment