asked Jul 13, 2010 at 5:07am
Canon Canon Personal Copiers (PC) 7

Epson R2400 - USB Faulty but FireWire OK...?


Just wanted to post my experience really with my R2400.

After years of great operation, no issues, the printer decides to only print a small amount of the file that is sent when sent to the USB port.

Now, I know that the advice to remove the printer driver, reinstall etc. etc. Another USB cable etc...

I did something slightly different.

I tried the printer via USB on a Mac with Tiger, Leopard and Snow Leopard, Intel and PowerPC, a total of five different Macs via USB - all the same problem.

Tried on three PCs with Windows XP Pro, Vista and Windows 7, then on a DOS PC trying to output the command prompt to the printer.

Then tried on a CentOS Linux desktop.

All computers regardless of OS would print a small amount of the print job then stop, the paper would eject and the printer return to ready.

So, I got hold of the Epson R2400 Adjustment Software and took a look at that.

I reset and re-calibrated everything possible within the printer, all functions reported success but still no more than a few hundred KB of data actually processed into print before the printer ejected the paper.

So, reset the printing system on my G5 Mac with Leopard 10.5.8, reinstalled the drivers from and connected the printer by FireWire, added the printer in the preferences and proceeded to print 35 photos, high quality, high resolution on A4 paper, full bleed etc... took about an hour, not one hickup at all.

The images where about 13MB Canon RAW files, so plenty of data to get lost if there was a problem.

So my printer is functioning again, but no USB, doesn't really matter to me as I have loads of FireWire options.

Does this point to anything specific within the printer though, or is it just a faulty USB sub-system, I assume that the print job reaches the printer RAM correctly, does the machine have separate RAM for USB and FireWire...