asked Apr 11, 2009 at 11:35am
Hp HP LaserJet 4

HP Laserjet 4345 MFP ---- will not initialize/boot


I am working on a LaserJet 4345MFP that will not complete its initialization sequence i.e... The three LED's on the front never stop blinking. The control panel displays the HP logo during this period but never comes to the ready screen.

I swapped the complete formatter assemblies between this 4345 and a working 4345. The first time I turned on the working 4345 with the suspected formatter in place, the printer booted and fully initialized. I turned the printer off and right back on. After that, the working printer (with suspected formatter installed) never would fully initialize again. I tried 4 or 5 times. I installed the complete formatter assembly from the working 4345 into the problem 4345 and it still would not initialize.

I swapped components (hard drive, FAX card, and firmware module) from known working formatter into the suspected formatter while it was installed on the problem 4345. There was no change. I did not have the luxury of swapping the other way around (suspected bad components to good formatter on working 4345).

These are the other things I noticed on the bad 4345:

1. The heartbeat light flashes --- ONE, ONE TWO.
2. There isn't a "Copy module" light on either 4345. Although the service manual states that there is a copy module LED. I looked at the circuit board and did not see an LED in that position.
3. The internal NIC card link light flashes but only when I leave the hard drive disconnected and reboot the printer. I tried with both hard drives and got the same result
4. I get replies from the printers IP and can access the web Jetadmin program when the hard drive is disconnected. Unfortunately for me the web jet admin program was very basic and did not have an event log. However the working 4345's web jet admin had more pages and information.
5. The FAX light LED light does not blink.
6. The engine test will not print.
7. If I leave the hard drive disconnected the three LEDs on the control panel will blink in sequence and then go out, the start button light turns to amber and the control panel LCD doe not change.

Here are my questions/thoughts:

Has any one ever experienced this type of problem?
Can I upgrade the web jet admin software on this machine to a newer version that has an event log? Where is the web Jetadmin software? On the internal NIC, formatter, hard drive or ????? If put the known good formatter back in the bad 4345 and access the event log will I see errors/events from the working 4345 or from the bad 4345. Where can I find a list of every component involved in the initialization sequence? Can I bypass these components one by one until the machine boots? If I do a cold reset will that tell me anything? Do you have any tips, tricks, or tests that will help me find the problem?

Any thoughts, comments, or help would be greatly appreciated.



P.S I am a network admin turned printer repair TECH (due to bad economy) so if I used word that seem out of place or I seem like a newbie it's because I am.

One thing in your post bothers me. When you put the formatter from the non working printer into the good printer and it initialized and then you turn it off and back on again it did not work. That could be because you are to wait at least 5 minutes after installing a new or another formatter so all the information from the dc controller storage chip can write to the new formatter. If you did not wait then you may continue to have problems with the formatter even if you get the other problem solved. A lot of times when these printers do not initialize it is the scanner module causing a problem. Sometimes you can just remove the cover over the interconnect cable at the back and remove and reinstall the cables and it then works. That would be the first thing I would try.
by dmzcompute on Apr 11, 2009 at 1:25pm Add comment
Thanks for the info...... I will definitly give that a try. - Anonymous
I am having the same issue on the 4345, however different circumstances have brought me to this point. Actually, the printer is only about 90 days old, should still be under warranty if I need to replace the formatter or hard disk. But, I have performed a cold reset, and an NVRAM initalization, I am going to try to init. the hard disk.

If anyone has any other thoughts on this I would love to hear them, waiting on HP to send me a replacement part is not something I would like to do.

Also, I have reconnected the scanner,duplexer, and hard drive cables.
by unknown on May 19, 2009 at 12:09pm Add comment
A new formatter fixed my problem
by unknown on May 19, 2009 at 12:57pm Add comment
Re-init. HD did not fix the issue, however after removing the Hd completely from the unit, I was able to go beyond the init screen and get a config. page so I am going to replace the hard disk.
by unknown on May 19, 2009 at 1:24pm Add comment
We changed the reverser assembly because we were having persistent jam. After changing the assembly we switched on the printer but it took very long and then it booted. But the problem still persisted so I decided to check the feed roller assembly. After checking the feed roller assembly and the putting everything back together the printer would not boot up to the Ready menu. I have tried some of the suggestions here like checking the front fan and formatter. The Formatter seems to be working but we have not changed it to test. Can someone suggest something else that might cause this problem.
by unknown on Apr 20, 2011 at 9:50am Add comment
Hello there,
I have a brand new hp 4345 mfp machine.
It shut down normally but when i tried booting again. it stops at stage 5 and never goes beyond that.

In short, it cannt respond beyond this point 5 and D on the letter series.

Can some one out there help me out.

Am in Africa and these machines are not many here.
Its only two months old.

Every thing seems normal but i cannt do anything.
Am stuck. very stuck.

This machine was imported from Dell US.
PLease help.
by unknown on Jun 30, 2011 at 6:22am Add comment
Hello there,
I have a brand new hp 4345 mfp machine.
It shut down normally but when i tried booting again. it stops at stage 5 and never goes beyond that.

In short, it cannt respond beyond this point 5 and D on the letter series.

Can some one out there help me out.

Am in Africa and these machines are not many here.
Its only two months old.

Every thing seems normal but i cannt do anything.
Am stuck. very stuck.

This machine was imported from Dell US.
PLease help.
by unknown on Jun 30, 2011 at 6:24am Add comment
Boa tarde,

Caso a inicialização trave no logotipo da HP, que foi o que aconteceu comigo, troque a DC Controller (que fica atras da impressora). Apos a troca ela voltou a funcionar.

Espero que ajude!
by unknown on Aug 5, 2011 at 10:18am Add comment
I just went through a similar issue myself. Turned out to be a bad engine control board. Give your about 4+ hours to replace it if you have never done one before. You will need the manual and you will need to pretty much take every part off of this machine. Mine was failing at the blooming logo 6/6 F with all LED's flashing in sequence.
by unknown on Mar 14, 2012 at 2:29pm Add comment
4 hours are you kidding. I can do it in maybe 25 minutes. Yes I have done it before but you only have to remove the formatter and the back cover and then the metal cover over the control board, disconnect all the connectors, remove and put the new one in and put the connections back. Piece of cake.
by dmzcompute on Mar 14, 2012 at 7:32pm Add comment
flash the firmware or replace the firmware
by NYFINESTTECH on Mar 17, 2012 at 6:23pm Add comment

i have problem with my HP Learjet 4345mfp it's always red light under start button. what should i do?

thanks in advance!
by catarman on Apr 9, 2012 at 1:04am Add comment
Does the printer come to ready with the icons on the display. If so go to the diagnostics menu and choose the item to display the event log. My guess is you will have 30 errors listed which means the scanner did not initialize during power up. If that is the case turn off and then back on and see if it comes to ready. If no joy, turn off the unit and in the back where the big cable goes from the top unit to the main unit, remove the screws securing the cover and then remove and reseat all the cables to the board behind the cover and then turn on again and see if it comes to ready. If not you may need to replace the scanning unit if 30 errors or the scanner control card which you reseated the cables.
by dmzcompute on Apr 9, 2012 at 5:28am Add comment
I repaired, Please follow instruction below

You have to take the top glass off of the printer to get access to the scanner head(bar that moves under glass). Remove the long strip of black plastic on the scanner head and look inside, you will see a small circle camera. Clean the lens of the camera with some alcohol and qtips but be careful not to scratch the lens. Reboot the printer and you're good to go!

Naseer Habib
by unknown on Apr 15, 2012 at 1:51am Add comment
And that instruction came from the link: http://h30499.www3.hp.com

always, alway, always give credit to the original suggestor.
by unknown on May 24, 2012 at 6:19pm Add comment
Hi all
Am having problem with my printer LJ4345mfp have got error 49.ff04, diagnosed found the problem in my flash card. Because when substituted with one flash card which works on another printer of the same model the failed one boot up to get ready and the users can work without problem. But when I install back the old flash card repeats the same mistake error 49.ff04.
I bought another flash card (NEW) of the same model as broken one HP Q7725-60001-0001 32MB but the printer does not complete the boot, ending with a blue screen.

What should I do?
by fernandorap on Sep 6, 2012 at 5:38am Add comment
Get yourself some imaging software and make a image of the good cf card and then use that image to reimage the bad cf card.
by dmzcompute on Sep 7, 2012 at 1:11pm Add comment
Hi dmzcompte. can you send me a link where do i can find manual for imaging CF Card? trying on Google but i can't find nothing about imaging cf card of laserjet4345mfp.
by fernandorap on Sep 9, 2012 at 10:10am Add comment
So mine is a bit different. I turn it on, I can hear the fan, motor turn and the ready and data lights come on green then it just stays there. no blinking or anything. The display also stays black. I'm guessing its either power or the formater but I dont know. I've tried pulling the hard drive because that was easy but it didnt change anything. Anyone care to point me in a direction?
by unknown on Oct 31, 2012 at 11:32am Add comment
Hi...I have a Laserjet 4345mfp. When I turn it on, the display is blank, all 3 lights stay on solid. The fan's are working, but no motors are turning. I have replaced the dc controller with the same results. I have gone through the Service manual, and it doesn't list this condition. Any help would be appreciated. Thanks
by billmca on Apr 8, 2013 at 9:43am Add comment
I would lean towards the formatter since that is what controls the display.
by dmzcompute on Apr 8, 2013 at 4:07pm Add comment
hallo there i have a laserjet m4345mfp it does everything except the photocopying.The photocopying led remains orange.i tested the scanner bulb on the menu diagnostic tool its working,i tested the motors they are working.
what can be the problem
by Chafadza on May 14, 2013 at 11:47pm Add comment
First make sure no one locked the scanner. The switch is on the left side next to the small strip of glass for the adf. If that is ok, then the most likely cause is the scanner control card located in the rear of the unit where the cables from the adf go. One thing you can try is to remove the cover in the back where the cable goes. With the power off, remove all cables and reinsert. Now turn on the unit and hopefully it will now work ok.
by dmzcompute on May 15, 2013 at 5:17am Add comment
Hi...I have a Laserjet 4345mfp. When I turn it on, the display is blank, no lights come on but the fans are working. Please advise
by unknown on Sep 12, 2014 at 3:29pm Add comment
With the power off remove the formatter. Remove any chips and put them back. Now put the formatter back in and turn it on and see if there is a difference.
by dmzcompute on Sep 12, 2014 at 4:02pm Add comment

Having a problem, M4345 When booting up, all 3 lights flashing in order, the hp logo keeps going from small to large and never stops

I've tried pulling the hard disk and disabling the back fan, not sure what other steps I've missed.

Thank you.
by swishhhh on Jan 4, 2015 at 9:41pm Add comment
my used m3035 mfp doing same thing, have no manual, turned it on green red lights flash non stop hp logo goes from small to large says 1 of 6 gets to 6, but lights keep cycling flashing, no buttons do anything, but power button, no sleep button, start nothing,.. - njhall