asked Mar 11, 2009 at 12:01pm
Hp HP LaserJet 2430

HP 2430 -RFU load error

I have a LaserJet 2430 with the display reading "Download file now, RFU LOAD ERROR". I have downloaded the software from HP but that is where I ran into the "Catch 22". I cannot download the software to the printer unless it is in a "ready" state with all error messages cleared but apparently the printer is not going to clear anything until I have upgraded the software. I tried every key combination I could think of to get it to cold reset but nothing changes. Any ideas other than "large caliber weapon - close range" would be appreciated.
i have too this problem . i found an site there are sell ing an usb falsh . you can connect this usb to formatter internal usb port and can re work ( erase & re program dimm slot) your printer . i am trying to find this software . i am thinking about that we can do this with any usb flash drive but we need this software if you can find send me [email protected] ( sorry 4 bad english )
by goligoli on Jun 5, 2010 at 3:18pm Add comment
Take out your PRINTER from your computer and see if you can get a self test.
From your COMPUTER, purge out all the print job that is on queue.
If you can't get a self test, turn off your printer, wait for a couple of minutes then turn it back on. Wait until it finish cycling up then try to get a self test. If the printer spit out the self test your printer is ok, if there's a service message, the printer got a problem. If thre's no service message, turn off both your computer and printer hook up your printer to your computer then turn on your computer first, wait until it finish cycling up then turn on your printer. If everything is ok,( are trying to load a driver for your printer) then go back to hp website and get the compatible driver for your printer.
by the novice on Mar 11, 2009 at 12:54pm Add comment
I just had a cm6040mfp give me this error and its a corrupt firmware issue. Downloaded the most recent firmware thru the USB port and it fixed my problem. Under the new firmware it was listed that this was a known issue and the firmware was the fix. Hope that helps.
by nivek on Mar 11, 2009 at 6:51pm Add comment
I have this error on a 2420. i have the firmware file but when i hook up the usb cable nothing happens. the pc doesn't find the printer. it will let me set it up and i can look at the properties but it won't let me print anything. it doesn't go through a cycle when i turn it off and on again. it just goes straight to that error message. - Anonymous