asked Jun 7, 2008 at 10:54am
Canon Canon Pixma MX850

Canon Pixma Mx850

I am trying to install a new printer Canon Pixma mx850 to work in network mode. When i get near the end of the install. I get an eror message. To setup this printer for network operations you have to connect it initially via USB and then with a network cable. It is after i am asked to connect the network cable that i get the followingf message.

New Port could not be created

It seems to create the port using a drive letter. I try to change the drive letter and still get the same problem.

Any help greatly appreciated.

Many Thanks
I have had the same problem with a canon mp600r. I have solved the problem in the following way. Apparently the problem was that the port already existed. You can remove this by using a program on the installation CD: \\LAN\\ENGLISH\\CNMNPU.EXE

After that you can reinstall the printer via the network tool or by using CD: \\LAN\\ENGLISH\\SETUP.EXE
by breker on Jul 2, 2008 at 12:40pm Add comment

I just found your post and followed your advice. It helped me fix the error "New port could not be created" I was getting as I was setting up a second laptop to use with Canon Pixma MX860. THANK YOU!!!

kali - Anonymous
This work for me on my Canon Pixma MX860. Thanks - unknown
Hi breker,

I join the other users in thanking you for your excellent advice. I had the same problem with my Canon MX410 and your advice solved the problem.

Before I went into the Internet I called the Canon support here in Israel and they threw the problem to my router, which was not true. Maybe I'll call Canon support again and teach them something new. - meirp
Once the MX850 is in the network, navigate to the LAN settings and you will see the IP address and the MAC address. If your network has a DHCP server, the printer will receive an IP address. If you have manual IP addresses you can give it one close to your printers IP address.
Then open the Canon IJ Network Tool and search for the printer. You should then see the printer with the port name
where xxxxxxxxxxxx is the MAC address.
You should then see the printer under Start-Settings-Printers.

Are you sure that the error message that you received about not being able to create a new port did not come from not having a memory disc in the slot. The software attempts to map this with a drive letter. If you have nothing in the slot then you can click on cancel or skip.
by skyout on Aug 5, 2008 at 3:52am Add comment
you're welcome, glad to know you got it working
by skyout on Apr 5, 2009 at 12:48pm Add comment
Another way of fixing it is by right-clicking to properties for one of your other printers (or microsoft fax, or anything in your printer folder).. Select the ports screen then delete the IP port.. I don't know if I remember the steps right but as long as you can locate the ports selection for any printer you should be able to delete it then re-run the network setup for Canon printers..
by unknown on May 23, 2009 at 9:37pm Add comment
Just wanted to confirm that breker's post works perfectly with this error.

by unknown on Jul 14, 2009 at 7:38am Add comment
This worked for me as well on the mx860. The only problem is that I cannot get the scanner to connect wirelessly as well. Any suggestions?
by unknown on Dec 5, 2009 at 9:12am Add comment
Updated fix for "New port could not be created. : 0000" error. Just worked through this with canon support for an mp990 over the network, to a win7 64bit computer. It seems to have something specifically to do with win7/vista 64bit. There is a utility that comes with the driver, called the Canon IJ Network Tool. When you uninstall the drivers, this apparently doesn't get fully uninstalled. Here was the resolution:

1. Uninstall the canon drivers, via add/remove programs or from the start menu.
2. Go to the install disk that came with the computer. Navigate to win -> Driver -> LAN
3. Run the file called "CNMNPU"

This fully uninstalls the network utility (apparently cleans up some leftover registry entry or something).

4. Restart
5. Download the latest win7 x64 drivers from canon's website. This is currently a file called "mp990swin101ej.exe". Install. Should work this time.
by unknown on Dec 28, 2009 at 5:14pm Add comment
I have a canon mx 850. The front flaP WAS ACCIDENTLY STEPPED ON CAUSING the spring at left hand side to unhook and now the flap will not close. The printed page will roll out with much crankling noise. I could not get access to hook the spring back in place.
Will appreciate if anyone would venture a solution of how to gain access to the side spring or dissassemble the unit

Many thanks
by unknown on Jul 18, 2010 at 5:20am Add comment
The printer installs and works with the usb but I can't set a static ip. The installation gets to the point where it shows you to provide the ip of the printer. When I display the printer ip on the printer, it's starts with 169.n.n.n so it's not seeing the router which should farm out an ip in the 192.168.0.n range. Is there a cmd on the install cd that allows me to manually set the printer ip?

Thanks in advance.

by pcwong on Aug 17, 2010 at 7:32pm Add comment
I cannot get the scanner to scan to PC on a Canon MX860 Mulitfunction Printer
by Cooperx5 on Dec 28, 2010 at 6:53pm Add comment
I have a canon mx850. I put paper in tray in front of the printer but the screen says its empty and to put paper in tray. I took the paper out of the tray and replaced it with new paper. Tried to print but came back that there is no paper in the tray.
I then used the paper loader in back of the unit and it printed fine. Tried to use the paper tray in front still shows no paper in tray. Anyone know a fix for this problem. I used the feed switch to go from back to front that did not work either.
by unknown on Jan 31, 2011 at 4:43pm Add comment
by unknown on Apr 16, 2011 at 5:40pm Add comment
I have owned my MX 850 for several years and not experienced any problems until recently. Now, when I use the print function from any type of document or email etc, about every 9th line comes out looking like it is in Italic print with a very light line running down the middle of the affected line.

I have tried using the Auto Align and the Manual Align features numerous times with NO success in fixing this problem.

Interestingly, it does not have this anomoly when making a copy of something.

Any ideas?????
by exadmiral on Oct 31, 2011 at 12:19pm Add comment
Anybody know what error 8200 is about? Recommended solution?
by unknown on Nov 29, 2011 at 3:17pm Add comment
when i turn on the printer I get error message 5C00. The copy light is blinking alternately with the alarm light.

I have tried an overnight reboot and taking out all the ink cartridges and cleaning everywhere I can see. No luck.

There was a paper jammed in the far right corner (niece using the machine in my absence). Even when that was cleared, no change.

Please advise.
by scheideckerj on Nov 29, 2011 at 7:08pm Add comment
My Mx850 will not print from my computer, at first I thought the printer was broken but found out it was not but running a test page, it scans and everything else but when i tell in to print it says the job stopped, can anyone help me with this issue?
by noNotagain on Jan 23, 2012 at 9:43am Add comment
I have Canon Pixma MX860 and am having the same problem as enduroman. I read all the replies but don't understand them. My printer worked fine (wireless) for over a year. Then I got a message that said "acquiring printer settings" or something like that, everytime I tried to print, with or without a cable. I uninstalled the printer. Now I am trying to install it again. It will work with the cable. But I have not been able to complete the network installation. The computer finds the printer and gets to the last step. Then I get the message "new port could not be created". I turned off my firewall and still am not able to complete the install. Thank you for any information that may help!

by ksjupiter on Jan 24, 2012 at 9:42pm Add comment
So nice thread that I found it so helpful
by unknown on Jan 25, 2012 at 3:59am Add comment
Does anyone have a solution to error 8200?

Thank you.
by unknown on Feb 18, 2012 at 9:06am Add comment
My Mx850 will not power up. I tried to turn it on, but it is completely dead. Does anyone know, is there a fuse somewhere that can be replaced or test something else to look for the problem?
by macjkb on Apr 11, 2012 at 7:04am Add comment

I have been looking everywhere for a fix to this error I was recieving. After finding your thread on here, and following your instructions everything worked perfectly as it should.

I wouuld also like to add that after followingyour instructions I was able to install the printer with no effort onto all the wireless laptops we have in our house, without the need of even plugging them into the printer.

Thankyou very much for taking the time to post this thread.
by JordanRichards93 on Apr 14, 2012 at 5:19am Add comment
I have a Canon MX850 printer. I was having an error code of 2100. I have taken out the ink cartridges and cleaned the part that the cartridges set in with warm soapy water. I have let it dry over night in front of a fan. Now I have an error code 5400. I don't know what else to do. Can you help me?
by 4242beard on Aug 8, 2013 at 10:48am Add comment
Thanks to breker for the solution. It worked - MG3100 (MG3170 specifically). Removed the CNBJNP port which was created when I installed the driver for USB. After that, re-installed (There is an option to change connection method in the latest CD that Canon provided). It got installed successfully.
Happily using wireless now.

Thanks again,
by unknown on Oct 16, 2013 at 3:14am Add comment