asked Mar 14, 2008 at 8:12am
Epson Epson Stylus Photo RX620

Epson RX620 Ink cartridges cannot be recognized

Have a Epson rx620, color on prints started looking off, ran a nozzle check black was virtually nonexistent. I removed the black cartridge and reinserted it, after that I started getting the message that the ink cartridges cannot be recognized (all of them). So I removed and reinserted the cartridges and power cycled a few times and it started working again but still no black. I went to the store bought a new black cartridge and inserted it, but now the message saying that it cannot recognize any of the cartridges is back. All the cartridges appear to be genuine and do not look like they have been refilled.

I just tried removing a couple off single cartridges thinking that there maybe be a problem with one of them. When I remove a single cartridge it only shows that it cannot recognize that one , but when I have all the cartridges back in it cannot recognize any of them.
I hope this helps somebody...
I found that if after I closed the latch that locks the cartridges in place I push down on all the cartridges a few times the error clears and the printer works!
by wmarkel on Mar 14, 2008 at 8:46am Add comment
After many attempts at other helpful suggestions, this one worked for me!!!

Thanks so much...
- unknown
Tried this and it worked first time, thanks you so much. A real simple answer to a mind boggling problem. Clever chap. Many many thanks! - FulhamGaz
THANK YOU!! I've been installing and setting up my new RX690 today and getting so frustrated with that error message. Gave the latch a bit of a push, as per your suggestion and what do you know - it worked! Pure genius! Thanks again - meagss
THANK YOU!! I have been fighting this for 3-4 hours today, and could not get it to work. That irksome message just kept popping up.
I tried pressing down on the cartridges after reseating them, and voila! It works!!
Many, many thanks! Thought I was going to have to get a new printer. I have been using replacement cartridges from ABCink.com, and have never had a problem with them - until today! Pressing down fixed it. I had even tried replacing with Epson cartridges - reset, and even that didn't work.
Thanks again. - unknown
thank you so much!! this actually helped after hours of troubleshooting!!!!!! - unknown
I have been frustrated for a long time about this problem...called epson, and they could not fix the problem. This worked for me!!! I pressed on all of my ink cartridges and presto, it began working again...thanks for your post!! - Anonymous
I have had this message several times. I remove the cartridge and rub a soft tissue over the gold part of the cartridge. Then replace. This does work. Good look.
by AJCrafts on Apr 20, 2008 at 11:51am Add comment
My thanks to AJCrafts for the tip on cleaning the chips with a soft tissue. I use Jettec cartridges and when I replaced the light cyan I got the message that the cartridge could not be recognised.After removing and then replacing it, I got the message that none of the cartridges could be recognised.Searched high and low for an answer until I came accross AJCrafts tip.I removed the light cyan only, cleaned the chip and when replaced the printer went into 'ink charging' mode and all six cartridges were recognised.Brilliant. Many thanks. - Anonymous
Worked like a charm. Thanks SOOOOOOOOOO Much - Anonymous
Used the same advise on mine cx3800 - worked like a charm, thanks
by unknown on Feb 10, 2009 at 2:28pm Add comment
You guys are lifesavers - had a major domestic with my wife whilst trying to resolve this one!!
by Anonymous on Apr 21, 2009 at 2:22pm Add comment
nope, nada, none of these work. Have 3rd party ink and will have to try to Epson brand...new there was a reason I hated Epson.
by Anonymous on Jul 6, 2009 at 8:49am Add comment
In the Epson printer utility try the Nozzle Check and the Head Cleaner Utility. I did it and it printed the sample and recognized the cartridge.
by unknown on Aug 1, 2009 at 6:15pm Add comment
Thanks for above info, as well as cleaning the Gold parts I also carefully depressed the locking tabs a little and that did the trick. Seems they were a little loose so this tightened them up with a CLICK every time
by unknown on Sep 11, 2009 at 10:41am Add comment
Rubbed a kleenex over side chip heavily and shook up and down then pushed each cartridge in slot with some force, slapped the cover shut and pushed down sharply ( somewhat frustrated by now ) and it worked. It says genuine epson ink even though it is not. EPSON SUCKS, but we still win. YOUR A LOSER EPSON, I BEAT YOU
by Anonymous on Sep 26, 2009 at 6:15pm Add comment
I tried this several times without any success. This will be my last Epson Printer. I always had HP's, but hated the tri-color cartridges because I felt it wasted ink, but this is just as bad, will not print or recognize cartridges when they get low. The printing quality of my previous Epson (R220) was great. I had some of these problems, but not nearly the problems I have with the NX415 and the print quality is not as good. Of course they no longer make the 220 and mine finally said it needed service. I figure that is another Epson rip off.
by unknown on Jan 19, 2010 at 7:15am Add comment
i've tried all of the advice on this page and none of them worked, any other ideas anyone please? i'm pulling my hair out here....it worked fine with all other none epson ink and now it wont work at all.
by unknown on Jan 24, 2010 at 6:24am Add comment
My Jet-Tec Magenta has just failed again when half full. I've had no joy with the clicking, slamming, chip cleaning, nozzle cleaning etc. over the 3 years that I've had my DX 8450. Many cartridges will not work again if removed and replaced even if they aren't showing a fault, maybe it upsets the charging or the chip memory ? Just guessing. The local engineer advised me to run proper Epsom cartridges through it every 3rd or 4th cartridge or when it failed as this acts as a cleaner. Just passing that advice on. Rip-off prices but it seems to work. - Anonymous
I tried all of the above and then took a Q-tip with a bit of isopropyl alcohol on it and gently rubbed the inside of the cartridges holder where the sensors go. I then reseated the cartridges and pressed hard against the holder. It finally worked! Go figure!

Thanks to everyone for their input....these tips ought to be on Epson's support page.
by unknown on Feb 5, 2010 at 12:17pm Add comment
The rubbing alcohol applied with a Q-tip to the sensor inside the printer finally worked! This was after reseating, pressing down on the tabs, wiping the chip with tissue and even the machine with tissue and Q-tips didn't work for my NX400. Thank you and God bless you all! - Anonymous
I removed the black ink cartridge & replaced it with a new 1,i then started to get a message that none of the ink cartridges cannot be reconized,I removed all of them & reinserted them,but still getting the same message,they are all genuin epson. help?
by Anonymous on Feb 23, 2010 at 8:47am Add comment
I found this link on the internet. Seems like Epson keeps changing the little chips on the cartridges which can often cause a full cartridge to show empty or not an Epson cartridge. And even make all of the cartridges show as non-compatible. So I carefully scraped off an old chip from an old cartridge and put it on the new. It worked. How long it will keep working I have no idea. I am thinking of going with CCS reusable cartridges next time I have a problem. One thing for sure, I won't buy an Epson printer next time.

by unknown on Feb 23, 2010 at 1:20pm Add comment
I switched the chip off the empty Photo Black cartridge, with the new one not being recognized- and it worked. Kudos to Tom King. i can't tell you how good if feels to finally see the message "Ink Cartridge Replacement Complete!" - DCDunkle
Thanks Tom King, you're a genius. After a long fight w/ my epson RX590, thanks to you I got the guts to replace the damn cartridge chip with one from the old cartridge that was empty, and IT WORKED. I was almost on the point to trash the printer, and the worse is there is not many (and better, and cheap) alternatives for the functionality I need. Thanks again, and baaahhh to epson and its stupid ideas that make us spend time and money! - unknown
In Response To: Tom King
I researched the site from the link on your response. They sound like an excellent solution to my printer problems! I was wondering if you want me to use your name as 'referred by' on the site before I order, so you can get the 'credit' they spoke of on their site. Let me know. Thanks for the link!! - Marie M.
I have an Epson RX560 that has the same problem of not recognizing ink cartridge. I have tried all of the suggestions of wiping and pushing and even replacing a previously used chip. None of them work. Any more suggestions please
by Anonymous on Mar 26, 2010 at 4:09am Add comment
thank you!!!!
I tried the pulling out the ink and pushing it in tightly over and over (cause i bought it over the internet and i didn't want to return it) and after the fourth time the ink started charging!

i had a stylus epson NX400 and on the box it said it only worked with stylus cx700F/cx8400 and workforce 40/600. I thought i'd have to buy it all over again but now I don't!

by unknown on Apr 26, 2010 at 4:35pm Add comment
Marie...that's fine. I hope the new cartridges work out well for you....Tom
by unknown on May 1, 2010 at 4:37am Add comment
Wow, am I ever glad I found this thread. Thanks to all who shared here. I am the "fortunate" owner of an Epson printer which is refusing to recognize my EPSON ink cartridges AND saying there is a paper jam when there is not. LOL I have tried most of the suggestions to get it to recognize the cartridges... including the rub them hard, shake them furiously and pound on them (there is a point beyond which you don't care) :) -- all to no avail. This is the FIRST time I have changed the ink cartridges!!

I had no idea the problem was so widespread. But... but... but...

Today I ALMOST bought an R-1900 photo printer! I had every intention of buying it until I read all this and realized what a mistake I was making. This is my first Epson printer and up until now has been my favorite. But I am headed out tomorrow to buy my first Canon... since I won't even consider an HP due to past experience. How on earth is Epson avoiding a class action lawsuit?
by Misti in Seattle on May 1, 2010 at 11:23pm Add comment

I have just been informed that there is a small device which can be purchased at Staples for around $12 which will reset the cartridges. It is called and Jet Tec Inkjet Ink Level Resetter.
by Misti in Seattle on May 2, 2010 at 1:50am Add comment
My next printer will be a Cannon...
My next printer will be a Cannon...
My next printer will be a Cannon...
My next printer will be a Cannon...
by Anonymous on May 5, 2010 at 10:34pm Add comment
Thankyou thankyou thankyou to all who posted a solution to this problem, it worked a treat for me....how frustrating in the first place!!! Who would have thought that rubbing a tissue on the chip would make the stupid thing work!
by Anonymous on May 19, 2010 at 3:20am Add comment
I tried EVERYTHING mentioned here and I could think of. I FINALLY got rid of the headache. How you mayask? I live on the 3rd floor of an apartment building... watching tumble down the stair made me feel MUCH better. Damn Epson.
by Anonymous on Jun 2, 2010 at 7:16pm Add comment
LOL I think bouncing it down the stairs is the best solution. Personally I am enjoying my new Canon.
by Misti in Seattle on Jun 3, 2010 at 5:00am Add comment
Been having this problem with an Epson Photo RX585. Either it stops printing or when the JetTec ink cartridge is about 25\% full says it cannot recognise cartridge. Tried all the fixes above but couldn't get to recognise compatible yellow and light magenta cartridges - both new!!
Fortunately I had a new compatible magenta and the old yellow cartridge. Swapped for these and it recognised them. Once I had replaced the empty yellow all was working again. Would recommend keeping your old cartridges to swap out to when this happens - it may fix your printer.
All in all, I am not happy having to go through this routine every time I change cartridges. Have been using Epson for years without issue but now will not buy Epson again. Was thinking of HP but other users seem to prefer Canon - what would other users suggest?
by AdrianB on Aug 23, 2010 at 11:10am Add comment
None of the above worked for me...I am so frustrated. I also had a previous Epson printer that worked great for several years so I didn't think twice from purchasing a new one. But I will NEVER own an Epson again. I promise you that. Epson should have a class action lawsuit filed I agree. They spent so much time developing a cartridge that cannot be "refilled" yet their own printers don't even recognize them! That is absolutely unacceptable. NEVER AGAIN!!
by unknown on Aug 30, 2010 at 1:05am Add comment
Have 2 Epson Printers - R340 3 years old and no problems. Bought a SX415 4 weeks ago for it's scan and copy capablities and after 160 black A4 prints I was told that the cartridge needed changing. Man in the shop told me it was probably only a part filled cartridge that came with printer. Started to get worried.
Black cartridge 'emtpy' again, another change but guess what ? Cartridge cannot be recognised and by the way, the yellow needs replacing too ! Hours later after head cleaning etc, all ready to go but copy comes out blank apart from a few smudges....... Reading the problems of others I am off back to the shop tomorrow to claim my purchase was not fit for purpose. Their problem, not mine. Watch this space. I might just buy an alternative - time is money after all and am not going to waste it chasing a manufacturer who appears to be selling a product with which so many people are having a problem.
by unknown on Sep 22, 2010 at 4:39pm Add comment
Yea, it's too bad this crap happens. It only happens with some of their printers. I have 3 Epsons and experience this problem only with my RX620.

Since I cleaned it, I've had far fewer problems. Replacing the chip from another cartridge also helped. See previous discussion.

All that said, you're right. It's not worth the hassle. Buy a different printer.
by unknown on Sep 22, 2010 at 5:40pm Add comment
HEY it works... on the Epson NX515 with WOX DE-ET068 replacement for Epson 68 cartridges. Pushed down several times on all 4 new cartridges... and now it works.. I should have gotten the real things form Epson. getting a cleal line on the printouts....
by unknown on Oct 2, 2010 at 10:41am Add comment
see previous post 22 Sept.
Retailer didn't quibble and gave me my money back.
New printer purchased - not Epson - not never again !
by unknown on Oct 18, 2010 at 1:56pm Add comment
If your cartridges previously working and the printer suddenly can't recognized it There's a way to fix it. The cartridges terminal is not fitting to the printer terminal that's why the printer can't recognize it properly.

All you have to do is hit the side of the printer until the printer and cartridges terminal if perfectly aligned. But if you want to do it the easy and most formal way, remove the cartridges clean the terminal and put it exactly as needed to make the terminal of each device connected. Still not working? Clean more and fit more. That's ALL!
by unknown on Nov 10, 2010 at 2:12am Add comment
Have tried all morning with this method to fix the non recognition of all 6 ink cartridges on Epson R340 printer to no avail. Have had problem for 2 weeks so will now buy a new printer.

Thanks anyway

John Peacock
by John Peacock on Nov 11, 2010 at 4:41am Add comment
Have read all these useful comments but can't find the one magical/miracle solution I need to this problem:

My all-in-one Epson Stylus Photo RX520 (out of warranty) has been working OK for the past 3 years using very reliable compatible inkjet cartridges. But a couple of days ago, after I replaced an empty cartridge, the plastic cover of the cartridge holder refused to click shut as it normally does. It closes but remains slightly above its proper level. I tried re-inserting all 4 cartridges (all are brand new from the same company I generally use) and they all click into place as always. Also tried pushing down again as suggested above. Still the printer won't work. The LCD message shows that the lid is not closed (it is) or that the Magenta cartridge is empty (it's full). I've tried everything I can think of but still no joy. Contacting Epson support is useless: they just tell you to buy a new printer. I phoned some printer repair services but either they don't deal with or it would cost more than a new printer. I'm sure all it needs is just a small adjustment to the plastic cover of the cartridge holder so it will click fully down again, but how to do that?
Before I stop tearing what's left of my hair and give in (as Epson wants us all to do) and buy a new printer (it WON'T be an Epson!) I'd like to solve this tiny problem:
Can anyone help? PLEASE!
by unknown on Nov 17, 2010 at 10:17am Add comment
Thanks to all of you for guiding me through this trouble-shooting! I've been through so many steps and problems I'm not sure I can repeat them, and I still haven't solved the problem of not getting black ink. But I DID manage to get the printer to recognize the cartridges.

First, the black ink was not printing. I tried head cleaning, and it said I couldn't clean the head a second time unless I first replaced two print cartridges. I replaced the magenta and cyan with the exact same brand I had used before (I buy compatible cartridges from 4inkjets.com - LDProducta), and then it said the ink cartridges cannot be recognized. I pressed and wiped the chips with a tissue. At least I finally figured out that they were only complaining about one cartridge, the cyan one. I discovered it was really easy to put the old chip on the new cartridge, but none of these steps helped. It still didn't recognize the cyan cartridge.

By the way, at that point the printer was saying that three of my cartridges were genuine Epson cartridges, even though they were really compatible ones.

Then I replaced the Cyan cartridge with another one from the same source, and then it recognized the print cartridges and reported they all were genuine Epson. But the black ink still is not working.

So then I took a Q-tip and rubbing alcohol, and washed the area where the ink goes into the printer (around the little black piece that goes into the print cartridge at the bottom). It looked fairly goopy.

But then when I put the cartridge back, pushed down, and closed it. Then I got a message that
by hbograd on Dec 24, 2010 at 9:28pm Add comment
Folks...let me say straight off that my RX620 printer is over 5 years old. Nothing made today lasts very long, and printers are no exception. Planned obsolescence is what makes money for the makers.

That said, sometimes you can get them to work again, for a while. I've posted a couple to suggestions earlier on this issue. It got my 620 up and running again. But last week, it quit right in the middle of the page and said my light magenta ink was out. I put in a new Epson OEM cartridge and got the same message.

Tried the usual steps of pressing down, reset, etc. No luck. Then went to the Q-tip, denatured alcohol and cleaning the entire inside of the cartridge box, especially the front wall channels where the chips are read. Also cleaned the ink sponges...carefully....and the track. Lots of messy, dried ink in there.

Turned it on again and lo and behold it's working again. For how long, I don't know. With all the time I waste on it, I'd be better off getting a newer printer. The refurbs are a lot cheaper. IF you decide to do that, check on the internet about cartridge costs and amount of ink used, That often adds up to more than the cost of the printer if you used it often.

If you don't use OEM cartridges, I'd suggest taking a look at this website. Their reusable cartridges are much cheaper and they give good advice and responses to your questions:


Hard to find real people willing to help these days and these folks do! Good luck, Tom
by unknown on Dec 27, 2010 at 5:16am Add comment
Hi all!
I have a problem with my Epson RX690, there is no any error message and all of the cartridges are full, but it prints pinker than its actual color, there is no cyan color.

Please help, if anyone knows about this problem?
by unknown on Jan 25, 2011 at 10:25pm Add comment
Tried everything. Epson is a POS. Moreover you cant even print in B&W. NEVER ever going to buy another Epshiet. It it not even worthy of the trash can.
by unknown on Feb 21, 2011 at 2:59am Add comment
Many Many thanks!

I used a tissue soaked in alochol to clean both the gold chips on the cartridges and the terminals they touch. Then I also pressed the cartridges down extra hard.

All working perfectly now, cheers!
by TasDogs on Mar 2, 2011 at 7:22pm Add comment
I have an Epson Stylus Photo RX560 - about 4 years old.
I put non-Epson ink cartidges in, the printer was initially fine but then a day later it suddenly did not recognise the magenta cartridge and went on strike. This was really annoying as I only wanted to print a text document so only wanted to use black ink, but the printer refused to do anything at all just because it didn't like the magenta cartridge. Anyway, went through all the advice on this page, none of it worked except the one about swapping the gold chip over from the old cartridge (which I had to recover out of the rubbish bin!) onto the new one. It was actually really easy, no scalpel or glue required! just snapped off and on. The printer is now happy and has begun working again. Good luck to us all.
by unknown on Mar 4, 2011 at 1:22pm Add comment
I had the same problem with my workforce 600. I tried all the cleaning, jamming it in, everything and none of it worked. The yellow still wasn't being recognized. I saw the post above about the chip and thought maybe that was the issue. I noticed that the magenta cartridge had a slightly different looking chip, so I checked the replacement Epson cartridge. It also had a slightly different look (the chip that is) and once I put in the new cartridge it worked. I'm keeping the cartridge that didn't work and bringing it with me when I buy other cartridges to make sure I get the right one. Keeping my fingers crossed....Thanks guys!!
by Stu_9 on Mar 16, 2011 at 12:21pm Add comment
I did the same thing that was mentioned above. However, i used hand sanitizer and a q-tip. I used above normal force to put them in after shaking them and i figured that i wouldn't work and as soon as i clicked the OK button it said "Charging ink. Please wait." I'm so excited and thank you all for writing this. Now it says "Complete" How happy i am. I was really ready to throw this f*cking Epson Workforce 615 out of my window.
by unknown on Mar 21, 2011 at 10:10am Add comment
Just thought I'd give feedback as I found this thread after Googling my Epson SX415 not recognising a new and genuine Epson cartridge.

I tried loads of variations of wiping chips, making sure it was clicked into place, following Epson's vague "turn it off and on again" type instructions. I mean loads of variations. For a long time.

This forum led me to resorting to angrily shaking the cartridge and instead of clicking the cartridge back into place, SMACKING it down, much much harder than before.

It now works again.

Go figure. You may try shaking alone before smacking, but hitting it did feel good ;)

Thanks for the tips.
by unknown on Apr 22, 2011 at 1:57am Add comment
I replaced an ink cartridge in my Epson printer, and I also got the message that it could not recognize the cartridge. The only thing that worked is when I switched the chips between the old and new ink cartridges (the chips snap out/in the cartridges easily). Now at least the printer recognizes the new ink cartridge.
However...now I get a different message: "You need to replace the ink cartridge." I tried shaking the cartridge, and turning my printer off/on, but the printer still says I need to replace the ink cartridge, even though it is full of ink. Any other suggestions to get the printer to realize the cartridge is full of ink?
by snowdenc on Apr 30, 2011 at 10:29pm Add comment
Reset the chip.
by unknown on Apr 30, 2011 at 11:14pm Add comment
I have an Epson TX300F and pushing the cartridge very hard was very successful. This printer is so crazy that I'd like to dropkick this. Anyway, it's now back to normal. Thanks for the tip!
by unknown on Jun 28, 2011 at 1:51am Add comment
I have had a problem with my printer (Epson Stylus RX585) not recognising any cartridges all of a sudden after I had replaced two empty ones. I tried everything suggested on this page and nothing seemed to work. At the end of my tether today I was going to bin it and buy a new one (AS EPSON ADVISED!!!!! They said the repair cost would probably be more than the cost of a new printer!!!!) and then I accidentally stumbled across a fix! Here it is:

I took out one cartridge and then closed the carriage lid and pressed "ok". The printer then informed me that just that one cartridge needed replacing. So I replaced it and then immediately took out a different one. So now the printer tells me once more that just the absent one needs replacing......

BUT.... when I pressed "ok" and the carriage returned, the screen now said I needed to replace all APART FROM the first one that I removed on its own! So I repeated the process, removing a different cartridge every time on its own, pressing "okay", and then simply replacing it and removing a different one until the LCD display said that there were no more that needed replacing! Completely BIZARRE workaround but it seems to have worked!!!

Hope this helps someone else! :) This problem had been driving me INSANE!!!!!! :>
by unknown on Jul 17, 2011 at 8:08am Add comment
A word of caution before you throw the printer out as I was about to do.......I finally found my Printers Preferences..Previously my printer had been saying the black needed changing so I did...again ..and again ( first time user of the cheaper ones so very wary thinking `you get what you pay for`)In the Pref window however it was displaying the blue as empty!!!! Moral? don`t believe the printer messages
by Jast on Aug 23, 2011 at 4:03am Add comment
I tried all the advice posted and in the finish i rolled up a piece of kleenex and wedged it behind the cartridges so it pushed them towards the contact point (the gold bit) and hey presto it started charging the ink and yippee it worked. I refuse to pay the extra cost of epson cartridges. I've had this printer for years and have never put epson cartridges into it and am not gonna start now.
by blatha on Sep 2, 2011 at 2:45am Add comment
I have tried everything all of the above. Nothing except (maybe) changing the chip...except the chip I am using is from my cartridge that had just run out... and when I put that in it says... the cartridge has run out. The chip must remember that the cartridge it was on has run out! I am using genuine Epsom cartridges, and when the get to about 1/2 full the printer no longer recognizes the cartridges.

Only use epson as I use linux, and Epson seems to work better than the rest under Linux (except for this issue). Will go CISS if I can get it to work.
by unknown on Sep 8, 2011 at 3:24am Add comment
I have tried all the above tips but the display still says the blue cartridge cannot be recognised. I can't exchange the chip because the old one is a different size. I am so frustrated and covered in ink - please help!
by lealaw on Sep 23, 2011 at 9:48am Add comment
Well, spent the last hour and a half trying all the suggestions on this forum.....cleaning contact points, with and without alcohol, removing and replacing cartridges, banging them in, banging the printer. Using genuine Epson cartridges and this is the first time this has happened and these are all new cartridges. I think I'm about ready to go the throwing it down the stairs and then heading off to Best Buy for a Canon or HP route.......
by bluangel on Sep 29, 2011 at 2:39pm Add comment
I have spent a frustrating time trying out all of the above suggestions to no avail. I think the idea of throwing it down the stairs is the best one at least it made me laugh hopefully lowering my blood pressure looks like it's a new printer for me also definately not Epson or Lexmark - I hear Kodak is supposed to be economical, any comments ?!
by unknown on Oct 10, 2011 at 10:59am Add comment
Tried everything.
Still no joy.
Cure:-Replace all the cartridges at the same time, regardless of contents or buy Epsom cartriges which, would you believe always work individually and first time.
Funny that.
Clever software.
Clever Epsom, too, 'cos people are still buying them by the hundreds.
by deemac on Oct 18, 2011 at 8:11am Add comment
had problems charging 'pro-jet' inks for my rx585.not recognised! tryed some old genuine epson ink and replaced with my unrecogniseable inks, and hey presto! all is fine again. printer must have reset itself when i put the epson inks in. hope this works for others as it has myself.
by jaikhay on Oct 30, 2011 at 12:53pm Add comment
This is the first epson printer that i've ever got and brought it on the recommendation that it was ideal for students because of its individual ink cartridges. It worked fine up until i had to change the black cartridge, put in a new epson cartridge and its telling me that the new one has less in than the one i'm replacing tried all itsthe suggestions here and its still not registering that its full.

Help i really can't afford a new printer, got any more suggestions?
by unknown on Nov 10, 2011 at 5:09am Add comment
Try another black cartridge? The one you installed could be damaged in some way perhaps.......
by unknown on Nov 10, 2011 at 5:55am Add comment
The printer reads the ink level off the chip on the cartridge. If this was an original Epson branded cartridge take it back to where you purchased it and have it replaced. If not an original Epson cartridge, anything goes. Hope this helps.
by unknown on Nov 12, 2011 at 2:50pm Add comment
This is an awesome page. THANKS! Rubbing the sensors down worked

So sad and telling that it isn't on Epson's own page. You use their products and they don't work, and they can't tell you why or even facilitate their customers saying what works--
by unknown on Jan 29, 2012 at 7:49am Add comment
I had tried ALL above fixes..I had refillable tanks as well.(only refilled black tho..then errors) .but had to remove ALL and reseated All then it worked perfectly
by unknown on Feb 9, 2012 at 7:40pm Add comment
rubbing the sensor on the printer didnt work ....frantically rubbed the cartridge sensor worked
by unknown on Jun 6, 2012 at 4:23am Add comment
epson stylus tx121 keep flashing the two red light and the green light is flashing
by unknown on Jun 6, 2012 at 4:31am Add comment
The printer's ink pads are at the end of their service life.
by zafurko on Jun 6, 2012 at 6:32pm Add comment

With the SX125 it was simple, I made the printer chip less
by unknown on Jul 24, 2012 at 4:40am Add comment
Hi to all.
My printer (Epson SX130) is just a few days old.
I've replaced the black ink a few days ago and in the first days it worked fine, but yesterday I've got the message " Black Ink Cartridge Not recognized". I've tried all the steps you've told about in the earlier posts and nothing (I didn't clean the head because I don't know how and I assume it is too earlier to clean the head because the printer is just a few days old).
I've noticed that the chip of this new ink cartridge is a little bit different then the other, though it is still a genuine Epson ink cartridge.
Any help please?
by ilion on Jul 29, 2012 at 5:07am Add comment
Tried cleaning contacts, repowering, etc to no avail. Still had "...cannot recognize.." on yellow and cyan. Called Epson tech support at (562) 276 4382, filled him in on hstory, and he said to violently shake the cartrige before re-inserting. First the yellow came back, then I had to re-shake the cyan, and it came back. I've had the printer since 2008, and it performs better than the HP's I've had. I think the key is having the direct number to tech support. There was no waiting at 11:00 am.
by mgzion on Sep 5, 2012 at 10:51am Add comment
Tried everything.
for one hour
Still did not recognize the original epson cartridges..BRAND NEW PRINTER,USED ONLY ONCE,TWO MONTHS AGO!CAN U BELIEVE???

My cure- one foot kick(it was enough everything got spread around),next step -straight to the garbage ben.Feel sorry I leave at the ground level and not 7th floor,but still,I feel allot better now!

by unknown on Sep 6, 2012 at 7:35am Add comment
epson sux, if the unit is under a year old, and you have proof of purchase, call Epson at 1-800-GOEPSON. They will replace it under warranty. Hope this helps.
by unknown on Sep 6, 2012 at 10:11am Add comment
Thanks to everyone for the advise, tried all the tips to no avail. Lost my temper after an hour and banged the top of the ink cartridges really quite hard and would you believe it problem solved.
by unknown on Oct 7, 2012 at 1:59pm Add comment
As silly as it sounds..... also make sure you have the correct ink cartridge. Some of the cartridges are physically interchangeable, but will cause these problems to happen.
by unknown on Dec 14, 2012 at 6:58am Add comment
Tried all the above on a NX515 with no luck; Cannon it is...
by unknown on Feb 24, 2013 at 11:04am Add comment
I have a weird problem: I installed a black ink cartridge T0481 (it's not an actual Epson cartridge, but I use them all the time and they've never given me a problem before) to my Epson RX620 printer. The printer registers the cartridge and says that it's reading it and whatnot, but when I go to print something in black...nothing. All the other colors work, and I tried changing out the cartridge for a fresh one, but the same thing happened. If anyone's even still paying attention to this thread, please help!!!
by unknown on Apr 12, 2013 at 1:08pm Add comment
The Black part of the printhead may be clogged. Try running a few cleaning cycles. If that does not work then buy a kit like this http://www.fixyourownprinter.com/kits/epson/K89 Heat the cleaning solution and follow the directiond.
by unknown on Apr 12, 2013 at 7:58pm Add comment
Try calling Epson tech support direct at (562) 276 4382. I was at wits end, and thought I tried everything. Their tech support really helped.
by mgzion on Apr 16, 2013 at 3:11pm Add comment
Nothing wotks.
drank the rest of the alcohol.
and went to bed
new printer
by unknown on Jun 20, 2013 at 3:46pm Add comment
It has worked after shaking the cartridges. thanks a million
by unknown on Jun 23, 2013 at 8:00pm Add comment

by unknown on Aug 17, 2013 at 5:53am Add comment
by DELPHIA on Aug 17, 2013 at 5:57am Add comment
Delphia...Don't recommend cleaning any manufacturers printhead with alcohol. It will dry out the rubber components in the head.
by unknown on Aug 17, 2013 at 9:40am Add comment
After I changed a cartridge, I received a message that none of the cartridges were recognised. I took the cartridge out, cleaned the gold contacts (I could see dirt on them), replaced it and then received the message that only the new cartridge was not recognised. I took the cartridge out again, re-cleaned the gold contacts, replaced it and then everything was ok.
The lessons of the episode are;
Only replace one cartridge at a time so you know which one is giving you trouble and, secondly, clean thoroughly!
by swhigg on Oct 19, 2013 at 7:24am Add comment
Hi there!

I had the same problem, 0805 (light cyan) cartridge wont be recognized.
After 5 mins of staring i see that one of the contacts broken on the printer head.
Because i was not able to solder the head (i did not try it, i now it is impossible) i soldered a piece of wire in the ink Cartridge. 2 minutes and it works fine.

Now i have to solder on every new 0805 cartridge a piece of wire, but never mind :D
by unknown on Mar 9, 2015 at 7:26am Add comment

Hd snapping the ink cartridges in better, as per other people's instructions, and no go. I got all frustrated, banged the printer's side, and reposed in and out the dang cartridges and nada. Got all pissy and told the printer to Proceed with low Levels. I clicked Print and then when the epson printer icon came on, I clicked on settings and Ink supply levels. In here, it said my YELLOW ink was low, and yet on my epson printer screen, it kept saying my black levels were low. wtf. i had an extra yellow as I hadn't changed it out with the cyan and blue and yep, all working now. geez. try your computer instead of the printer!!

by cdngirl71 on Jul 3, 2016 at 5:19pm Add comment

I have the same problem. With the first 2 printers it was the black ink. The next 2 it was colored ink. I have had no trouble with Epson printers in the past, but I'm getting very irritated with this model. If anyone else has a problem with this printer please let me know.

by narena on Sep 13, 2016 at 10:17am Add comment