asked Feb 7, 2008 at 3:30pm
Epson Epson Stylus Photo R280

Epson Stylus Photo R280

Hello Im new and am glad I found you guys. Im hoping one of you wise people can help me.

Ive got 2 of the Epson Stylus Photo R280's. Recently I got this "Cover is Open" error message when I tried to printon one of them. The cover is not open, the cartridge cover is not open, and the little tab is not broken. Ive been going nuts trying to figure it out. Ive looked over the printer latch on the working printer and it looks fine. Someone told me that there is a sensor I need to look for. I went to the UK site that you guys were talking about to find a repair manual but they didnt have my model so I went with the closest model the R285 and they didnt mention anything about the cover open sensor problem.

Is there anyone who can help me with this problem, what do I need to look for, where can I buy parts? This is a great printer otherwise, it prints really fantastic on my cd's.

I thank you all for any advice you can shoot my way.

I too am having the same problem with a new out of the box r280. Whenever I print it loads the paper and then stops, with the power light flashing and the two orange lights also flashing, although at twice the pace the power light flashes. I of course emailed epson support and of course have not heard back yet. I've tried everything from unistalling drivers and reinstalling and using/not using my usb hub, etc. When I run the printers test function not connected to the computer all it prints on the page is "PU2477 QP100653" Does this code mean anything to anyone or anyone have an idea where to look it up?
Thanks in advance!
by unknown on Jul 15, 2008 at 2:19pm Add comment
I have exactly the problem described with my brand new R280 - no printing, but two orange lights flashing. Does anyone have a solution?
by epsonstylus on Sep 5, 2008 at 4:21pm Add comment
I have exactly the problem described with my brand new R280 - no printing, but two orange lights flashing. Does anyone have a solution?
by epsonstylus on Sep 5, 2008 at 4:38pm Add comment
Silly question time. One of my customers brought one to me with these symptoms under warranty. Did you put the cartridges in? He got to this step during setup and thought that the lights were a problem, so he didn't put them in. When I did (following the directions) the printer came to ready.
by MMurray on Sep 5, 2008 at 6:33pm Add comment
I bought the Epson R280 about three weeks ago and when I hooked it up I had green light and then tried to print. Nothing two red lights flashing, the print carriage was trying to move but wouldn't, I called Epson tech. support. (562) 276-7282 and when I explained the problem they said they would send me another one. Well I got that one a week ago and hooked it up yestoday and guess what HaHa the same problem so I called Epson Tech. and explained the problem and they are sending me another one and they told me to keep the other ones. Now that will give me three Epson R280's and I hope the next one works.
I believe Epson has found out that they have a series of printers that a percentage of that series has a problem and the cheepest way for them to fix it is give the customers a new one.And if I am right and there is only so many in the series having this problem then it would make sense to just ship a new one.
Wish me luck and I will do the same for you guys.
PS Call Epson and get a new one.
by unknown on Sep 14, 2008 at 6:34pm Add comment
Sounds familiar! I called tech support Saturday, and they told me the same thing. I'll be frustrated if I get another one that doesn't work, but hopefully we'll get more ink cartridges. Then if we eventually do get one that works, at least we'll be stocked with ink. Of course that's where they make their money, so maybe they'll deprive us of even that perk for our trouble.
by epsonstylus on Sep 15, 2008 at 5:10pm Add comment
The solution to your problem is quite simple. You have to open the printer by taking out all of the retaining screws that hold the top cover in place. (Not difficult) Don't force it. If the cover does not come off easily, you have missed a screw. Once it is off, you will see that there is a wire and plug beside the "cover open" sensor, which is the slot beside the left side retaining screw. On my printer, it was unplugged. Push it in until it clicks firmly into place, and re-install the top cover. Re-start the printer, and off you go. If the printer cartridge carrier refuses to align itself with the opening, press the ink button until it is in the right position. (It moves a couple of centimetres each time the button is pressed.) Finally, DO NOT TURN THIS PRINTER OFF!!! Every time the printer is re-started, it cleans the heads, which wastes ink, and this printer drinks ink like it is cheap wine. If you keep it on, it does not do the self-cleaning ritual, and mine has printed excellent prints for qutie a while, even though I am still on the original cartridges.
by Anonymous on Sep 28, 2008 at 8:08pm Add comment
Dood, you are a flippin GENIUS. That worked like a charm! - Anonymous
Thank you very much !
It has worked beautifully !!! - Anonymous
Thank you Anon! That fixed the vexing problem from hell! Sure enough, the little connector was not fully seated in its socket! I just pushed it in, and Voilá! C'est finis! You rock! - steelydeacon
I only found one screw to take off and the cover doesn't budge.Any more suggestions. I am open to suggestions. - unknown
My R280 printer died after 6 days of use. Will not turn on. Called Espon support, and they are sending a new printer. But, now, what do I do with a printer which will not turn on??? Parts? Boat anchor?
by unknown on Sep 30, 2008 at 8:49am Add comment
Source of very expensive cartridges. - Anonymous
I had a similar with my brand new R280 that I got today. I installed a continuous ink system (CIS) and when I tried to print, I received the error message that the cover needed to be lowered into the proper position. This is not possible due to the tubing for the CIS system. In looking at the printer, there is a tab in the lid that drops into a slot on the body of the printer. I stuffed some kleenex (with sufficient force to push the switch down) into the hole and now it prints just fine - even with the lid not fully engaged. Hope this helps as one way to solve the problem.
by Anonymous on Oct 30, 2008 at 7:56pm Add comment
thanks it worked - Anonymous
removing the lid worked perfect. and opening up my printer is a lot more fun than waiting a couple of hours on tech support, and a couple of days for a new one. thanks!
by unknown on Nov 3, 2008 at 9:40am Add comment
Brand new machine. The ink head does not move far enough to the left to load the initial cartidges. Nothing looks blocked, but the head only moves about an inch to the left, not enough to free the lid. I found 3 screws to remove the cover, but must be another that I am not finding. Any suggestions?????
by unknown on Dec 28, 2008 at 8:10am Add comment
I just turned on my machine for the first time about 3-4 weeks ago and then when I went to use it, a few days ago print it showed the yellow cartridge was out of ink even though it was never used and it seems like it still has ink in it(I shake it and can hear liquid and it still is wet at bottom of cartridge). I called epson they are sending me new cartridges but I don't think this is the problem since all of you are having the same problem! Can I reset the printer to recognize the one that's in the machine, can I refill the cartridge, is there a way to reset the chip if it has one, that has been tripped so to speak. this printer I got over a year ago and so it's out of warranty but is brand new. Also how do you hook up continous feed inking?
by unknown on Mar 9, 2009 at 9:26pm Add comment
Had the printer for just 3 months. Today tried to print on CD for the 1st. time. The CD tray went in then came out then the red/amber lights started to flash. Took CD tray out, lowered the paper tray, turned off, turned on, started to sound like it was going to work then heard a clunk from the ink cart. holder then lights started to flash. The ink cart. holder does not move it stays to the right.

Any help would be great! Thanks
by hlthnut on Mar 17, 2009 at 1:40pm Add comment
I'm also having problems with the CD/DVD printing I have gone with the default settings and also tried adjusting the settings from the Epson printing program but I get the same thing over and over - it only prints 1/4 of the image on about 1/4 of the disk - It is also printing on my plastic tray - Please help it is so frustrating
Dave - Anonymous
just got my printer and i did how the book said hit the ink button and well it wont go off anyone help
by Anonymous on Apr 9, 2009 at 5:08pm Add comment
Just got my new r280 and for some reason windows xp won't recognize it! usb ports work fine with everything else. Does anyone have a clue to what's going on? Thanks
by Anonymous on Apr 10, 2009 at 8:00am Add comment
Suggest getting a replacement CD tray. If they warp or get dirty, the printer can't read them properly.
Hope this helps.
by Anonymous on Apr 24, 2009 at 12:09pm Add comment
I just bought the R280 for sublimation printing. I printed out on puzzle and the color was poor. I cant get it to print any color but black. The cartridges are all full. Does anyone have any ideas?

Thank you.
by rufflesandlacecountr on May 3, 2009 at 1:58pm Add comment
You might double check that grayscale isn't checked on the printing preferences (advanced tab). - Anonymous
I just purchased A R280 to replace my R260. I'm trying to use the refillable cartridges from my R260 but the R280 will not recognize them. I planned on selling the Epson cartridges on ebay as I can probably sell them for more than I paid for the printer(30 brand new). I thought the refillables would work because they are the 2nd generation chips which are supposed to work with the newer models. And when purchased they were advertised to work for both models + a few others.
Any Suggestions?
by unknown on Jun 30, 2009 at 10:05pm Add comment
my does not work for anything. it wont connect and keeps sat error brand new
by Anonymous on Jul 8, 2009 at 2:10pm Add comment
I need to remove the cover on this R280 to fix the paper feed but can only find three of the screws that hold the cover in place. Please someone tell me where I can find the screw that holds the right front part of the cover in place.
by cuidate on Jul 10, 2009 at 11:28am Add comment
If you bow the cover by pushing in the center it will pop right out, but it takes a fair amount of pressure. - Anonymous
first off you should not force or bow the thing as that is not required. unlike the 3 outside screws the elusive 4th screw is inside under the cover. it is tinier than the others and labeled L4. once removed the whole top will slide off with NO FORCE.

i had the blinking two orange lights like people have reported. but for me the fix was not plugging back in the "cover off" cable. upon removing the top all the cables were secured just fine. it seemed to me the head was simply "jammed". having recently gone through a move i suspect the printer was probably dropped on its side and the head had lodged a bit too tight.

i was able to free it by gently giving it a nudge and that solved my two blinking lights problem. in the end i probably didnt even need to take the top cover off. - Anonymous
I have an Epson Sylus Photo R280 which I use almost exclusively to label CDs.
I just changed out the yellow and black cartridges.
The machine has accepted the yellow cartridge but is still saying that no new black cartridge has been inserted.

Any suggestion as to why and what I can do to fix this problem?

by dougcanipe on Feb 26, 2010 at 11:24am Add comment
I have a blinking orange light alternatelty.before it happened, and before it run out of ink it send a message saying that the parts has reached its life expectancy and must be serviced.Its only 1 year old and used rarely..any clue????.
by unknown on Mar 28, 2010 at 6:58pm Add comment
Where is the 4th screw? I found two on the outside, one on the inside under the front cover. Where is the 4th screw? Thanks!
by Anonymous on Apr 9, 2010 at 5:35pm Add comment
the 4th screw is inside.. under the front cover but in the rightmost just infront of the ink catridge assy. inside the is smaller in size compared to the three. - Anonymous
I jsut added black ink to my r280 but all it is doing is printing in a pale pink. Got any ideas??
by Anonymous on Apr 19, 2010 at 10:19am Add comment
The print head is clogged. You need to flush the print head of dried ink. Get a kit like this
by Anonymous on Apr 19, 2010 at 12:27pm Add comment
My Epson R280 was working just fine. My 1 year daughter pulled one of the thin black strings under the cover and it came out from one end; Can you tell me how do i hook it back; it came out from the left end of the printer.
by unknown on Apr 24, 2010 at 9:35am Add comment
I was replacing the cyan ink cartridge on my Epson R280, when I pushed the ink reset button it slid over to the right and stopped. Can't get it to reset . I am using a Macintosh. Please advise.

Myka Jelina
by mika jelina on May 24, 2010 at 6:11am Add comment
How do I fix the paper feed!!!??? I was printing and the 2 orange blinking lights came on. I cleared all paper and turned the printer off. I left it off for a while. When I turn it on the two lights return and the paper feed seems stuck. Help!!!!
by Jdozier on Jun 10, 2010 at 7:59am Add comment
I pulled a jammed paper out of my R260 —didn't read the jam instructions. Yes, I got the "chuck, chuck" sound of the printer trying to feed. Tried the top removal, but quit before finding the final screw. Voila! I reset the lever to CD print, then back again, and the thing worked! I realize this might not work for all. - designer_js
This may help: There is a metal plate that is supposed to be secured to the output feeder by some metal flanges, but often it can come loose or may not have been secured at the factory. The plate is merely clipped on to the output feeder with some metal flanges that are pressed out from the plate itself and then bent into position as clips. Remove the top cover screws and remove the top cover itself. Then see if the metal plate over the output feeder is loose. If it is, just press it down and toward the front of the printer until it is securely fastened to the output feeder assembly. If the plate is loose, it will move independently from the feeder assembly and have a tendency to block the path of the printhead assembly, which gives a "General Error." Good luck. - steelydeacon
My r280 has worked well for over a year, but now each time I reboot the PC I have to re-install the drivers. I have downloaded the latest drivers and used the Epson un-install but still have the problem. I am running Windows XP.

Thanks for your help.
by laserjerry on Jun 10, 2010 at 11:30am Add comment
I was getting lines in print outs so I did the maintenance to align the heads and the lines continued to get worse and silly me kept trying to align them not its like having double vision. I tried unplugging to see if that would fix, I clicked default settings, nothing. Now I am looking at having to by another printer unless you can tell me how to fix it.
by Spirits on Jan 14, 2011 at 11:36am Add comment
Hello everyone I just bought a brand new epson r280 and I never used it before the red ink light does not go Off and the power light blinks I tried it all the ink cartridge is brand new came with the printer what do I do....?????
by unknown on Mar 8, 2011 at 5:45pm Add comment
Return it.
by philly5706 on Mar 12, 2011 at 7:21pm Add comment

i have an epson r280 that will not recognize all my ink cartridges .. i have the ink cartridges that have the tubes and container on the side ... need help asap pleaseeee
by unknown on Aug 30, 2011 at 10:43am Add comment
My Epson R280 printed out quite a number of beautiful prints. Now there are big areas of magenta. It's as if it's printing magenta instead of black. And the magenta is all mottled. I have cleaned the heads quite a few times. I hate to keep doing that because it takes ink to clean the heads and this printer DRINKS ink like crazy. Any suggestions? Thanks. AMc
by AMcView on Sep 4, 2011 at 10:49am Add comment
How do you get the top cover off? I found the four screws and the cover lifts up but it won't come off bc of the paper feed.

I have the two flashing orange lights (one for ink, one for paper). I'm trying to set up the printer for the first time (but it's out of warranty bc I bought it a while ago and don't have the receipt). At first, the ink cartridge holder wouldn't move past the left side but, by lifting it from below, I was able to slide it over to the left. It moves freely in both directions now.

When I turned the power back on, the cartridge holder was in the right place and I installed all the cartridges. I got the two orange lights again but pressed the ink button for several seconds (as per the instructions on the Start Here guide). Nothing happened. Technical support was useless. They just had me unplug the printer and plug it in or push the ink button about twenty times.

I got the cover off far enough to make sure that the cover sensor was properly plugged in and that the metal bar over the output feeder was not loose. The sensor was plugged in and the bar was securely in place. Any suggestions?

by anon1 on Sep 21, 2011 at 2:43pm Add comment
Yes my R-280 is from years gone by but I can not part with it because it prints a great face on DVD,s
. However it drives me crazy, My dvd tray appears in good condition as I got it new right out of the box with said printer. Approx 50\% of the time it will kick the DVD tray out and request I reset the DVD tray and push the paper button. I may have to do that 2/3 times for it to print. That is a lot of waisted time when printing a dozen different faces. I did see a nice utube video on the best epson repairs. It all looked fairly professional until he unplugs the printer,takes the unit out doors and drops a very large bolder on the printer and he proudly says NOW IT IS FIXED FOR GOOD. Any better ideas than that would be appreciated.

Thanks in advance...
by unknown on May 4, 2014 at 8:52pm Add comment