asked Feb 7, 2007 at 8:21am
Unknown Printer

Samsung CLP-510 How to reset counters (also belt)

I bought an old CLP-510 for $10, which literally had all counters full. I reset it all within 1 hour and now have free copies until the printer really dies...

Here a comprehensive guide how to reset all counters in the Samsung CLP-510:
Toner image counter, imaging unit, fuser, transfer roller, transfer belt. All you need is 3 pieces of wire!

Thanks goes to PCRMike and Dunfield - they are the heroes who enabled this all.

1) Resetting toner chips:
Use the SSEBR Chip resetting program on You need a PC with an LPT-Port, a DOS-boot disk, his DOS-program and 3 small wires.
He also has instructions for the waste toner bin. (There are various posts on that topic.)

2) Resetting belt chip: Also use the SSEBR Chip program, it is the same 24C04 IC as used by the toner. Looking at the bottom of the belt cartridge, connectors facing you, here are the relevant pins on the oval connector:

On the bottom left is the cut off corner of the black connector plate - just so that you are holding it right. ;-)

Connect the cables as follows:
A = Data = LPT pin 16
B = Clock = LPT pin 17
C = Ground = LPT pins 20-25 (any of these pins)

First backup the chip with the option “SSEBR /B belt”.
Then reset with the option “SSEBR /Z”

3) Resetting the imaging unit, fuser and all rollers:

Start up the machine with push in the buttons "online" and "cancel"
--You will see the message "Download mode press online key"
Press about 15 times the "menu" key
--You will see the message "Uncheck consumable mode"
Press about 15 times "menu" and 5 times "enter"
--You will see "Press access key"
Press a few enters
Press 3 times "cancel"
Go to the EDC mode
-- you will see "press access key"
Press "cancel"
Go to maintenance and initialize the parts you like to reset.
(sometimes you have to try a few times; don't wait to long in between the steps!)

BUT, hey guys & gals, no guarantee. It worked great for me, but try it at your own risk.

And once again a special thanks to PCRMike and his invaluable input in this forum.
hi you have 2 different steps it looks like, 1 and 2 are ok but step 3 is different can you do step 3 without having to do step 1 and 2 as step 3 is resetting the cartridges in the printer software and not on the program
i take it

by comet240 on Feb 14, 2007 at 11:16am Add comment
To reset the Transfer Belt the Pin from the left (in Your example a b c D needs 5v+,
then it will work very fine, but i made from a new belt a backup and restored it to the old, didnt use the Z- (zero) function.
Also samsung SCX4200 and MC2150 needs 5V Power on the forth pin.
by berthub on Feb 14, 2008 at 2:01pm Add comment
maybe read it wrong i guess the roller isnt the cartrige? so u still need to reset the cartrige plus the other stuff

i figured it only had imagining unit and transfer belt to reset also

oh i hate this printer lol
by comet240 on Feb 14, 2007 at 12:21pm Add comment
Yes, each step 1-3 can be done individually.
You can reset the toners, the belt, etc. individually.
After one month I still have free prints from a "junk" printer. :-))
by unknown on Mar 10, 2007 at 1:34am Add comment
I just tried resetting the Transfer belt to 0 with the SSEBR program and it failed.

Now it will not backup the Eprom... Says it failed also... Looks like it may have corrupted it...

No big loss as the printer won't work with the current belt anyways... Says to replace it...
by unknown on Mar 23, 2007 at 11:29am Add comment
No need to replace the belt, if only the counter is "full", as long as the belt is still fine.(Unless you want to go safe ...)
I can send you the backup of mine, in original condition (counters were full), before I reset it.
by unknown on Mar 25, 2007 at 12:44pm Add comment
Can you email me that belt backup file? I've used the backup and restore procedures many times on the toner cartrages with great success, but just now found the answere for the transfer belt! But of course my chip is already maxed out so nothing to restore from. - Anonymous
I had backed up the Eprom before I tried to reset the counter so I have a good image...

I tried restoring the backup and it failed also... Everything I tried said failed.... So I reset the counters on all the toners and turned the system on to see if the toner resets worked and it no longer says to replace belt... Printed a test page without any problems...

My best guess is the eprom got corrupted and when I put it back in the printer it reset the eprom back to default....

At this point everything seems to be working as intended... I appreciate the help.
by unknown on Mar 25, 2007 at 1:24pm Add comment
>"My best guess is the eprom got corrupted and when
> I put it back in the printer it reset the eprom
> back to default...."

I can confirm this behaviour. I also usen SSEBR to turn Transfer Belt counter to zero, and after that I got "Invalid Transfer belt" message.

I tried to restore the file I had taken before starting this zeroing operation. Looks like restoring ended prematurely, reporting something at the third phase. Also CLP was not satisfied but gave exactly the same error message.

I tried for a couple of time to get to the printer's Maintenance Menu by holding "online" and "cancel" buttons when powering on. The "Invalid Transfer belt" message was always faster and prevented me to get to the Maintenance Menu.

I powered off several times, and even plugged the main power cord off, and tried again. Finally..., after some more tries I got through to the Maintenance menu. There I first Printed Test page out to see if it prints anything, and it did.

After I closed Maintenance menu, the CLP-510 printer again prints OK. The original "Replace Transfer Belt Soon" message was gone also.

As someone else already said before, I also hate and I love this Samsung color printer:)
-m- - Anonymous
Hello, I need help with a new transfer belt I purchased from a seller on eBay. I did not need it right away, so I kept it in storage for about 4 months. When I tried to use it recently, the printer does not recognize it at all. After I closed the printer and turned it on, the initialize process ended with a message "Install Transfer Belt". Apparently the printer does not see the new belt at all. Is there anything I can do to fix this? I tried the supplier but have not received a reply from them.

Thanks in advance!

by LeeG on Jul 3, 2007 at 12:26pm Add comment
Id like to ask if anyone could pleasesend me the file to reload on the Belt since mine is out and i dont have the "unused" version of that file... thank you very much in advance


email [email protected]
by unknown on Oct 16, 2007 at 7:31am Add comment
you don't need the original file, you can just reset the counter to zero! worked great for me!! just use the ssebr program.
by Anonymous on Oct 16, 2007 at 9:34am Add comment
I used the ssebr program to try to reset it, tho it didnt go very well, now the machine presents the error "Invalid Transfer Belt"...
I tried to reset it in another computer tho no sucess, i guess the eprom got corrupted the first time i tried to reset.
I dont have any usable Backup to reprogram the Eprom, thats why i would kindly ask if anyone has one i can use to please mail it to me...

Thanks in advance

[email protected]
by unknown on Oct 17, 2007 at 10:40am Add comment
Hi everybody,
Does anybody have the map of EEPROM? I have the proffesional programer for this types of EEPROMs, so I need to know on which addresses is stored the counter.

Thanks and best regards,
by unknown on Oct 27, 2007 at 2:11pm Add comment

i've found a way, to read out the eeprom under WinXP, but all i can see are FF`s. I dont have a new toner at the moment, to compare wheres the drifferences, so please could anyone tell me the adress where i have to change the values and towhat i have to change it.

by Anonymous on Nov 10, 2007 at 2:10am Add comment
What utility are you using in XP to read your EEPROM?
- Anonymous
The EEPROMs have configurable address. Up to 4 EEPROMs can share 1 I2C bus. If you wrong address the EEPROM you will read FFs.

Rius - Anonymous

i've encountered a slight problem with the belt reset. Toner resets work without a problem. Belt reset gave me "invalid transfer belt". I suppose my eeprom is currupted because my backup doesn't work either. Could one of you guys send me a copy of their belt backup to my email address [email protected] . I would be very grateful.



by unknown on Nov 29, 2007 at 4:10am Add comment
Could anyone send me good backup of transfer belt

kind regards
by unknown on Jan 28, 2008 at 1:45am Add comment
A while back, I bought a new Xerox 6100 transfer belt, which is compatible with the CLP-510. It works fine except that I need to reset things every time I use it. I also have an old belt that produces very faded images. Has anyone tried to switch the id from one to the other, to eliminate the need to reset?
joncris [email protected]
by joncris on Feb 13, 2008 at 1:27pm Add comment

Thanks for the advice. Unfortunately, I can't understand it. If it involves resetting eproms, I have never done it, and don't know what equipment would be required.

by joncris on Feb 14, 2008 at 3:35pm Add comment
Could anyone send me good backup of transfer belt


by zse on Feb 15, 2008 at 6:38am Add comment
Could anyone send me a good backup of the transfer belt.
[email protected]
by makoshark on Mar 26, 2008 at 9:47pm Add comment
I had also problems with resetting the transfer belt; the printer gave "Invalid transfer belt" message.
BUT, start up with:
Start up the machine while pushing the buttons "online" and "cancel"
--You will see the message "Download mode press online key"
Press about 15 times the "menu" key, until
--You will see the message "Uncheck consumable mode"
by Anonymous on Apr 4, 2008 at 1:14pm Add comment
Thanks to eBay, after cannibalizing 4 units and supplementing them with odd parts, I have three good working printers. However, one of the file transfer belts [aka image transfer units] started producing fading print, and needed replacement. The housings look good and straightforward to dis-assemble and re-assemble. Is there a source for just the belts themselves, NOT the entire units? [The usual unit price is $130 - $270; I bought some used ones on eBay for less.]
Based on other high-priced consumables, I'm not optimistic.
by joncris on Jun 10, 2008 at 10:22am Add comment
The Dunefield fix procedure does work!

I was able to reset the counters for all 4 of my toner cartridges.

It is important to pay meticulous attention to the directions, though. The thing that took me the longest was to find an old computer that has 5volt pins for the printer parallel port. I had to use an old computer from about 1999. If the pin voltages of your printer port are 3.3v as they are for most modern computers, then the reset procedure won't work.

Mr Dunefield has done an excellent job documenting his fix! Thank you. I found the diagnostic program very handy.

I also tried the tape over the pin solution. It didn't work for me. I was only able to print 1 or 2 pages and then I would have to turn the printer off and on to get it to print again.

Buying new chips or special hardware to reset the chip counters may also work, but I haven't tried them.
by wmhalpin on Jun 15, 2008 at 5:03pm Add comment
hi all how do i get to resetting the t-belt,is there only 1 way to do it, it seems that it is now discontinued
by mrkay on Jun 26, 2008 at 3:28am Add comment
To reset belt (and toner cartidges) You can use a reset chip aviable from instead of the DOS program and printercable. I used about 5 min to reset my transfer belt. Just notice wiring diagram posted earlier in this thred, pin 2 an 3 are connected different on the cartrigde than the transferbelt.
Therfor connect PIN 1 on reset chip to PIN A on trasfer belt, PIN2=C PIN3=B
by unknown on Sep 15, 2008 at 12:58am Add comment
By the way, I did not have small enough clamps to get my three SSEBR cables connected to those tiny Transfer Belt connection pins.

I finally carved a suitable size plug out of wood. Then drilled totally 6 holes with 0.5 mm drill, and threaded steel wires through those holes. Three of those holes were not needed for connection, but they acted as cable clamps:)

It took about 2 hours total, but finally my wooden connector was ready and I got the work done.
by Anonymous on Oct 24, 2008 at 6:31am Add comment
When resetting the toner eproms, they get their VCC from the CLK signal of your programming cable, so no problem here.
When resetting the transfer belt eprom, there is no such provision, you must provide 5v to the 4th pin on the oval connector or else you end up with the 'Invalid Transfer Belt' message that many here on the forum are getting. You can use the 5V from a spare hard drive power connector inside your computer.
On the eproms themselves, the WE line is not connected, this will pull that line low by default, thus allowing writes to the eprom. By tying that line high, writes are disabled, so that means the printer cannot update the eprom with new page use data, it will be set at 0, or whatever number of pages it contained before being tied high >>FOREVER<< (or forty years, which is the estimated data retention life according to manufacturers of the eprom). This means you reset it, tie the WE line high, and NEVER have to worry about toner and transfer belt page counts again(or at least for 40 years).
by rohmell on Dec 18, 2008 at 1:30pm Add comment
An easy way to connect to the transfer belt for programming purposes it to remove the 5 screws holding the black connector and plate to the TB unit (2 screws on the black connector, 3 screws on the plate)
On the rear of the black connector is a white connector that plugs into the black connector. These can be disconnected from one another. If you remove this white connector, you can now easily connect your programmer leads into the white connector's holes using straightened out paper clips.

NOTE You MUST have 5 volts on the 4th pin in order to properly backup, restore and zero your eprom, otherwise you will have the 'Invalid transfer belt' error message when done.
If you get this message, and need to print simply:
1. power off the printer.
2. power on the printer, then quickly press and hold the MENU button for 5 secs until you see the display say UNCHECK CONSUMABLE MODE.
3. release the MENU button and the printer will start up normally and you will be able to print.
Unfortunately, you will have to do this each time you power up the printer.
A hardware solution to this problem is to add a circuit that will apply a short to the MENU contacts of the front panel switch for 5-10 seconds after power up. Use a small relay or mosfet to perform the shorting function, along with a 555 timer or UJT for the timing circuit.
If you want a software solution, you need to get a good valid backup of the eprom that was obtained using the 4 wire method (5V line in addition to clk, data and gnd)
Unfortunately I originally used the 3 wire method, so I have corrupt eprom images for the transfer belt, and cannot do further research and analysis.
If anyone can do a backup of a transfer belt eprom using the 4 wire method, please email it to me so that I can do further research and refinements of this methodology -> [email protected]

by rohmell on Dec 18, 2008 at 3:48pm Add comment
After some investigation and analysis, I have come up with the file for zeroing the transfer belt counter.
If you have corrupted your eprom using the 3-wire method, you will need the 4-wire method to restore your transfer belt eprom correctly.
If you need this file, email me > [email protected]
by rohmell on Dec 20, 2008 at 1:39pm Add comment
Hey I need the transfer belt file, I messed mine up!

Could anyone email that to me at

[email protected]

PS: thanks in advance my job depends on it.
by unknown on May 7, 2009 at 2:20pm Add comment
Does anyone have a good backup file for the belt? I got the "replace transfer belt" error. I tried using the "Z" command with several desktops but they all failed. Now I get a "invalid transfer belt" error.

Thanks Randy
by Anonymous on May 31, 2009 at 9:41am Add comment
This metode works with Samsung CLP-310 ?
Does anyone try it ?
Does anyone have a good backup file for the belt ?
by unknown on Jul 30, 2009 at 10:12am Add comment
Have been getting tons of emails as to the four wire method, so here it is:

Looking at the bottom of the belt cartridge, connectors facing you, here are the relevant pins on the oval connector:

On the bottom left is the cut off corner of the black connector plate - just so that you are holding it right. ;-)

Connect the cables as follows:
A = Data = LPT pin 16
B = Clock = LPT pin 17
C = Ground = LPT pins 20-25 (any of these pins
D = +5 Vdc = Obtained from floppy/HD drive connector or USB port.
by rohmell on Sep 7, 2009 at 5:41am Add comment
Ok trying to understand your 4-wire setup...

On D you said it had to be connected to the 4th pin... Is that the 4th pin from a particular side or pin number 4??

Want to give this a try and need to wire it correctly...

Thx for the help.
- Anonymous
Sorry NM on the last post... I misunderstood what wires were hooked up where...

The D is on the transfer belt and not on the 25 pin printer port... 5v can come straight from the power supply to the 4th pin on the transfer belt and then flash the eeprom...

I appreciate the file and help Rohmell...

by Anonymous on Sep 7, 2009 at 6:14pm Add comment
Ok I got it all hooked up like Rohmell detailed and it worked perfectly... Transfer belt images is now 0... Complete reset and no invalid transfer belt any more...

Ask Rohmell for the good image to restore the eeprom if you have the invalid transfer belt message...

One thing I learned... If you set up the 4-wire system as Rohmell details and you get a "failed!" message after flashing make sure the +5v on the 4th pin is getting through... The first couple of trys I had the failed message and it didn't work...

by unknown on Sep 7, 2009 at 7:26pm Add comment
got bad break n got failed on reseting transfer belt can
I need the transfer belt file, Could anyone email that to me at

[email protected]

PS: thanks in advance...
by eggieph on Dec 4, 2009 at 10:09pm Add comment
Please could somebody send me a working file for the transfer belt as im trying to reset mine but dont have a file saved from when it was working

please send it to cdownes(at)

Many thanks Chris
by unknown on Oct 21, 2010 at 6:45am Add comment
Will this work to reset the cartridges in any other Samsung printers, specifically a CLP620??

by JoBo on Jan 12, 2011 at 3:49pm Add comment
To reset the transfer roller counters etc you require the hidden maintenance menu.

Turn off the unit, hold down enter and turn on. Hit enter when it says EDC mode. Access key is cancel 2x's, menu to maintenance, enter, scroll to imaging unit or transfer roller, enter, when it says initialized turn off and back on.
This is the reset you are looking for.

Invaluable help from
by unknown on Jan 15, 2012 at 11:28am Add comment