asked Jan 4, 2006 at 9:03am
Hp HP Color LaserJet 4650

Hp color laserjet 4650 Card problems

hey guys... I got a prob with my Hp clj4650... It tell's me that the cardslot isn't initialized.... So what can i do to fix it... As i heard i need some kinda pincode but i can't find it anywhere... Please help me..... Thanx....
You need to go through the procedure to initialize the hard drive, even though you don't have a hard drive installed...

I found it hard to believe too, but it works.

To initialize the hard disk:

1 Turn the printer on.

2 As the printer performs its power-on sequence, press and hold the PAUSE/RESUME (HP Color LaserJet 4600 models) or MENU (HP Color LaserJet 4610n and 4650 models) button until all three lights on the control panel are lit.

3 Press the left arrow button The message INITIALIZE DISK appears on the control-panel display.

4 Press the check mark button, the printer initializes the hard disk and continues its power-on sequence.

The card slot not initialized message should now be gone.
by Stephen on Jan 5, 2006 at 6:59pm Add comment
Perfect fix, you really know your stuff. Thanks again. - Anonymous
Thanks, that worked great.
Jan - Anonymous
Hi. I followed the steps you gave for initializing card on hp 4650. That seemed to have happened, but I send a page to print and nothing happens. Any clue?

Thanks - unknown
Steven you saved the day for Moe. He had one on-site, called me and I looked up your post which I saw before and had Moe do the routine. Printer fixed. Good job Steven.
by dmzcompute on Apr 17, 2006 at 12:55pm Add comment
Many thanks Stephen, I gave you a point as well.
by moe on Apr 17, 2006 at 1:42pm Add comment
Your welcome.
by Stephen on Apr 17, 2006 at 7:59pm Add comment
It didnt work on my 4650. I hold the check just after I turn it on. It gives me all three lights, but wont respond to any of the buttons, except the green check which makes it continue to boot. Any ideas?
by unknown on Apr 9, 2007 at 1:31pm Add comment
If it's a 4650 did I say to hold the checkmark?

Please read more carefully...
by Stephen on Apr 9, 2007 at 5:12pm Add comment
On a 4650, I hold the 'menu button' at printer startup,
when I got 3 lights-on I press the left (back) arrow button
but nothing appears on the display. Printer pass calculating memory size, starts up normaly and displays the error message.
thanks - Anonymous
On a 4650, press&hold the 'menu button' when the memory count starts..
thanks again
by Anonymous on Nov 1, 2007 at 9:13am Add comment

Thank you, I was able to remove the "cardslot isn't initialized" message.
by unknown on Jan 3, 2008 at 11:07am Add comment
Printer lcd message was alternating between "Ready" and "Card slot not initializing". Error is now gone, thanks.
by Anonymous on Mar 14, 2008 at 6:31am Add comment
The fix submitted by Stephen wasn't working until I read the anonymous posting from 11/1/07 @ 9:13 a.m. Power on and wait until the memory count starts. You will get three lights. Follow Stephen's instructions and the error message will disappear.

Thanks to all!
by Anonymous on Mar 14, 2008 at 11:00am Add comment
Thsi was great help...
Thanks You!
by Anonymous on Jun 11, 2008 at 2:41pm Add comment
Worked like a charm. You do have to wait until the memory starts counting on a 4650, other than that it was easy. Thanks
by jeffsno1 on Aug 20, 2008 at 2:29am Add comment
by Anonymous on Mar 11, 2009 at 1:18pm Add comment
Great fix!! Thanx for the help!!
by Anonymous on Jun 22, 2009 at 1:21pm Add comment
Did you make any other attempts at fixing the 4650 before you folled the correct procedure?

If you did a cold reset you probably need to reconfigure the network card.
by Stephen on Jul 3, 2009 at 4:57pm Add comment