Tom Bl

asked Dec 29, 2010 at 3:44pm
Hp HP LaserJet 2200DN

HP Laserjet 2200DN reports LAN Error

This HP Laserjet 2200DN reports a LAN Error.

The test page printed says "I/O card not ready", LAN ERROR - LOSS OF CARRIER" and "Port Config: Disconnected" It does show the model number of 610n card as J4169A. There is a hardware address and firmware version listed, but no IP address. The TCP/IP Status says "Initializing"

So it appears the 610n is dead. Is there a way to get it going again?
Do a search for baking the board. It works if cold solder joints of the main processor are the cause. One thing is look at the back of the card and see if any of the lights are on. I have seen a few where the contacts inside the rj45 jack go bad or are malformed so there is no communication between the printer and the switch.
by dmzcompute on Dec 29, 2010 at 6:13pm Add comment
I may be on to something here, but the instructions I have from HP do not appear to cover this situation.

The LEDs on the 610n were not lit. I disconnected the cable to the 610n and the CAT cable to the computer that was connected to the router. I connected a new CAT cable directly from the computer to the 610n. The LEDs on both the computer and the 610n now light up. Next I printed a test page. It now reports an IP address - the same one as when everything worked OK before. It also reports "Status: I/O card ready." I next tried to get the PC to find the printer. I tried to browse to http://(__ip_address_)/ which worked before, but there was no response ("Internet Explorer cannot display the webpage"). I then tried the HP download manager, which has a discovery utility. It ran for a period of time and reported "No Jetdirect devices were discovered." An attempt to use 'print' and 'find printer' was also unsuccessful. So it appears the 610n remains dead, even though the LEDs are on, etc.

Does this mean I need to bake the 610n with a hair dryer, to try to deal with a cold solder joint?

Is there anything else?
by Tom Bl on Dec 30, 2010 at 11:01am Add comment
Read the procedure and success stories here:
You can see one of the last posts had no success with a hair dryer, but did with baking.
by moe on Dec 30, 2010 at 11:21am Add comment
Yes, I'll go read the stories at the above link.

With so many bad stories about the 610n, would I be better off to buy an after market outboard LAN device and connect the printer to it via the printer's USB connection? I understand Netgear may make one of these.
by Tom Bl on Dec 30, 2010 at 11:27am Add comment
Big deal, you take it out once a year and bake it. Baking is practically free. I usually bake up a batch of cookies so I don't waste too much energy. Bake the cookies first, so you don't get any of the electrical smell on them.
by moe on Dec 30, 2010 at 12:32pm Add comment
Tom after reading your post you really need to get someone to help you. First off to get a printer to work with ip directly connect to a computer you need a crossover cable. Lets make this real simple. What happens if you disconnect the cable that you had going from the router to the computer and connect it to the printer. Do you get any lights on the jet direct card. If you do, then either the cable you were using before for the printer is bad or the port on the router is bad. I really do not think you have a bad jet direct but have cabling or router issues.
by dmzcompute on Dec 30, 2010 at 5:14pm Add comment
I went through the baking exercise and had the same result. Then I proceeded to substitute cables. I found a different cable from the router to the 610n gives me an intermittant connection. With this the LEDs on the 610n light up and I am finally able to see it's HTML page with my browser. But it's intermittant. When I get the connector at the 610n with a little pressure to one side, it works. So it appears I need to find a way to clean or repair the cable connections. The way it's behaving I suspect it's the connector on the 610n. Any recommendations on cleaning this? (It doesn't appear 'dirty' but I've seen that kind of situation before.) Should I use a metal brush? Or a spray chemical cleaner? Whet's best here?
by Tom Bl on Dec 30, 2010 at 6:02pm Add comment
If not the cable then you need to get another jet direct card. Those rj45 input jacks generally loose some of the spring in one or more leads so good contact is not made. Just about impossible to fix as attempting will generally bend the contacts out of shape.
by dmzcompute on Dec 30, 2010 at 9:33pm Add comment
Now I've tried several CAT cables. I found one that appears to work every time. I'm surprised about all of this, because the cable that connected the printer worked without any issues for some time. Nothing happened to change anything. So I'm curious about what caused the failure. A visual inspection of the cable and the connector on the 610n does not show me anything obvious.
by Tom Bl on Dec 31, 2010 at 11:31am Add comment
That's like asking someone in CA why my snowblower in NJ would not start, but now its does. Why did it not start before. Lets get real here, it works, leave it alone.
by dmzcompute on Dec 31, 2010 at 3:53pm Add comment
What would people in CA know about snowblowers? It's 50 degrees here and we're all complaining how cold it is. It's supposed to get up to 60 tomorrow for the Rose Parade.
Happy New Year everybody.
by moe on Dec 31, 2010 at 4:36pm Add comment