asked May 28, 2008 at 4:15am
Hp HP Color LaserJet 2605

HP Color Laserjet 2605 formatter unavailable?

I have looked in the service manual and on partsurfer and the formatter does not seem to be available.

The printer hangs during boot.
It displays Hewlett Packard with 3 arrows underneath.
I have seen it boot once, display 79 error, then reboot and hang again.

Do an online search for P/N Q5966-60001.
by Bert on Apr 20, 2009 at 6:19pm Add comment
I have exactly same problem.
It displays Hewlett Packard with 3 arrows underneath.
Please help me.
by Anonymous on Apr 20, 2009 at 3:15pm Add comment
The part number Bert listed is available from HP, but it costs over $200. You can probably find a whole printer for that amount.
by Stephen on Apr 20, 2009 at 6:32pm Add comment
I am seeing good working 2600's & 2605's with no toner for $100 to $150 on classifieds in Salt Lake City, Utah; it is a local TV / Radio station website that people list to for free. Go to the classifieds & then advanced search in the computer section. The listers usually want you to pick up a printer but may ship ?? I got a 2605dn with 3,000 pages for $60. I had to remove the scanner & clean the laser mirrors for crisper print but now it runs great.
by unknown on Apr 23, 2009 at 8:28am Add comment
Well for 79 errors as others pointed out already, it's formatter related (specifically the firmware).

The company Liberty Parts Team did a good general article on it.
by Anonymous on Apr 24, 2009 at 12:38pm Add comment
sorry for the thread bump
i'm having the same problem. when i turn on the printer, i get the Hewlett-Packard with 3-4 arrows underneath it. both the lights are lit.
i did the engine test many times and it prints the colored line paper without any problem.
the 4 cartridges i've are the original ones, though one was running low and i manually override it. i did a firmware update a few days ago before the problem showed the smiley and the printer worked fine for another couple of days.
my printer is out of warranty by 2 months, so they won't repair it.
appreciate any help :)
by addtd on Jul 10, 2009 at 5:29pm Add comment
Bert answered the question above - when it freezes during boot, the most you can do is reseat the connections / ram (and unplug the network cable if one is attached) from the formatter.. but even if you get it to boot, it wont matter, because you still need a new formatter board.
As stated above, perhaps try to get one used without toners and swap formatter boards (or use the other one with your toners/transfer belt/fuser spares.)
by unknown on Jul 13, 2009 at 11:14am Add comment
oh, well I guess you could try a factory reset.. I guess.

Press and hold the Select and Cancel Job buttons and turn the printer on. When you see the message "Permanent storage init" displayed, release the buttons.

If that doesn't work, there is a "Super" NVRAM init procedure, which is the left and right arrow keys (instead of the select and job cancel).

It erases all settings on the printer. This usually wont work if the formatter is dead though.

by unknown on Jul 13, 2009 at 11:21am Add comment
nope nothing worked
i couldn't find the printer on ebay or craiglist :(
by addtd on Jul 13, 2009 at 8:58pm Add comment