asked Jan 31, 2002 at 12:10pm
Epson Epson Stylus Color 640

Epson Color Stylus Error Codes

I am currently having a problem with my Epson Stylus Color 640 printer. I cannot find any documentation here or at Epson's web site.

I am getting all lights flashing, that is the paper light, black and color light as well as the power light all flashing at once.

I have tried a few things, making sure no paper is jammed. I've tried removing the ink and turning it back on to reset it but strangly enough, it thinks that their is still ink in it and tries to work anyway only to end up with the same 4 flashing lights.

Does anyone have a clue as to what this might be?


I am having trouble with my Epson Stylus C42UX. I just got it and everytime I try to print something, I get an error message telling me there is a paper jam. There is no paper in it. The trouble started shortly after I replaced the black ink cartridge with a generic one. Could this be causing me problems or could it be something else. Please help!!! I'm ready to through the thing away. I have only had it for a couple months.
by unknown on Feb 9, 2003 at 8:21am Add comment
Hi Blaine

I have exactly the same fault you had, did you ever get a solution to the problem, any help much appreciated.

Many thanks

by unknown on Aug 4, 2002 at 2:58am Add comment
That's maintenance error, replace pads and reset.

To reset try This...

1.Power on with "load/eject" and "cleaning button"
2.After "load/eject" light turns on press cleaning button.

by unknown on Aug 4, 2002 at 3:58pm Add comment
We have the same problem with the Epson 640.
ALL the lights flash. I have replaced the ink pads, but cannot reset it properly. I have tried what is suggested but it does not work.
by Neil on Jan 21, 2003 at 11:19pm Add comment
Well I couldn't get the printer to reset either.
I let my printer die many months ago. I've pretty much decided that their are better printers on the market I could buy instead of trying to make this lemon work.

Thanks to all who have responded tho.
by unknown on Jan 22, 2003 at 6:33am Add comment
I finally reset the Epson printer with the codes that I have. The secret is in the timing
by Neil on Feb 5, 2003 at 7:49pm Add comment
It sounds like the waste ink overflow drain is full and needs to be replaced or cleaned. Then you have to do an eeprom reset.

I have a service manual that tells you how to do it.

Send me an email and I will send you the procedures.

by unknown on Feb 9, 2003 at 7:50am Add comment
Please help me reset something so I can get this paper jam error to stop. If I go through the cleaning process for the ink it prints the test pages just fine, but if I print a regular page it will not ... help!!! - Jav0nz
Hi Mr. Scott,
Can you send me an email of the troubleshooting proceedure too. I have the same problem with my Epson Stylus 640 printer. Thanks.
- Anonymous
Hi Scott could you help me by sending manual to help me clean and repair Epson 640 that has three flashing lights
Many Thank, Patrick - Anonymous
Hi Scott,
I saw your reply on the fix your own website and was wondering if you could help me. I am having trouble with my beloved epson stylus color 600. Quite suddenly, all the lights starting flashing and I've done all the usual by checking for paper jams and replacing the ink - with no luck at all. You stated that you might have a fix for this problem. I would appreciate it if you could clue me in before this epson gets tossed out my window into the cold.

Thanks a bunch!
Dawn - Anonymous
I had that suspect! Can you send me the procedure to reset the eeprom? Thank you! Best regards. - Anonymous
Hi Scott,

Read your message, could you send me the information how to do it, I would very much appreciate your help as I have the same problem.
Thank you.
Patrick - Anonymous
Was that with an 0x9d error code. If so my Epson xp800 has the problem. Could you please tell me how to fix it. - Irsalan
I have a Epson Stylus Color 600 printer. When I try to print all I get is jibberish all the way down the side of the paper. what do you suggest to correct this?
by Kris on Feb 9, 2003 at 9:05am Add comment
Becky your printer there is not paper in it, you must see one litlle sensor of paper is fetter
by Gaby on Feb 14, 2003 at 12:52pm Add comment
See www.findmanual.net - they have all service manuals and service programs. Due to them I fixed thesame error on me C20! They arefriendly!
by Eva on Feb 14, 2003 at 11:31pm Add comment
Becky, try this :
- enter bios setup, and change the parallel port settings to ECP
- if that doesn't work, is either the cable or the drivers u are using :)
by unknown on Feb 15, 2003 at 5:40am Add comment
I have an Epson Stylus Color 600 printer that has the "load/eject and power" lights flashing, and the black and color ink out lights staying on. Can any one tell me what the problem is? I would appreciate any help.
by unknown on Feb 17, 2003 at 10:53am Add comment
Hi, 2003 is a long time ago. Still have the 600. My black ink does not print. Any ideas on how to fix it?

Very Truly Yours,

J. Bradley Keefer - Two_bradleyfix
anyone have an idea what the following means AS I do believe that my Epson 860A IS working to a certain extent: "A Communication error has occured. Check all cable connections and make sure all devices are on. If the device was turned off during printing, cancel the print job. If the error still does not clear, see the manual's troubleshooting section to cancel the error." Using Win98, other printers work and I have swapped different interface cables thinking the twisted pairs are duds. Test pages work but I think they'd work even when the printer was disconnected from the actual PC. Just bought this thing off someone, didn't have drivers so I downloaded them from Epson (9 floppies and also extras for the Stat Mon Utility). All are installed and seem to be correct. Anybody know if this is a quirk of Epson's printers?
by unknown on Mar 18, 2003 at 4:48am Add comment
Hi, all. I've been reading all your comments. My Epson 740 quit right in the middle of a print job. All the lights are flashing. I tried to download the manual from www.findmanual.com. It came in a Zip format that for some reason I can't open. All I want is to know how to reset the printer to get it to start working again. I cleaned the Ink cleaning pads.(NOW I KNOW WHERE ALL THE COSTLY INK IS GOING!) Help!!! Frank
by Frank on Mar 27, 2003 at 7:45am Add comment
I DID IT! I couldn't get my Epson 740 to reset after I cleand the Ink Pads. I tryed Roberts method above but it didn't work.

1.Power on with "load/eject" and "cleaning button"
2.After "load/eject" light turns on press cleaning button.

I tried and tried and went out and bought a new printer. Then I tried one more time. The trick is you have to hold the 'CLEANING' button for about 5 or 6 seconds or untill the thing resets!! WA LA. Back goes the new printer and $248.95 goes back into my wallet. HA!!! Too bad 'BEST BUY'
by Frank on Mar 30, 2003 at 5:55pm Add comment
This works with my Stylus Color 640, too.
All lights flashing, on every power-up.

When paper load light shows, important hold down only
ink/clean button - don't give up, maybe 10 secs.

Thanks a million. - unknown
by Denny Conway on Apr 2, 2003 at 5:06pm Add comment
by Anonymous on Oct 6, 2006 at 10:09pm Add comment
tells me some parts have come to the end of their manifacutures life.and see my local dealer .has anybody got a idea who best to see or the cost or should i just get another
by unknown on Jul 27, 2007 at 3:31pm Add comment
I had the same, I checked all cables as the error said
Check all connections and make sure all devices are on. If the power was turned off during printing, cancel the print job. If the error does not clear, see your printer documentation.
However, all I did was open the lid and pressed the green button to move head to left, then when it reset, I cleaned the printer head works ok.

Epson photo 1290
by unknown on Feb 4, 2008 at 12:36pm Add comment
I've Epson Color Laser LP-8000c printer that shows massage " Service Req E0041" what is wrong ? I checked all things.
by unknown on Mar 15, 2008 at 4:26am Add comment
I've Epson Color Laser LP-8000c printer that shows massage " Service Req E0041" what is wrong ? I checked all things.
by unknown on Mar 15, 2008 at 4:29am Add comment
Check all connections and make sure all devices are on. To cancel printing, click the Cancel button.
by Anonymous on Oct 2, 2008 at 11:29pm Add comment
All my print jobs get the message "stopped", it does not print test pages either
All new cartridges - uninstalled/reinstalled software
USB in computer, not in hub
Power seems OK
Get the message "Operation could not be completed, client-error-not-possible"

Anyone any suggestions?? I've been mucking around for a couple of days now, getting pretty desperate!

Any help greatly appreciated...
by femke1311 on Jan 5, 2009 at 3:21am Add comment
It is all covered in the link. You need to read.
by Anonymous on Jan 16, 2009 at 9:05am Add comment
kuyung, No need to post the useless link all over the forum. The above link IS TO THE SSC UTILITY.
by Anonymous on Jan 18, 2009 at 9:11pm Add comment
Thanks Alot buddy
by Anonymous on Jul 29, 2009 at 9:54am Add comment
give me solution about this problem
by unknown on Aug 17, 2010 at 5:39am Add comment
yogam photos
by unknown on Sep 27, 2011 at 5:17am Add comment