asked Oct 3, 2003 at 7:02pm
Epson Epson Stylus Photo 1280

Epson 1280

The basket that holds the ink cartriges on my 1280 has two brass bushings that connect and guide the basket to the metal rod that the cartrige/head slides upon while printing. One of my brass bushing came out of the plastic basket that holds the cartrige to the rod - while it was printing. I have pressed the brass bushing back in place, and the cartrige is again sliding smoothly on the rod, but the red light on the front of the printer is still on. I am getting a warning that there are foreign objects stuck in the printer...and the printer will not print at all with this warning on. There does not appear to be anything physicaly wrong, the cartrige slides smoothly back and forth. Since then I have unpluged the the cartrige to the left, turned it back on ...etc. with no luck. Anyone have any idea where the sensor is that tells your computer their are foreign objects stuck in the machine....any ideas other than sending the thing off to repair?? Thanks for your time .
I have a Stylus Photo 1280 that is 4 years old.
Recently, Photos are coming with fine black parallel streaks on them. I cleaned the grey rubber rolls that stabilize the papers position. I noticed that the sponge underneath the printer head is soaked and it is the source of the problem. The problem is mostly when I use the 2880 resolution and is not that important when I use the 1440 resolution.
Any idea how to clean that sponge?
by ziad on Aug 29, 2005 at 10:46am Add comment
I have the parallel streaking problem as well. How did you clean the grey rubber rollers? Did you resolve the problem? Thanks for any input you have! - mjrohlf
The print head assembly jammed (on a continuous ink system ink lines) mid way through a job. Now the assembly just "stutters" from one side to the other with an occasional slam. Then the red steady maintenance line somes on. I've shut down the printer (and unplugged it) several times to no avail. I've also cleaned and lightly lubedthe carraige rod, again to no effect. From what I have read on this forum it appears that the printer is "confused" as to where actually the head is. If that is the case, I am not clear as to how to "reset" it. Any thoughts / suggestion would be appreaciated.
by jclay on Aug 11, 2006 at 10:43pm Add comment
SK...JUST TO LET YOU KNOW: I have not had one of those bushings ever come out before, or actually even seen that particular message before...Normally a 1280 will indicate the particular SERVICE ERROR CONDITION thru its two operational panel lights: the "Power Light/Led" and the "Error Light/Led". Send a reply back thru this Printer Repair Site and let me know if the "Power Light" is on SOLID, BLINKING or OFF and if the "Error Light" is on SOLID, BLINKING, or OFF. I can then try to look up the indicated Service Error Condition and see what might be your printers possible problem. As an "Epson Authorized Service Dealer", there's only so much information and help that I can legally give, but I will try to help you as much as I can...Denny Conway
by Denny Conway on Oct 6, 2003 at 1:59pm Add comment
I have had this happen to at least 3 1280's and in each case, I've pressed the bushings back in and, if they didn't stay, I put a little clear bathtub silicon caulking on the exterior of the bushing and pushed it back in and it stayed. The printers then worked just fine.
Dennis Barnes - Dennis Barnes
I have had the same problem and would love to know how to fix it.

by unknown on Mar 1, 2005 at 7:57pm Add comment
Graham: Which problem? The bushing falling out of its holder, or the red light problem? We need to know just what the possible Service Error Condition actually is, that may be indicated on your printer. Service errors are inducated by the combination of the lights on your printer, that are on SOLID, or FLASHING, or actually OFF. Let us know exactly what kind of problem your printer is actually having and if we can help you further, we will try...Denny Conway
by Denny Conway on Mar 2, 2005 at 11:16am Add comment
The bushing falling out followed by a SOLID error light.

The carriage is in the cartridge change position. This also happened after installing new cartridges.
by unknown on Mar 2, 2005 at 1:13pm Add comment
Graham: All you can easily do, is to try and get that bushing pushed back into its holder. Usually, you can re-insert the bushing by visually lining it up, with the opening in the Print Cartridge Holder Assembly. Sometimes you may have to rotate that bushing until it actually goes in. If it won't stay in, you could apply a couple of drops of superglue, to the outside of the bushing where it slides into that plastic holder. Once its in and dry, if you used superglue, then clean and lube the carriage assembly. That will usually correct that Service Error Condition, which will turn that red error light off. Although it's possible your printer has an electronic or mechanical failure, the most common problem is that the "Carriage Assembly" is simply DIRTY and or DRY, causing it to stick and make noises. That usually results in the printer loosing track of just where the "Print Cartridge Holder Assembly" is actually at and that can cause the error light/led to come on. Sometimes when the printer looses track of where that assembly is at, it then keeps telling that assembly to keep moving and can even cause it to slam into the end of the printer. Try wiping off all around the round metal carriage bar or shaft [that the print cartridge holder assembly moves back-n-forth on], with a lint free cloth. Also clean the outside of the metal bushings with q-tips, that the carriage bar passes thru, on both sides of the print cartridge holder assembly. You can also use alcohol on the cloth, if there is a lot of build-up on the carriage shaft/bar. Then lube the metal bar on both sides of the holder assembly, slightly with a precision oiler, not a spray lubrication, or the appropriate grease thats used on some of the newer models [Epson C40UX, C62]. A drop or two of a Teflon based lubrication or Tri-Flo lube is best on the older models of most printers. Manually slide the holder assembly back and forth to spread out the lubrication and wipe of any excess lube or blackish build-up that appears on the bar. After the carriage assembly is cleaned & lubed, then you should perform the "Printhead Alignment Procedure" thru the PRINTER PROPERTIES UTILITY thats loaded onto your Computer System. That alignment can be thrown off because of a dirty and or dry carriage assembly. Sometimes people will simply do a re-alignment without cleaning & lubing that assembly. That simply does a quick fix that usually does not last long. Once that assembly is cleaned & lubed, the actual alignment is then usually off, from those previously done re-alignments and or the sticking & binding caused from when that assembly was dirty and or dry...You can check out this link, supplied by WES, to see different lubrications: and also this link provided by WES, , to see some general information on "Carriage Guide Shaft Maintenance"...Good Luck! Denny Conway
by Denny Conway on Mar 2, 2005 at 2:39pm Add comment
Make it three with this problem. Bushings came off and cartridge holder wobbled badly. Found the bushing problem, turned the printer back on ... green and red blinking lights ... attempts to clean, then no green and solid red light. Printer properties can't find the cartridges or the printer, which apparently has closed connections, even immediately after being turned on again. Tried changing cartridges with no luck.

Super-glued the bushings back in place, cleaned and lubed bar. Same problem.

I'll try another lube/grease. Otherwise, I'm stumped. I thought that I had caused a worse problem until I read that others with the 1280 have had the same problem ... at roughly the same time. Amazing what the Internet lets us find out!
by dermott on Mar 8, 2005 at 9:11pm Add comment
dermott...Just so you will know: When your printer is in a "Service Error Condition" [red lights on or flashing], that stops normal communication with your printer, until that service error is corrected...When the Power Lightbis OFF and the Error Light is on SOLID, that indicates a FATAL ERROR service condition. Here's some general info on Fatal Error's: I'm sorry, but just as it sounds, that fatal error is the worse possible error on your printer. There is no actual reset procedure for a fatal error service condition, because either there is an actual hardware/part failure, or a related area is requiring some servicing to be performed, to be able to correct that fatal error. You may need to try and locate a Service Manual on-line, that you could download for in-depth troubleshooting, disassembly and servicing, if you want to try and locate your possible problem. There are approximatly 9 different things that can cause a FATAL ERROR and most of them involve HARDWARE PROBLEMS [bad/defective/failing electrical parts] in the "carriage assembly" or "paper feed assembly". You would normally know if you have been having any paper feed problems [jams, misfeeds, crooked feeding copies, etc]. You would also normally know if your printer was having any unusual or strange GRINDING NOISES or RATCHETING NOISES, that may indicate a DIRTY or DRY CARRIAGE ASSEMBLY. As you have already cleaned & lubed that carriage assembly, that would normally eliminate that particular problem. However, if your not sure about possible carriage problems, or just to eliminate that area, you might want to clean and lubricate that assembly again. You need to eliminate possible problems and the carriage assembly is one of the biggest and most common problem areas, that cause that Fatal Error Condition. Try wiping off all around the round metal carriage bar or shaft [that the print cartridge holder assembly moves back-n-forth on], with a lint free cloth. Also clean the outside of the metal bushings with q-tips, that the carriage bar passes thru, on both sides of the print cartridge holder assembly. You can also use alcohol on the cloth, if there is a lot of build-up on the carriage shaft/bar. Then lube the metal bar on both sides of the holder assembly, slightly with a precision oiler, not a spray lubrication. A drop or two of a Teflon based lubrication or Tri-Flo lube is best on the older models of most printers. Manually slide the holder assembly back and forth to spread out the lubrication and wipe of any excess lube or blackish build-up that appears on the bar. After the carriage assembly is cleaned & lubed and if that corrects your fatal error condition, then you should perform the "Printhead Alignment Procedure" thru the PRINTER PROPERTIES UTILITY thats loaded onto your Computer System. That alignment can be thrown off because of a dirty and or dry carriage assembly. Sometimes people will simply do a re-alignment without cleaning & lubing that assembly. That simply does a quick fix that usually does not last long. Once that assembly is cleaned & lubed, the actual alignment is then usually off, from those previously done re-alignments and or the sticking & binding caused from when that assembly was dirty and or dry. You can check out this link, supplied by WES, to see different lubrications: and also this link provided by WES, , to see some general information on "Carriage Guide Shaft Maintenance".....Out side of a possible hardware/part problem, the only other easy thing to check is the "Encoder Strip/Sensor Strip" [Linear Encoder] and area on SOME NEWER Epson Printers [no sensor strip on most older Epson ink jet style printers]. A long, almost clear strip of plastic is connected from the left side to the right side of the printer. It is normally positioned just above the carriage bar/shaft and runs through an Encoder Sensor mounted to the backside of the Printhead/Print Cartridge Holder Assembly. This strip appears to be almost see threw, but has tiny encoder dots/marks on the strip. These dots/marks give the instructions to the printhead assembly & main board assembly during a printing job/run/test. Its possible for that strip to become disconnected or dislocated and if it is not running thru the sensor, located on the backside of the print cartridge holder assembly, that will cause the fatal error to occur. Its also possible for ink spray/spots/dots to get on or collect on this sensor strip. This build-up of ink spray/spots/dots on the sensor strip, causes the sensor to actually read the information on the strip wrong. The sensor is trying to actually read the ink spray/spots/dots and gets real confused. This can cause strange problems to happen and more often, a Service Error Led/Light to come on. You need to very carefully and very gently clean this strip with water only, on strips of coffee filters or lint free rags. This strip can easily be UNHOOKED and easily DAMAGED/BROKEN and then your printer won't work at all, so try to hold it still with one hand, while you clean it with the other hand. It comes off easily, but its fairly difficult to reinstall. Almost always you will end up having to remove the Top Cover to be able to reconnect the encoder strip without damaging it. Its possible to reinstall the strip backwards, or even upside down and that will cause more errors and problems. Its also possible that your strip is not correctly inserted thru the encoder sensor, or that the sensor is dirty [blow out with canned air]. That sensor is one of the electrical parts that could also be going bad, but always go for the easy possibilities first. Try cleaning the encoder strip, blowing out the encoder sensor and making sure the strip is running thru the sensor...There is a free download of an "Epson Stylus Photo 870/1270 Service Manual", from, at , that you can use as a guide on your "1280" printer. That manual may be of some help in troubleshooting your "1280's" fatal error condition...Good Luck! Denny Conway
by Denny Conway on Mar 9, 2005 at 10:05am Add comment
dermott: If that free download, of the "870/1270" service manual, is actually not of any help, then you may need to try and locate a "1280" service manual on-line, to buy and download for reference in disassembly, troubleshooting and servicing. I have not checked on any particular makes or models, but here are some sources that you can check with for a possible service manual: You will have to check the following web-sites for availability [some may be able to order or locate Service manuals for you] and pricing: , , , , , , or, Good Luck! Denny Conway
by Denny Conway on Mar 9, 2005 at 10:08am Add comment
Please help, My Epson 1280 lost its two bushes out of the carriage while I was cleaning the print head with a paper towel. But kept getting solid red light.
I pushed the bushes back in and lubricated them well, cleaned clear strip that tells carriage where it is, turned off hundreds of times,possisioned carriage in all different places, restarted,but still get solid red after a bit of short back and forth on start and a then general error in utility. I have had the carriage apart but saw nothing and took care about reassembly, I cannot see any mechanical problems ,does anyone out there have any ideas Im in New Zealand and sevice shops are very hard to come by. Thankyou Paul - Anonymous
I've encountered an installation problem that I cannot get around with the epson 1280. I am running on windows xp.

so the instructions tell you to not load with the windows xp and use the epson cd installation, however I did not. And now when i go to either install the epson (hoping it will override the other one it does not work). Also when I try and uninstall the first epson problem it does not work. What shows up every time is a window that says ..

"16 bit windows subsystem": The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose 'Close' to terminate the application.

I have already tired dling another driver from epson's website, the same popup shows when i try to use that setup. Also I tried to restore my computer back a day to indirectly uninstall it and that still does not work.

apparently epson ts says that its not their problem and that its something wrong with the microsoft system. Does anyone know anything about this?

Help please!! thank you.
by lengjai108 on Apr 2, 2005 at 6:23pm Add comment
Your operative system has been damaged by a virus or a worm.
The issue you describe is covered in this article in Microsoft Knowledge Base:;en-us;324767

There a freee fix available on-line, Xp-fix.exe you can find at:
by newuser on Apr 2, 2005 at 10:16pm Add comment
I have the error light and power light blinking back and forth.
by unknown on Apr 3, 2005 at 1:20pm Add comment
It is a waste ink counter owverflow error, you need to reset the printer with this software:

Once installed you need to configure it closing the main window and right clicking the icon in the tray area, from there choose Configure and select Epson Stylus Photo 1280.
After configuration, select Protection counter -> Reset protection counter, will fix the error.

However you should consider to clean also the waste ink absorbers, located at printer bottom. You can find some informations about how to do it in the service manual for your printer you can buy from web-sites like (see the Denny Conway's post above for more addresses).
by newuser on Apr 3, 2005 at 1:48pm Add comment
I also have the alternating flashing lights idicating a "waste ink counter overflow". I have downloaded and installed the SSC Service Utility 3.80. No matter how I configure the computer/printer connection (USB, LPT, etc) the program reports a error "Printer off, or some other problem". Turning the computer on or off with the printer on causes the print head to cycle so they must be talking to each other.

I recall somewhere reading the error ligts will deny power to the printer. Am I missing a step?
by unknown on Apr 24, 2005 at 1:32pm Add comment
Had my 1280 for at least six years and it is a love hate relationship. Same problems, threw a bushing a few years back that I epoxied back into it's mount. (I don't want crazy glue anywhere near that shaft.)

Had the same alternating red/green flashing "waste ink counter overflow" error indicator. Tried the SSC but as the Epson service manual says "with this error the printer will not accept command data". Here is what to do.

1)Press and hold the "roll paper" and "maintenance" buttons.
2)Then press the power button until green light starts flashing.
3)Release all three buttons.
4)Wait until red light starts to flash.
5)Press and hold the "roll paper" button for 10 seconds on the clock. Release.

That should do it. But it took me three tries to get it. Once it does, you're in bussiness and that SSC thingy will tell you your count is back to zero.

- Anonymous
I've described Ssc Service configuration a bit more completely here:

You probably need to stop Epson status agent since it can block communication from pc to printer.
by newuser on Apr 24, 2005 at 1:47pm Add comment
Great Utility. Thanks Guys. Fixed exactly same problem for me.
Seems it has plenty more features too. ;)
by vidiman on Apr 28, 2005 at 10:19pm Add comment
Thanks everyone, that problem has been fixed. I really appreciate it.

However, another problem has come up. Whenever I send something to print to the 1280 (usually using photoshop and illustrator), I can only do it once; meaning that if I tried to send something else to the printer afterwards, the printer will no longer respond and/or the program from which i printed from freezes.

detail to my situation that may or may not pertain to the problem:
-I have another printer connected to my computer (an hp officejet g55).
-I am using a PC
-I am connected with a firewire usb cord.
by lengjai108 on May 2, 2005 at 4:34pm Add comment
Does anyone know what the plastic sheet thing is that came with my stylus 1280 i am having problems right now with it printing tinny lines the lenghth of my pics could that be the thing that fixes it?
by unknown on Jul 7, 2005 at 4:41pm Add comment
and sorry but yes i have done the allignment utilty all the way threw twice
by unknown on Jul 7, 2005 at 4:46pm Add comment
I've installed the lasted driver (version 4.1) for my epson 1280 and have been searching the printer setup utility for a way to print borderless. there is no 'borderless' option in the layout section of my printing preferences (though online help does suggest that option). I heard that I have to launch a second printer and change its set-up someway but I was wondering if anyone has any advice.
by unknown on Aug 3, 2005 at 11:38pm Add comment
Try paper tab. Note that only certain types of paper will allow borderless printing. For example, plain paper does not allow borderless printing.
by unknown on Aug 4, 2005 at 4:37am Add comment
I have the same problem as Ziad, I think, and it's driving me nuts. The sponge IS dirty, I suppose... but what shows up on my prints (all of them) are repeating images of the tiny rollers the paper passes under just before the ink cartridge. Usually just one of the rollers. thus there's schmutz going down the right hand side of the image. How do I get in there and really clean it?
by unknown on Aug 29, 2005 at 12:00pm Add comment
The problem most likely is that the residual ink is being picked up from the full width metallic paper feed roller under the small rubber rollers. The only way I know to clean this properly is to remove the upper case (Printer unplugged of course) and proceed to clean the rollers by carefully spraying them all with a mild non foaming cleaner. For the best results you have to remove the metal front carriage guide and black plastic paper feed guide (looks like a tray that the paper rests on before it is ejected). Put paper towels under the full length paper feed roller to catch the spray residue. Spray, rotate the paper feed roller, and repeat until clean.
Hope this helps.
by unknown on Aug 29, 2005 at 10:38pm Add comment
I have an Epson 1280 with the blinking light errors. I have installed the utility and tried everything to reset the protection counter. A communication error constantly occurs. I tried stopping the Epson status agent and it still doesn't work. If anyone knows a fix for this please post something or
E-mail me directly. [email protected]
by DarinL on Sep 1, 2005 at 9:57am Add comment
Try putting a little bit of 3 in 1 oil on the carriage shaft.. it's only a temporary measure, but should get you back up and printing until you can have the unit serviced.
SeanY - SeanY
I cleaned the grey by alcohol wipes. If you open the cover, you can scrollthe whole cylinder by turning the wheel at the end. The friction against the rubber will clean it. The sponge will have to dry up and I do not know a way to clean it.
by Anonymous on Oct 16, 2005 at 2:42pm Add comment
I clean the sponge by pressing the ink cartridge change button to move the carriage. Then I lightly press a papertowl against the sponge so that the excess ink will be absorbed. I will sometimes have to do this a few times depending on how much ink comes up. You have to be careful not to press too hard because the sponge has a tiny spring underneath it that you don't want to bend or break. I keep doing it until the ink looks like it's not soaking up as much. It doesn't need to be clean of ink, it just needs to be less saturated with ink. When it was really bad, I put a little alcohol on a papertowl and pressed it against the sponge after I had already absorbed the excess ink.
by unknown on Nov 9, 2005 at 10:01am Add comment
I've had no problems with my 1280 until a virus wormed its way into my system recently and I had to revert to original factory settings and reload everything. Now, the prints from my 1280 are no longer borderless. There's about a quarter inch or less border at the top and on both sides of the print, and about a half inch or more border at the bottom. The image is fine otherwise. Any idea what's happened here? The 1280's manual doesn't address this matter.
by unknown on Jan 21, 2006 at 7:15am Add comment
help, my 1280 will only print part of a jpeg or just a line or two of text from publisher but prints full page no problem from paperport, never had this problem before and have been unable to figure out how to set or reset printer configuration - any ideas? Thanks - Peter
by Anonymous on Feb 10, 2006 at 4:53pm Add comment
My Epson Stylus Photo 1280 dropped on the ground from about three feet and one of the plastic carriages which holds a brass ring broke. Is it possible to get another carriage piece (especially since there is brand new ink in there)? I hope that I can because it is my only "larger" format printer.
Thanks, Paul
by linkprops on Mar 29, 2006 at 4:56pm Add comment
You can get a new carriage assembly from compassmicro In some cases if you are lucky you can use gel type super glue and glue the bushing back in.
by Anonymous on Mar 29, 2006 at 5:22pm Add comment
I need to find the best way to clean the printer out so that I don't get ink-streaks on the back-side of the documents I print. The back-side is visible to the end user, and can't be marred by ink.

Any suggestions would be appreciated.

by patcii on Apr 17, 2006 at 2:39pm Add comment
Paper will no longer feed through the printer. The printer does pull the paper into the initial position, but then the red light over the maintenance button comes on steadily and all other functions ease except for power on/off. When powered back on, the red light is off and I can again feed a sheet, but with the same results.

This error appeared during of installing the Niagara II system. At one point, there was an excess of ink and a sensor or switch my be inundated with ink. Does anyone have an idea of what sensor may be involved? Or what may be going on.

Have checked and I am quite sure that there is no paper jam.

by unknown on Jun 2, 2006 at 1:15pm Add comment
here is a good website to get printer parts. I am having the same problem, I took my printer apart reinstalled the new print head, and while i was doing that i damaged the encoder strip and then the Fatal Error Red Light came on. I just ordered it today, i will update this post if i successfully get my printer back in working condition.
by g on Jun 6, 2006 at 4:18pm Add comment
and one more thing, i have two new inks installed, and my printer does get picked up by my computer and it shows that both inks are full, that is what makes me think it is the encoder strip that is the problem. - g
I cannot get my 1280 Epson Stylus to print

It stopped printing. I cleaned the ink pads and tried to reset the counter but it says error in installing the hardware

Everything works fine, it recycles on command, all utilities work but it will not print and keep saying that the paper in not properly loaded. It goes through but will not print.

Can you help me immediately, thanks
by unknown on Jun 14, 2006 at 4:28pm Add comment
I have an epson 1280. I was having difficulty feeding off a roll of paper. Ended up with a paper jam and had to pull the paper back from from the rear. Now no paper will feed, roll or sheet, red light and green light flash alternating. Printer will not print test page(diconnected from computer)holding down maintance button and turning printer on. When connected to computer, General Error message comes up, for printing. Currently have cover off printer and see nothing obvious. Is there any hope? Thanks, Greg
by fortshockley on Jun 28, 2006 at 1:10am Add comment
The carriage of my 1280 is sitting on the left side in the cartridge exchange area and will not move back home again. The red lide is on. The power light is on.

The yellow button does not have any reactions.
If I turn off the printer and try to move it back manually it does not let me because an obstruction I can't see.

If turning on than the carriage is moving just a little bit indicating that it works but then stops. There is no abnormal noice or whatsoever. Any suggestions of what I can do?
by Jokofix on Jul 1, 2006 at 4:58am Add comment
Once the printer is turned on the power light goes off and the red light is on.
I Tried 2 different cartridge sets: same thing.
I now running the SSC Service Utillity to find out more.
In the SSC Service Utillity the Status Monitor is greyed out and not available.
by Jokofix on Jul 1, 2006 at 5:30am Add comment
Thanks guys - I had the same issues with the alternating blinking lights but none of the utility worked until I shut down the Epson monitor in the services.
Appreciate the help!!
by unknown on Jul 17, 2006 at 1:11pm Add comment
Help - I've had the 1280 for five years. I changed the color catridge and the printer will not recognize that there is any ink in it. The carriage only moves back to the right when I turn off the power. Both the red & green lights are on. I've tried resitting the catredige to no avail. Any suggestions?

by fbhikku on Jul 17, 2006 at 2:11pm Add comment
It could be a bad chip on the ink cartridge. Read this page for more info
by unknown on Jul 17, 2006 at 2:58pm Add comment
I am getting red lines across the entire length of the page. sometimes they stop if I do a clean but if I stop printing for more than a few minutes they come back and I have to clean the heads again up to 10 times before they disappear again. Once in a while they aren't there at all but that is getting really unusual. Anyone have the same problem?
by Mudd on Jul 22, 2006 at 8:00am Add comment
Yes, I too have the same problem, there are red lines from left to right and it has been happening with different color cartridges... How can I fix this problem? - Anonymous
If cleaning and updating the drivers did not help then the print head is failing.

I hope this helps,

by unknown on Jul 22, 2006 at 12:25pm Add comment
I have the red lines appear on print even after cleaning the heads. How do I repair the failing print heads...Thank You..Rene - Anonymous
I seem to have the same red line (and sometimes blue line) problem. I have been getting horizontal lines about 1/8 of an inch apart running through parts or all of my image. I've cleaned the nozzles and the nozzle check comes out fine. How do I update the drivers? How can I tell if my printer head is dead? - unknown
I am new to this type of printer and I installed a Easy Flow system to it. My problem I am having is the black color is not jet black but more of a dark gray. When I printed the photo out on the factory ink cartridges, it was jet black. How do I fix this problem?
by unknown on Jul 30, 2006 at 4:41pm Add comment
I have been reading about bushings falling out on the 1280.

Mine did, after the printer fell about 3 feet. I put them back.

I cleaned and lubed the bar that guides the head. I cleaned both the nearly clear head positioning strip about the bar and the clear wheel with numbers on the left side of the printer used for paper positioning.

The printer still shows the power lite off and the other (service/maint whatever) on.

Has anyone made any progress on this.
I am down to looking for the service manual.

I contacted EPSON via the "EPSON Connection" to see if I
could get a manual from them. It felt like I was being
answered by a poorly done AI program.

If I have to buy the manual online has anyone actualy paid
for and recieved the correct and useful service manual.

by 3v0 on Aug 3, 2006 at 9:58am Add comment
by Anonymous on Aug 11, 2006 at 9:34pm Add comment
Check to see if the carriage bushings did not get knocked loose. It is very common for thenm to become disloged and cause that type of problem. If the bushings are loose you can use gel type super glue. Forsome reason the gel glue works a little better than regular super glue. Also check the encoder strip to see if it is clean.
by unknown on Aug 11, 2006 at 11:24pm Add comment
it make a loud noise but the cartridge move half way then it stop

what should i do
by Anonymous on Aug 12, 2006 at 9:06am Add comment
Operating System: Macintosh OS X.4.3

Printer: Epson 1280

Problem: Power light is flashing green; Error light is flashing red

Dialogue box information:

Communication error; general printing error...

Question: Basically... What to DO!??

by unknown on Sep 9, 2006 at 7:35am Add comment
It could be that the DE lock lever has come from its mounting hole. Remove the top cover and look behind the cartridge 'parking area' for a little white plastic 'peg' sticking up between the slide rail and the metal frame. This should get moved about 12 mm when the carriage leaves home and pushed back again when the carriage parks. Then look at the other side of that frame for the actual DE rod which that peg is part of. The rod should be sliding in its mounting holes at both ends. The usual fault is that it comes out of the hidden hole and cannot slide to engage the gears for the paper feed & waste pump. Come back if this is the case and I will advise further.
by unknown on Feb 22, 2007 at 3:32am Add comment
My DE lock lever has come free from its mounting hole. I am having a problem getting it back into its place. Can you help me out with pictures or instructions. Thank you.

hello everyone.

my epson is a couple of years old. about 90\% of the time that i print, i get an error message that says "paper not loaded correctly." but i know that it is.

the only way that i can get it to print is to load up the tray with a thick/heavy stack of paper (nearly as much as is in one new package of epson paper).

which makes me feel like its something having to do with the sensor -- its as if the printer doesn't sense there's paper in the tray unless it is a really heavy stack...

wisdom and/or assistance much appreciated....
by unknown on Mar 30, 2007 at 1:42pm Add comment
Sara, it sounds like the paper feed input rollers are worn or dirty / dusty. Does the "paper not loaded correctly" message come up after it has actually gone through the motions of feeding the paper? The paper feed sensor on the 1280 is just one, which detects when the paper has fed as far as the main fiction material ( grey ) coated roller. Failure to reach that point will put the red light on and a press of that button should start the feed action again.
To clean the input rollers:- Take a sheet of plain paper and give it a very, very light spray with clean water. No need to cover it all just a band about 2" - 3" wide across the middle of the sheet. Place in the input tray and press the paper feed button. Assist it into the input rollers if needed. Repeat once or twice more and then the same with a dry sheet.
by unknown on Mar 30, 2007 at 2:07pm Add comment
Does anyone know if or where one can get or buy the service manual for the Epson 1280 ?
by 3v0 on Apr 1, 2007 at 7:23am Add comment
Did you find one? - Anonymous
I just got a 1280 from my son's fiancee. There's 'way too much green in both pictures and test patterns. A pyramid test pattern of stacked 1/4" color squares (red on lower left, blue on lower right, and yellow at top - which is the apex) has green in much of the right side of the pyramid with far fewer blue squares than seen on the monitor.

Fresh ink, nozzles cleaned and checked, no evidence of malfunction. Same result using automatic, epson color management, and no management at all.

Any ideas would be greatly appreciated.
by unknown on May 12, 2007 at 2:36pm Add comment
i just printed a boatload last week, and when i went to turn the printer on just now, it won't. like it's not even plugged in. and it was perfectly fine last week.

i went to the epson site, went through their troubleshooting section trying out what they had suggested, and nothing. i've had the printer for years, but it's not a heavy use machine. what are my options with this thing? is it dead and i should take it out back with a shot gun? i appreciate any help i can get! thanks!

by Scott Cohn on Jun 21, 2007 at 11:41am Add comment
Without a service manual you can only do so much. First try the things that are so simple you might be insulted. Is the outlet live, did the dog chew through the power cord etc.

If none of them work open it up and see if there is power at the controller. Check if the switch is bad, stuff like that. Take care when you open it. Some of the internals can be easily knocked loose.

I have one with mechanical problems. So if you intend to get rid of it I may be interested in getting it for parts.

These are good printers, I do hope you get it working.


by 3v0 on Jun 21, 2007 at 1:57pm Add comment
My 1280 prints additional image in an offset as it approaches the end of a printed page. That is, it seems to print a ghost of the bottom right corner of the image offset from the original. after a few prints (and wasted ink) it works as well as ever. Problem is getting worse, and I am afraid to open it up....utilities are of no use. No smudges, no smears, just ghosts of the bottom corner....very frustrating! HELP! thanks in advance!
by prophoto on Jul 3, 2007 at 12:33pm Add comment
Yes ... I too have just become a victim of the "Epson horizontal line blemish". What a pain it is, too!

I have just spent three or four days bashing my head against the wall - with a client in New York waiting on a print ... because my trusty and much loved Epson 1280 suddenly started printing horizontal black lines at random.

Much head cleaning and nozzle checking ensued ... until I thought I had a perfect print ...

... but no!

Now I have yellow lines instead! (Hardly noticeable at first glance.)

However - this did lead me to conclude that somewhere in my machine there lurks a small piece of "krud" that is quite mobile.

I decided that one course of action would be to simply keep on printing - at low resolution and high speed.

The result as of this afternoon is that it seems to have worked. I just got my "perfect print" at last.

If you can be reasonably sure that this is the cause of your problem - give it a try.

....The only downside is that it has just cost me about 1 zillion dollars in paper and ink to do it ......

by Subdriver on Aug 4, 2007 at 4:37pm Add comment
I thought I was the only one in the red line private HELL. My printer usually does get better after many, many, MANY (30+) sheets of paper mixed with cleaning cycles for a perfect print but returns to lines after a few days of non-use. I too think it's a piece of "krud" floating around since it improves/disappears/changes frequently. I had a repair person suggest a cleaning cartridge but when reading about them it advises not to use...I'd love to just get in there and get the fuzz off -does anyone know if that's possible? Or if a cleaning cartridge makes a difference? I've always used Epson inks so they can't blame it on that... - unknown
Quote: "I thought I was the only one in the red line private HELL. My printer usually does get better after many, many, MANY (30+) sheets of paper mixed with cleaning cycles for a perfect print but returns to lines after a few days of non-use. I too think it's a piece of "krud" floating around since it improves/disappears/changes frequently. I had a repair person suggest a cleaning cartridge but when reading about them it advises not to use...I'd love to just get in there and get the fuzz off -does anyone know if that's possible? Or if a cleaning cartridge makes a difference? I've always used Epson inks so they can't blame it on that..." End Quote

No!'re not alone! ....and to be fair ... this is a "printer problem", not an "Epson" problem. I would love to know what paper you normally use. (I always use Epson inks, and heavy matte or watercolor paper by Epson)

Since my last post, my 1280 has performed impeccably, which I feel may prove my diagnosis to be correct. How long it will last? - I don't know.

I feel that the only way to cure the problem would be to strip the machine down and really get at the underside of the carriage for a thorough cleaning - but I don't have that much courage! The truth is that time and use will and must cause a build-up of ink and "fuzz" under the carriage of any printer. It's an "occupational hazard" if you will.

And the folks at most risk are those of us using matt papers.

I thank all those on this forum who have had the foresight to warn us all about ensuring our paper is clean before inserting it - and also the good advice of TURNING THE PRINTER OFF WHEN NOT IN USE! I was not aware of this when I found this forum - I also use an HP500 Designjet - turn that brute off for a few days, and you'll have to put in new cartridges for sure.


by Subdriver on Aug 13, 2007 at 7:33pm Add comment
I was reading the forums and someone asked for resolution on a printer problem, but I cannot find the answer. Please help! I have an Epson Stylus Photo 1280 printer. I recently bought a continuous ink system from Coastal business. I have a CIS (sublimation ink) in the printer currently from Best Blanks and it works great. I wanted to try out the new CIS (pigment ink) in my current printer to make sure it works before I purchase another Epson 1280. After installing the CIS it starts the normal process (possibly head cleaning?). Then it will move back to the position to remove the CIS. The utilities message states there is a foreign object in the printer. The power light is off and the error light is solid. I can then remove the CIS and replace it with my other CIS and it works just fine. Thank you for your help and time!
by unknown on Aug 18, 2007 at 12:28pm Add comment
HELP! I have 2 Epson 1280 printers and they work great except for one thing. When they get to the last half inch of the image they are printing it seems to slow down and take longer to finish the last half inch as it did to print the first 8 inches. And to make matters worse it leaves vertical white lines in the image. I have done all of the cleaning steps but is there something else to check? Is this a flaw in the printer itself as it does it to both printers.
by hpotter56 on Sep 2, 2007 at 12:43am Add comment
I was printing a photo, it got about a quarter of the way through, when the printer stopped. The paper fed all the way through, and the maintenance light came on. When I turn off the printer and turn it back on, the ink carriage moves about an inch, and it's hard to move back and forth. I don't want to force it, anyone have any ideas?
by unknown on Sep 28, 2007 at 8:30pm Add comment
Read the earlier posts in this thread.

Could be that the bushings that hold the head on the rods came loose.
by 3v0 on Sep 28, 2007 at 10:01pm Add comment
I did, and that didn't happen. Something else started happening as well, the carriage now moves across very slowly, while both lights blink, and then stops and only the maintenance light stays solid. - unknown
I've struggled with one clogged nozzle on my 1280 for over a week. I've tried everything I could discover on the Net including purchasing a cleaner to push through the print head. All to no avail: still the yellow nozzle is clogged. Any other tips or tricks out there? Is it possible that one clogged nozzle is the sign of a blown print head? I don't want to junk this printer yet as any of my newer Epsons will not work with MacOS 9.x.
by jclay on Nov 19, 2007 at 9:36pm Add comment
There's a clear plastic strip that has come undone when I transported my 1280. There's a little spring that's attached to one end of its notch, but nothing is attached to the other notch. Could you tell me what this plastic strip is and what it's supposed to be attached to?
by unknown on Dec 13, 2007 at 12:04pm Add comment
Sounds like the carriage encoder scale which goes through the sensor on the backside of the carriage. The notch rests on a hook at the opposite end of the carriage.
Hope this helps.
by unknown on Dec 13, 2007 at 10:56pm Add comment
I just wanted to say "THANKS" to this website and especially the guys who shared information on the "waste ink counter overflow error". This link worked great for my 1280, you just have to read the directions carefully. The first screen seems confusing to activate the service icon by hitting the "X" to start it.

You guys have saved me alot of pain/inconvenience of taking my printer to a service tech who would spend 30 seconds resetting the printer and charging me premium bucks for it.

On a different note... I'm using a Niagra bulk ink system. The print cartrige seems to have an issue making contact from the chip to the cartrige holder. If I position it just right it works OK but requires constant re-adjusting. Any ideas for fixing this??
by unknown on Dec 28, 2007 at 9:18am Add comment
I have the flashing light problem (green light and red light) but am on an Intel Mac and can't seem to find a solution in what I have read. I've disconnected everything and plugged it all back in numerous times.

I get this message:

Status description
A general printer error has occurred.

I also see "Actions to take," with instructions which I have followed.

is there any hope?
by jordan2 on Jan 20, 2008 at 4:10pm Add comment
I have red thin bands printing through the images to the outside of the printing area. I do not have this problem with plain document paper. Just photo papers. This just started . Anyone experience this? Yes I did clean nozzles many times, aligned the heads etc....
by unknown on Feb 4, 2008 at 4:40pm Add comment
i also have three red bands at the last part of a photo print. i've tried all the tips i've gotten and nothing helps. i'm starting to freak out. PLEASE someone give me a fix for this. HELP! - unknown
I recently purchased a used 1280. Seller printed a page and did a nozzle test I was present. When I tried to set printer up at home I ran into a few problems. Carrage was loose wobbly and would stick, THANKS TO THIS SITE, I was able to fix (left carrage bushing was out Now when I try to set up I get error messages: operation could not be completed or printer off. I followed the start here sheet to a tee. NO luck. I have installed and uninstalled twice still no luck. Also, whan i first turn printer on it slowly moves to the left and then flies to the right starts stops starts stops and then the red light lites (green light out). If I push the power button the red light goes out and I get a steady green. I have down loaded driver updates from epson. I`m baffled can someone help?

by Anonymous on Feb 11, 2008 at 2:51pm Add comment
run a word doc with a bunch of black text, at least 4-5 pages and then try your photo again when he lines are gone from the word doc. Be sure to shut off printer when you're done and cover if possible to keep dust from flying in.
by unknown on May 21, 2008 at 9:06pm Add comment
How does the nozzle (stair step) pattern look. Are all nozzles firing properly and not skewed?
by unknown on May 22, 2008 at 10:41am Add comment
yes. it is all good. it is odd that the banding only starts on the last quarter of a print. a computer tech friend said it sounds like a logic board issue. the R1800 is only a year old.
by unknown on May 22, 2008 at 10:47am Add comment
Which printer are you talking about the 1280 or R1800?
by unknown on May 22, 2008 at 11:26am Add comment
i have the R1800
by unknown on May 22, 2008 at 11:39am Add comment
A general printer error has occurred...I get this message when I go to print os X 10.5.4
by unknown on Jul 6, 2008 at 2:16pm Add comment
I have this Epson 1280 that I don't use much. Now that I want to use it after following all the normal head cleaning instructions so many times. My yellow color is still not printing. Since I have lost almost a week reading and following instructions. Maybe somebody can direct me to a printer repair shop around Queens - Long Island New York that wont chop off my arm.

I think the printhead was damaged.

Any idea how will it cost to change it?

I will appreciate all the suggestions.

Thank you so much.

Nelson Perez
BeautyPod LLC
by beautypod on Jul 20, 2008 at 4:27pm Add comment
My 1280 is only printing the first half of any page. Anyone have an idea why this would happen
by unknown on Sep 9, 2008 at 5:14pm Add comment
that epson ssc reset utility is not working with my mac os 9.2
dowloaded it, but i can't use it at all.
been going nuts since fri. trying to clear up the problem of the flashing red and green lights. I found your site today, and have absorbed the ink on that one sponge, have cleand and lubed the shaft, and cleand that thin plastic strip with a damp coffee filter, but are afraid to take things apart further without a service manual. for personal reasons, I can't get one right now, and I gotta make this thing work.

any thing else I can try? I can't aford to bring it for service.
by unknown on Sep 16, 2008 at 6:09pm Add comment
I'm afraid that what you got the ink off of wasn't one of the pads. they are located under the print mechanism which comes out of the lower cover in one piece. Also, I'm afraid that the SSC utility doesn't work on Macs. But, if you can get the utility to work using a PC, then you can get at least halfway through the next maintenance cycle before ink overflow becomes a problem.
by MMurray on Sep 16, 2008 at 6:29pm Add comment
My i280 will not print colour.I sent it to be fixed at my local computer store and they said that it will cost the same to replace the head as buying a new printer. I have had very good results from my printer and just bought 3 sets of ink cartridges. Could some one help me with a solution to my problem?
(1)cleaning the color print head,
(2)getting a print head
(3)what do you suggest to resolve my problem.
At present my pocket can't afford a new printer with the specs of the 1280 so any help would be appreciated.
Thanks in advance Monty
by Monty Lewis on Jan 15, 2009 at 12:41pm Add comment
i have a epson 1280 it was working find untill a pice of plastic got cought in the move ment an now it hangs an bangs an the red light coms on is there a reset on the rollers or anything i might try thanks john
by johnsby on Jan 19, 2009 at 11:48am Add comment
Check to see if the bushing have not popped out of the head.
by 3v0 on Jan 23, 2009 at 10:30am Add comment
Beyond printer was dead, as in DOA, blinking lights and flat lining and then I did your suggested fix: came back to life better than Lazarus.
The internet is astounding...
by unknown on Mar 13, 2009 at 2:25pm Add comment
Glad to be of service - however this just reset the "waste ink overflow counter" to zero. Word to the wise, you better soon empty out the waste ink tray or you will have a serious ink overflowing over your counter error. This ink is a hag to get off.
by Anonymous on Mar 13, 2009 at 2:38pm Add comment
I have been getting blue streaks across my prints and have done a lot of print head cleaning. I found on the internet somewhere and I am sorry I don't know exactly where. Rumor says that Epson is having troubles with their ink cartriges or the chips in the cartriges. Is this true what ever the case is I am looking for a new printer and it will not be a Epson.
by unknown on Sep 5, 2009 at 3:18am Add comment
If the lines are being printed over the image then the head has probably blown and would need to be replaced.

Can hardly blame epson for a part failing on an old unit like the 1280 though.

by unknown on Sep 5, 2009 at 4:29am Add comment
Hi Folks, I have a problem I need help with. I run Mac OS X, Tiger, to my Epson 1280. My printer has worked fine for years. Today, when printing from any program, it does two things.

First, it starts to stagger the image. Meaning, as the paper feeds through, the image starts to skew to one side, resulting in a stair stepped image. It's not the paper moving though, that stays straight.

Then, both ink lights come on with the paper light, and it stops. I have to cancel the printing or shut off the printer to get it to respond to any button pressing.

I've run head alignment check, and that works. Any suggestions are welcome. Thanks.
by altitudesf on Sep 8, 2009 at 12:27pm Add comment
I have two epson 1280 hardly used but constantly giving me problems. One of the printers are having trouble with clean nozzle checks...constantly I tried cleaning the print heads hoping that would work but never does. Any help would be greatly appreciated. The other Epson 1280 is about 2yrs old and used only several times but when I just went to set it up..I get a solid red light on the maintenance button. There is no paper jam and all it says to do is take it in to a shop. I would rather attempt to fix it myself. I don't want to trash these printers I just want them fixed so I can move on and use them for work. Any help and guidance would be so greatly appreciated.
by unknown on Oct 2, 2009 at 3:59pm Add comment
sounds like the printers are in real warm setting or you are not printing something every couple of days. if your using epson ink it likes to set up in the spray nozzels if not used every day these ar hi voume printers i went to subliminal ink an have had no problem sence i quit using epson ink. and now i dont let it get over 85 degrees in the room ware they are.if the ink is set up in the nozzels you can try an fulsh the heads with some alcahol take a set of ink cartiges an use a synige an put about a table spoon of alcahol in each one if you can get it started find you a picture with all the colors in it an print till all the epson ink is washed out than buy an after market ink an they should stay working if you print every day or to. set the printer on a towel it gets messy some need to uninstall the software restart the computer an go into your progam files an deleat the epson printer files or it will put it right back like it was go to start run an click on browes an deleat the file careful no place to play. good luck john you need to print about 2oo pages to clear out the heads its a wast but its cheaper than the nozzels they cost more than a new printer. - Anonymous
I do use s sublimation bulk ink system....I just installed new ink. So would your suggestion remove the ink from its containers and put in alcohol into the individual cartridges with a syringe and just run a print job...continuously until it completely runs out of the cartridge? or should I just drop i on the print heads and install the cartridges on top of it? It is in a warm room...not sure the temperature...but I will start to keep ceiling fan on and it should cool it down....I also haven't printed something in awhile...and it is not being used daily only cause I got frustrated with the bad nozzle checks that I gave up for awhile. Do you suggest I use epson cartridges instead of the sublimation ink cartridges? thank you for your help appreciate it....Doreen
by Anonymous on Oct 4, 2009 at 10:43am Add comment
I was just given a Epson 1280 with bulk sublimation ink system. It has not been used in about 1 year. Most of the jets are clogged up. How can i get them cleaned out.


by unknown on Oct 9, 2009 at 1:07pm Add comment
I just installed CS4- using photoshop 11.0- and get communication error message on Epson 1280 saying to check all connections. Also ink monitor levels are not functioning and colors not printing well from older documents. I reinstalled original drivers to no avail. Any suggestions?
by sallya on Dec 19, 2009 at 12:55pm Add comment
I've had my Epson 1280 since 2003/2004 (don't remember exact date). I've always had head clogging issues and wasting of ink trying to unclog print heads. I've done tons of research and I've come to the conclusion of several ways to keep my unit running. Here are steps to keep unit working and print-heads clean:


1. Goto ebay and purchase T007/T009 refillable ink carts, some come with syringes (a plus), some carts come with ink pre-filled (not good), just make sure they are empty, unless you plan on using generic ink.
2. Goto drug store and get a new eyedropper/bottle, Windex (bulk, no sprayer), good paper towels,
3. Fill empty carts with Windex (real Windex, not the cheap unbranded blue window cleaner), do not use alcohol, i've used alcohol several times and it does not dissolve the ink residue as good as Windex.
3. Get a new eyedropper from drug store, also fill with the windex and use the eyedropper to put several drops onto the print-head parking pad.
4. Replace carts filled w Windex, run head cleaning a few times to get Windex to the print heads.
5. Hit the yellow button under lid again to move printing assembly to the left, put another few drops of Windex from eyedropper onto print-head parking pad again. Turn off power button, print-head assembly will go back to the park position without the extra steps. Let it sit for a day or two.
6. Cut a piece of good quality paper towel 3" x width of paper towel roll. Fold it twice lengthwise (should be @ .75" x width of roll). On right side of printer under the lid, flip paper thickness switch from "0" to "+". Turn on printer, hit yellow button to unlock and move print assembly to left. UNPLUG printer (power) from wall. Position paper towel between rollers (where the print head travels and prints onto paper). Use Windex-filled eyedropper and apply Windex to towel. Carefully slide printer assembly over Windex-soaked towel about midway. Move paper thickness switch back to "0". carefully slide assembly back and forth to clean print head. Repeat several times replacing towel. Remove soiled towel, turn power button on and run print-head cleaning several more times.
7. Replace Windex-filled carts with ink carts, run print head cleaning several times to flush out windex.

Heads should now be clean and clear until it needs cleaning again. I often perform this once a year, I use my printer occasionally. Hope this helps.
by unknown on Jan 18, 2011 at 12:31pm Add comment
My printer powered off in the middle of printing a PDF last night. I unplugged, replugged and turned it on manually and started to print again--then it powered off again.

This morning it's back to normal (as in, not shutting off) but now it doesn't print documents. The print head travels properly, it sounds as if it is printing, but nothing.

Although the ink cartridges are fairly new, I swapped those out for brand new ones. No change.

Ran the utilities (clean print head, nozzle check, etc.) and still it prints with invisible ink.

I don't get any error messages (no red light, solid or blinking). I really don't want to buy a new printer--any thoughts on what the problem could be/how to fix this?


by bralston on Nov 15, 2011 at 3:28pm Add comment