asked Dec 22, 2006 at 1:42pm
Hp HP LaserJet 4L

HP LaserJet 4L out of paper -but its NOT

HP LaserJet 4L says its out of paper, but the paper tray is almost full. Printer will print the test page when I hold down the button though. This problem out of the blue after working perfectly for the last year. (The only thing new is a demo font I downloaded from the internet the same week.) Could someone shed some light on me?

Also get a "found new hardware" message when I boot my computer. But I have no new hardware. This happened on the same day.
Check the cable between the printer and the PC. (I think you have a communication problem)

I also think the 4L is not saying it is out of paper, that would be indicated by a flashing light, I suspect that the out of paper message is on the PC.
by Stephen on Dec 22, 2006 at 5:22pm Add comment
The flashing orange code lights come on my printer too. Even after printing a successful test page by holding down that blue button. How could the printer detect paper on a test print and then see no paper for anything sent from the computer? - Anonymous
If the printer thinks the paper tray is empty it will indicate it with a flashing light.

If the PC says paper is out and the printer does not have a paper out indication, then the PC and the printer aren't talking to each other.

Ic could be a bad port on the PC, bad parallel cable, or a bad formatter board in the printer.

I'd swap the cable first, then try the printer on another PC, and after that start swapping parts.

Of course I've probably got at least a dozen spare cables, 5-6 running PC's, and 3-4 4L printers. (yes, I have so many printers I don't keep track of how many of each model I have, I just know I've got over 100... really, truly)
by Stephen on Dec 28, 2006 at 7:05pm Add comment
o.k I'm going to try everything you just suggested. If it doesn't work, I'll send you one more printer. -Then again, there might not be anything left to send. I will let you know what happens though, any which way it goes. Thanks for all your help.
-Tamra - Anonymous
I don't think it's the cable because I used a new one and got nothing. It still says that its out of paper. I think something might have happened to the port itself, though the hardware wizard says that its working fine.

I have gotten an error 29. I've searched for the meaning of that error code on this sight (or hp's sight, I can't remember)and it skips right over it. It goes error 26,error 27, "" 28, "" 30, ""31 -I'm being punished for something. Can you tell me what error 29 is?

I also still get a Found New Hardware notice when I boot up, but it can't find a driver and it won't let me know what new hardware it is that its found. I have no new hardware.

I'm getting a bit frustrated/desperate. Do you think you have the answers?
by Tamra on Jan 5, 2007 at 4:13pm Add comment
The fact that you get the found new hardware message means that it sees the printer if that is the new hardware and the best thing to do is to download from the hp web site drivers for lets say the hp 4000 just the pcl5 drivers. Run the hp program you download and remember or rename the directory where the drivers are stored. Then when you boot and get found new hardware you should have a screen where you tell the computer where the drivers are located and at that time direct it to the directory for the drivers you download and see if that works.
by dmzcompute on Jan 5, 2007 at 4:50pm Add comment
I figured it out! I tried my printer in another port and it worked fine -so it was the port that was the problem and it was the port that my computer kept recognizing as new hardware, though its been there and has been used for two years now.

What I did was open my computer, pull out the port, dust it off a little and put it back into a different slot. Everything is sunshine and daisies now. I can't explain why the port wasn't happy in that old slot but all that matters is that it's back and so is my printer. WaHooo!!!

Thank you Stephen and dmzcompute for trying to straighten me out. It helped my just to know that I wasn't ALONE trying to figure this one out.
by Tamra on Jan 9, 2007 at 2:43pm Add comment
I had just the same problem today with my venerable HPLJ4L.

Fortunately I have a couple od spare LPT ports, added when I had multiple parallel printers attached to the PC. Swapped the HP to LPT3; hey presto, problem solved. Looks like the LPT1(ECP) port has sailed into the sunset ...
by gladtobegrey on Aug 28, 2008 at 2:57am Add comment