asked Oct 1, 2006 at 2:06am
Epson Epson Stylus CX6600

Epson CX6600 printing blank pages only

My Epson CX6600 printer will only throw blank pages out... It sounds as it's printing - but there's no ink on the paper.

I bought the epson cleaning solution (here from the site) and cleaned the tubings. When I run a cleaning cycle I can see that ink it placed on that pad - and that it gets sucked into the tubing by the pump. So I guess my pump and tubing is fine.
I've then used the cleaning solution directly where the ink tanks go - and as the guides suggest I've slowly injected the solution... It sounds like the cleaning solution exits from the holes - and if I push the cartridgeholder to the side - I can see a wet spot on the wastepad.
I've then bought some new cartridges and some cleaning cartridges for the printer. I've run several cleaning cycles with the cleaning cartridges - and now I've put the brand new cartridges in my printer.
To start with I started a cleaning cycle - and I could see the ink being places on that little pad - and then a few seconds later beeing sucked down... I then started a nozzle check - but nothing appered on the paper at all.
Now what do I do?
from what I can see the nozzles are not blocked. The pump and tubing is working fine. I've installed new cartridges. Ink CAN go out of the printhead (saw that when running the cleaningcycle).
And there's no warrenty left on the printer.
Any suggestions?
By the way... I also tried re-installing the driver... Just in case that could cause any problems
by GlemSom on Oct 2, 2006 at 7:57am Add comment

Ok, I tried again but with a higher print quality (720dpi)... And there were a little ink on the paper... I then tried 1440dpi and a little more ink were on the paper.
I then run a headclean cycle - and now there's no ink at all again.
I have NO idea what is happening here?

I've uploaded a picture of the top of the two testpages. it's just taken with my phone camera - so the quality ain't that perfect... sorry.

by GlemSom on Oct 2, 2006 at 8:15am Add comment
I have had a CX4800 a CX5400 and a CX6600. The first two lasted 11 months and were replaced under warranty with a similar problem. The CX6600 is just past warranty and I have exactly the same problem. It was working okay although 2 weeks ago it had developed some lines that three or four cleanings fixed. I had to replace the black cartridge and after that only the cyan worked and it was poor. I have tried several cleanings to no avail. I have not used cleaning fluid. I would consider our family use to be regular and moderate. I am looking for the self destruct timer that Epson must be building into these printers. I will let you know if I come across any solutions. Otherwise it may become a scanner. Good luck on your end. I would gladly pay more to get some durability or maintainability.
by Anonymous on Oct 23, 2006 at 3:54pm Add comment
That was my posting under anonymous on Oct 23. I contacted Epson and they referred me to an approved repair depot. Without looking at the printer they said it was the print head and it wasn't worth repairing. Clogged print heads seem to be a common problem and there are several web sites with info on how to clean. I have $80 worth of ink so I kept looking. I found a site about a design flaw and a disconnected hose. I checked my printer and ...the hose was disconnected. It is not an easy repair and I am still working on it. Good Luck
by unknown on Nov 1, 2006 at 10:51am Add comment
The second link was STOLEN from Why not go to for better information. Why support crooks?
by Anonymous on Nov 1, 2006 at 1:20pm Add comment
maxpatchink is really good at stealing things. They used to be customers of ours for the Epson kits. Then they decided to copy it, pictures and all and sell it on their site.
by moe on Nov 1, 2006 at 3:17pm Add comment
My Epson CX6600 will not print from any website.It will print from text documents or programs just fine.I have tried completely uninstalling it and reinstalling.An Epson rep told me to download and install the web to page tool.It made no difference.I then uninstalled it and was able to print from the web just once.Then the same thing happened.The printer says it is printing,but nothing happens.It is online.Any Ideas? Lynn
by unknown on Nov 28, 2006 at 1:14pm Add comment
The pump hose can be manipulated without disassembly, but it takes a bit of a fine hand and some tools (like an offset long nose pliar). Mine was totally clogged with dried ink.

Result: Wouldn't print colors...
Running mulitple cleans just marks your ink as dropping in level when they're really full - their ink level has nothing to do with how much ink the printer thinks it has left...

So I need to get something to reprogram the ink carts... We'll see..
Cleaning this thing was a booger and a half..
by dcg9381 on Dec 27, 2006 at 6:08pm Add comment
Where is the the pump hose? Can somebody point to a pic? - Anonymous
must add different color code from the properties of the epson cx6600
then select the color
it will print
by unknown on Jun 11, 2007 at 8:21pm Add comment
Same thing ! blank pages.
Is ther some kind of a solution,
Cause I have also bought ink twice...

More then the 3 in 1 cost..

Please responce if you know how to fix it!

Thanks for your time

by Anonymous on Sep 16, 2007 at 8:54pm Add comment
I have basically the same problem. Purchased CX6600 all-in-one about 1.5 years ago. Just recently, it stopped printing. The pages feed thru (as in cases cited here previously) and it sounds as if it is printing, but the pages are blank. I had a document that I needed to get printed, but could not. Replaced the magenta cartridge, got an error that cyan was low. Replaced Cyan - still prints blank pages. Called customer support - woman was difficult to understand. When she said "Delete", I could not comprehend the word. She wants to go thru her instruction page and ask me operating system, uninstall printer, reload drivers, etc. which is ok - but I am telling her that when I do nozzle check, alignment and paper feeds thru - I get blank page directly from printer - so, what difference does Operating System make?? But, I went thru the whole routine just so that after 30 minutes she says - you need to take it in for repair. Geez...I am thinking there must be someway to cause Epson some pain for such a poor product - but yet to figure out how. Meanwhile I have a large scanner sitting on my desk shelf.
by daven46 on Mar 6, 2008 at 12:44pm Add comment
My CX6600 is sometimes printing blank pages. Sometimes the copy will be properly proportioned on the page and sometimes it will not. I don't know what to expect from one click of "print" to the next. Is there a fix for this problem? Can someone help?
by jgann57 on Jun 8, 2008 at 5:23pm Add comment
I am very dissappoint about this printer cx6600, it is printing the blank page, I even try head cleaning and checked the ink level, it's still not working;
Is anyone got the solution for this problem, please e-mail it to me? Many thanks!
by unknown on Dec 21, 2008 at 1:56pm Add comment
Is it me, or are people not understanding that if their printer ink is clogged, they should by the $10 cleaning kit to unclog their ink? I just dont get it.
by unknown on Dec 23, 2008 at 3:52am Add comment
I've had a CX6600 for four years and worked great. Suddenly started printing blank papers. Did all the standard troubleshooting per Epson. No luck. Epson recommended shipping to repair.

Did my own troubleshooting. IT's a simple fix. The tube from the ink tray becomes detached from the tube feeding the pump.

1. Press Setting and go to #5 replace cartridge. This will move the cartridge rack out of the way. On the right you'll see a small rectangle ink tray. You'll need to move the small plastic stop (has a spring underneath) to the right. This will allow you to see the feeder tube from this tray. Reconnect using a needle nose pliers.

2. Run the nozzle head cleaning routine a couple times.

After I did this, the printer was back in great condition.

The constant jarring over the years causes the tube to finally disconnect.

Epson must be aware of this; however, it's a easy fix that they can charge a substantial sum. It's also a poor design.

Hopes this helps.
by Tokyo on Mar 7, 2009 at 3:45am Add comment
You sir are a bloody genius my No1 mate, I was told today by my mate to "scrap the useless thing",and be-grudgingly thats what I was about to do. Then tonightI came across your comments. I followed them to the "book" and YES the tube was off and YES,it is a bugger to get it back on,took me ages, but on it went and now I'm waiting for the head cleaning to take effect. NICE ONE SON.
Diolch yn fawr (thanks very much)
Mike - Anonymous
Thanks a million, Tokyo! I followed your lucid instructions, and the printer works like a charm again. Because of the tight space, it's a pain to reconnect the tube, but as someone else said, it can be done (with needle-nose pliers, a small crochet needle, and lots of patience--it helps to also temporarily disconnect the spring)--even by a tech idiot like me. You saved me the expense of a new printer!! - Anonymous
what exactly am i reconnecting feeder tube to?? - Anonymous
Thanks Tokyo, I followed your instructions, and this fixed the problem. Now it prints. - Anonymous
Tokyo YOU ARE A GENIUS !!! it worked like clockwork, the hose was off, just as you described it. superb instructions, followed them perfectly, you need an extra long nose pliers to get at the pipe though.did a few head cleaning and it working perfect now.Epson should put a small hose clip on the hose to prevent this problem happening! Thanks a million Tokyo, you saved me buying a new printer and thank god for this website, i will definately recommend it. good Man!! - Anonymous
>1. Press Setting and go to #5 replace cartridge. This will move >the cartridge rack out of the way. On the right you'll see a >small rectangle ink tray. You'll need to move the small plastic >stop (has a spring underneath) to the right. This will allow >you to see the feeder tube from this tray. Reconnect using a >needle nose pliers.

>2. Run the nozzle head cleaning routine a couple times.

>After I did this, the printer was back in great condition.

>The constant jarring over the years causes the tube to finally >disconnect.

>Epson must be aware of this; however, it's a easy fix that they >can charge a substantial sum. It's also a poor design.

>Hopes this helps.

You Got it just right here, my cx6600 had exactly this issue. Followed instructions and solved the problem. Not easy to get to it, but can be done, my printer is as good as new. Thanks for that.

by Anonymous on Mar 11, 2009 at 2:22am Add comment
Glad it worked for you. Also, had a co-worker with a different Epson printer, but turned out to be the feed line also. Epson got to change design.
- Tokyo
when i got to #5 the cartridge doesn't move at all. it stays to the right - i can't get to anything. what am i doing wrong? - Anonymous
Really glad this worked. There's been several people (friends and co-workers) who have Epson, since they work in Japan, and have experienced the exact problem. I email Epson technical support about this problema and highly suggested they incorporate this in the troubleshooting process. Epson said they will consider this.

by Anonymous on Mar 23, 2009 at 2:45am Add comment
nevermind - i figured it out, but have now lost the 2 springs and cannot get it back together. i've just finished washing all the ink off my hands! dammit! i'm off to buy a new printer....
by Anonymous on Mar 31, 2009 at 6:23pm Add comment
My hat's off to you who have the dexterity, patience and persistance to actually work on this tube problem. I don't have any of the first and am losing 2 and 3.

I can see the tube but can't tell if it's disconnected or not. I've tried pushing it around with a long screwdriver and gently tugging it with needle nose pliers but can't get it to move much so I'm thinking it's not disconnected. Could there by another problem I can check on? If not I'm headed to buy a new printer. Do all Epson printers use the same design? I'd like to use the $75 worth of ink I just bought but not anxious to run into this issue again.
by sdrushella on May 20, 2009 at 12:55pm Add comment
With a little of all 3 I was able to take the short black tube off and clean it out and have gotten to getting it to print but not very clearly. I've printed several copies and it's not getting any better. Have run the nozzle check multiple times and the head cleaning. While it obviously helped it is still not acceptable. Any help out there at this point?
by sdrushella on May 20, 2009 at 2:11pm Add comment
I took my printer COMPLETELY apart and thoroughly cleaned the hose of all the dried gunk, still nothing. The hose was not disconnected but very plugged as I mentioned. what else would you recommend I try to get this expensive "paper weight" working again? Thank you in advance for any advice you may be able to give.
by unknown on Jan 20, 2010 at 7:56am Add comment
Glad you were successful. CX6600 is a good printer, except for this major design problem.
by Tokyo on Mar 26, 2010 at 6:29pm Add comment
face it folks, this cx6600 sucks and is a total joke! epson should ashamed to put out such a poorly designed product that works well for such a short period of time. HP printers suck also!
Into the recycling goes my cx6600...thank god the nightmare is over!
LOL what a piece of D U N G !!
by unknown on Apr 10, 2010 at 1:41pm Add comment
Absolutely right! Ever since the original Stylus 720, Epson consumer inkjets have sucked ass! Tiny over-priced ink cartridges, and a built-in self-destruct timer seem to be Epson's way of getting our money... but NO MORE!
We must hit them where it hurts... STOP BUYING THEIR CRAP!
by raboyoung on Apr 11, 2010 at 5:24pm Add comment
Thanks for the information. I got luckier than most in that my tube was not disconnected but that rectangular ink pad you note in your fix was caked with gunk and the area around it was quite messy as well. Before I tried to take everything apart I cleaned that area and did a quick head cleaning and viola it was working again. Anyway just a quick word to say that a good first step if the tube is not obviously disconnected is to simply clean that pad and it may help resolve the issue. Cheers!
by unknown on Jun 22, 2010 at 7:07pm Add comment
ooops of course I meant Voila not a musical instrument. Damn quick fingers always get me in trouble.
by unknown on Jun 22, 2010 at 7:13pm Add comment
Tokyo,Rubber Dog and other friends,my Epson DX3800 worked well until 2 days ago.I have printed a coloured document from internet and then made 2 photocopies,then when I continued,it was blank pages,very clean blank.I have checked the feeder tube,it's black,I supposed that's it.It doesn't look disconnected.But as suggested by Rubber Dog,I noticed the ink pad underneath the ink tank is very saturated.Could that be a problem,how can I clean it?Anyone can give me a hand,I need to repair it for work purpose.Thank you.
by scmalnis on May 5, 2011 at 12:19am Add comment
Just wanted to say thanks!! Have had my cx6600 for 7 years, and this is the first time I've ever had a was disconnected. Got to look like a genius for my hubby too. Thanks a million!
by unknown on Aug 7, 2011 at 12:51pm Add comment