asked Feb 27, 2006 at 6:54am
Canon Canon Personal Copiers (PC) 6

Canon Pixma iP3000 service error 5400

I purchased an iP300 printer without warranty and my son installed it with a CD from another iP3000. The printer would print pictures but not text and would not print black on test pages. I downloaded the drivers from Canon and installed them. Same problem. After looking in Canon's FAQ I thought that the print head might not be connected, so I took it apart and found no connection problems. Thinking I had nothing to lose,I took apart the print head. The black Channel was filled with gunk. I soaked the whole print head assebly with ispropanol, followed by hot soapy water and with the help of syringes,needles and some plastic tubing got the ink passages cleaned out. I then rinsed the assembly with acetone in an attempt to dry water from the wiring. I installed the head, turned it on without the plastic cladding and got service error 5400 when I tried to print a test page.(alternating green orange flash for 8 times then 6 times then repeats the 6 flash forever ) I replaced all the cladding and got the same errror. I let the printer dry overnight with the power off. Next day same problem. I found this web site and tried a technique mentioned in another post of plugging in power while holding on the power switch, and toggling the resume while holding power . No change. Anyone have any ideas Thanks John
Since I have 2 iP3000's, I switched print heads, and the one I cleaned works fine in the other printer. I have to go home from work to do the reverse switch. So somehow I messed up the other one in opening it.
by JAClement on Feb 27, 2006 at 10:03am Add comment
So the 5400 service error was caused by a faulty printhead?
I have the same problem, still not fixed yet
by desigur on Apr 9, 2009 at 1:38pm Add comment
JAClement,... the 5400 error is telling you there was excessive temperature in the printhead, and this error code will stop all printing attempts.

Unplug the power from the printer and leave it off for a hour and then check the pins inside the carriage and clean them and clean the contacts on the back of the head. One other thing to try would be to initialize the EEprom on the logic board. Search this web site for "Service Mode" and follow the instruction on how to get into that mode. Then press the resume button 3 times and then the power button and this will initialize the EEprom.
by unknown on Apr 9, 2009 at 9:48pm Add comment
After surfing many sites from googling & seeing complex answers that I didn't understand & worked for some & not others, I found a non elegant QUICK FIX SOLUTION to Pixma IP3000 does not print black and/or Error 5400:
Under Printing Preferences: Set your Media Type to Photo Paper Pro
by unknown on Dec 18, 2010 at 11:26am Add comment