asked Jan 19, 2006 at 2:51pm
Epson Epson Stylus Photo RX420

RX420 protection counter

Last year I purchased an EPSON RX420 all-in-one printer and I have to say the quality is spot on, but it stops there, After only one month I noticed that my ink cartridges diminished far to quickly compared to what printing I was doing, also as one of the other group members mentioned in this forum if you run out of any colour you can not document print, Black only, because the ink monitor renders your machine useless because you have to change the colour responsible which defeats the object of having separate cartridges, to cure this problem I was told to update the status monitor 3 and it works the one supplied with the set-up CD when purchasing the printer was out of date, so this may help anyone having trouble in this line.
However, everyone knows that Epson is paranoid about using there own Ink cartridges thus there printers are chipt to the hilt, after only a year with the RX420 I started to get the service window popping up on every print job telling you the parts in your printer require servicing, it is a pain in the back side, I have managed to endure it over the past week but something drastic seems to of happened, all the indication lights on the printer are flashing with the ( E ) error message and I can not get them to stop other than turning the machine off, I am unable to tell if this is related to the fact that the machine requires servicing or not, unfortunately this error renders the machine useless because I can`t get at the ink cartridges because I can`t get the machine to function correctly.
I have received some information that this could be solved using the eeprom protection counter software but I am not able to acquire it, so if anyone can crack this problem I will promise never to watch Big Brother ever again, honest.
You have a maintenance request error. You can reset the protection counter using the ssc utility from here

It is a good idea to replace or clean the absorber "waste ink" pads.

I hope this helps,

by Anonymous on Jan 19, 2006 at 4:25pm Add comment
this software does not work on the rx 420 series even if pads are replaced. anyone know what DOES rest the machine? - stobby2
I have had the same problem with mine and will be going back to Hewlet packard pretty soon!!! nice looking machine but totally impracticle!! I bought new cartridges recently cleaned the head 5 time it want print and the cartridges are saying they are less than half full not even printed anything been told to take it to my local epsom service centre where i will be charged £17.50p to have the heads cleaned what a heap of junk I can tell you right now what I think after paying £29.99p for new cartridges which includes 2 packs of photo cards which I will never use.

I can tell you now what Epsom can do with this heap of trash ps I tried compatible cartridges put they were not excepted at all.

by akibar on Feb 3, 2006 at 3:42pm Add comment
this RX420 is the biggest crap ever seen!

some years ago i sucessfull reset a RX420 with the utility, but don't remember how ... someone can help me there?
have to to it on the second RX420
I have one set of inks that i don't want to put to trash with the printer, i want to reset this piece of .... and use the inks - when empty we get also a HP again.
nothing's better then a canon or hp ...

by unknown on Oct 29, 2009 at 7:55am Add comment