asked Oct 12, 2005 at 2:28am
Canon Canon Color Bubblejet (BJC) 80

Canon mp390

Hello everyone,

I have a customer who brought this printer in just three months back with print problems. Replacing the printhead did the job back then.

It has now returned with the same problem, just as though the head is blocked again. I don't think she'll be too pleased if I tell her to spend another £80 on a printhead... who would be?

Any advice of how I can sort this out?

Ta muchly...
I have a Canon Mp390 and right now I have a problem with a jammed cartridge. I have read through the troubleshooting directions but that did not help at all. I have used a flashlight to see if there is anything jammed and the only thing that I saw was black ink covering one of the sprockets. Does anyone know what to do?
by unknown on Dec 12, 2005 at 4:26pm Add comment
I am having the same problem. Please share any "fixes" suggested.


Grappler - Anonymous
I have a jammed cartridge. Did you get a fix for yours? - Anonymous

Just got the same problem
Any ideas??

Al - amck
i was wondering if you fixed your problem and how you did it. I have the same problem now. Jammed cartridge noises cant come to the middle and is stuck on the right side - Anonymous
hello jamtam21 if you solved this problem, and have time to reply, i'm all ears!
my machine makes a continuous takatakatakataka noise on startup, and gave me this "cartridge jammed" message....

thanks, paul - Anonymous
The blowing through the little holes in the top of the ink cartridge has worked for me twice. By pulling up the gray lever, I removed the whole print head and left the ink cartridges in. I didn't have a regular straw, but remembered that I had a water bottle with a plastic straw. I cut off about two inches and put it over the hole and blew...and as suggested I had a piece of paper below because the ink came through.

The other day I ran it out of ink. Should have paid attention and not set it on 25 and walked away. So when I put in a new black printing again. Tried the blow through the hole and it worked.

Thank you thank you to the people who discovered it tip above and took time to psot it it. I didn't even try the soak and air pressure. Just thought I'd try the straw. Great Tip and it worked both times. Thank you again. Mary
by starbright57 on Jan 22, 2007 at 2:22pm Add comment
I have an error code ##345 on my mp390 printer. I spoke with Canon support and they advised this is a print head problem. As my printer is 18 months old and out of warranty I decided to buy a new print head and install it myself rather than pay for their engineer to come and fix it, but when the new print head arrived it hasn't worked any different - I still have the same error code ##345 - does anyone know what I've done wrong.

Thanks for your help.
by jaja4421 on Jan 28, 2006 at 1:15am Add comment
I have the same problem. I was making a copy and it just made a loud weird sound and the LCD display told me the cartridge was jammed. Did you have any luck getting unstuck?

Pete - Anonymous
I am having the same problem it seems as lots of other people, whereby my printer goes through all the motions but fails to print! I intend to take the above advice and clean the printer heads with hot water and dry etc...but I dont even know how to take the printer heads out! I am so fed up with it, mine is little over a year old also and being in last year at uni...really cant afford another, so thank goodness for people like you guys who are here to the rescue! Please help, thank you x
by unknown on Feb 22, 2006 at 2:05pm Add comment
I'm having a problem with a MP360. I get a message that says the cartridge is jammed with error code 5100. I've tried changing cartridges as well as cleaning the head. First, what is error code 5100? Next, are there any other suggestions as to what I can try to do to resolve this problem?
by Anonymous on Jun 1, 2006 at 11:00pm Add comment
cartridge jammed error message - any suggestions on what to do, the cartridge just keeps moving from side to side so cant get it out and cant print either- any help appreciated. it only three months old!!!!

by unknown on Sep 20, 2006 at 4:15pm Add comment
Hi have a client bought a MP390 to me paper won't feed. So far I have removed an obstruction from deep within the machine. There must be more I need to find out how to dismantle it down to the rollers. Have you go an instruction manual on how to do this.'
Yours Steve
by unknown on Nov 5, 2005 at 3:45pm Add comment
Hi I have a mp390 and I have just replaced the printer head as advised by Canon support for not printing. It is still not printing. It goes thru the motions but nothing on the paper. Ink is in the cartridges as there is ink at the bottom of the new printer head. I have refreshed and done a nozzle check. Still nothing. It is barely a yr old and no longer under warranty. Canon will be happy to sell me another with a discount code of course or I can have it repaired at a service center 100 miles away. Any suggestions? Very frustrated! Thanks.
by lisa702 on Dec 20, 2005 at 5:02pm Add comment
I am having the same problem. All of a sudden my printer stopped printing black. New ink, deep cleaning - nothing seems to work. Have you figured this one out yet?

Thanks - [email protected] - Anonymous
I have the same problem after having had the printer for under a year. I am probably going to take it apart tonight and try to see if that works. Did you ever come up with a solution?

Fabian Newman - Anonymous
It sound just like the problem I am having , I called a shop that repairs them and they said it is the primt buffer . If it si out ov warranty it is not cost effective to fix it . sorry - Anonymous
Hi I hope someone can help. My printer I have only had for about 7 months, it jams when the paper starts to feed and I need some help on how to fix this problem.It has not worked sence about 2 months after I recieved it, I just finaly have time to mess with it .
Thank you ,
by sweettweet1974 on Jan 25, 2006 at 10:08am Add comment
I have an MP390 printer that the printhead is stuck on the right side and won't move back and forth to print anymore. When I turn on the printer is makes a loud clicking noise like the gears are not moving and then I get an error message say that check printer.

I have done everything, like clean the printhead, changed the ink cartridges and even cleaned the inside with compressed air but nothing works, won't print.

Can anyone advise me as to what I could do to fix this problem?
by sweetitalian on Jan 27, 2006 at 2:30pm Add comment
How you fixed the problem with CHECK PRINTER? - mp390_1
Paper won't feed on left side, so jams when feeding starts. We have vacuumed to remove any debris. Still not fixed. We have gone thru the cleaning and the cleaning roller functions, but still no go. We were thinking that this must be planned obsolescence, because the machine appears to open only with a jig, which of course we don't have. Any Ideas???
by gabymiller on Feb 7, 2006 at 11:10am Add comment
Same here - starts to feed on right hand side but the paper is not taken in on the left. Doesn't actually mention paper jam cos it hasn't taken any paper in - just asks to load paper. Anyone fixed it? - Anonymous
by unknown on Mar 7, 2006 at 4:37am Add comment
Ok with the printer head jammed to the right....I found the cam gear was broken....which you basicly have to unsnap the blue plastic on front of printer and then vertualy take every screw out of the unit to get to the cam gear on the right hand side and under the ink tank....lots of fun....still trying to locate part.........from that tickk tick tick noise - Anonymous

Did you fix problem Tick tick tick loud noise and cartridges jammed by your self? can you tell me the steps. thanks
by Anonymous on May 19, 2006 at 9:22am Add comment
it seems to me that you are quite familiar with the MP390. id like to ask a big favor - im having a problem now with my MP390's scanner. i cant get it to work, i can copy documents and pics though but i cant scan them. my memory card readers too doesnt work. any suggestions on how to fix these? i am really hoping for your soonest reply. Thanks a lot in advance! =)
by Anonymous on Jul 10, 2006 at 11:10pm Add comment

With all the reading, I have decided to never buy a Canon printer or multifunction again, my MP390 stopped printing even after replacing with new carts and cart head..I wasted money on carts..why shud we be here having probs with our Printers..I used Epson and HP and never had probs like above..with HP its just the price of the carts..Canon just manufacture rubbish really

by Anonymous on Aug 8, 2006 at 6:46pm Add comment
Doesn't anyone see a serious problem that we HAVE to do any of this to get our printers working again? I've been trying all day using rubbing alcohol, paper towels, Q-Tips and compressed canned air and I'm still getting absolutely NOTHING out of my black side.

Canon has obviously manufactured a faulty, defective product here, yet refused to even acknowledge that there is a problem with it. My last printer was an Epson and it was even worse - it went to the scrap heap within a year of purchase.

I'm trying the soak in boiling water now, and I'll try the "straw method" too, but shame on Canon for this piece of crap. Is HP our only choice, with its $100 ink cartridges??
by Anonymous on Dec 16, 2006 at 2:41pm Add comment

Sorry, no manual. I've had a 390 in twice and it's been head problems only. Haven't stripped one down at all. I'm sorry I can't be more help.

by merlin on Nov 6, 2005 at 11:50pm Add comment
I have an mp390 myself and i just moved, it seems during shipping that the belt for the scanner head has slipped or got bumped off the gear that runs it. Any directions on how to take the scanner apart to have a look inside?
by Anonymous on Nov 21, 2005 at 8:56am Add comment
You will have to use a butter knife to pry the LCD panel open. You will see 3 to 4 small finger nail shape tapes, take these off and save them, then unscrew all those screws, then disconnect the ribbon cable to the LCD panel. Remove the panel, now unsrew all the screws on the back of the printer, and take the back cover off. Now the side covers are loose enough for you to remove the scanning unit by gently pull either left or right cover to seperate it. You will see 3 holes on the back of the scanning unit with 3 black screws, remove these, and use the butter knife to pry open the black and blue housing. Be careful with the glass, it may come off from the top part, use scotch tape to secure the glass. Now you can put the belt back on and reinstall the black and blue plastic housing by snapping them back together. Connect the ribbon cable to LCD panel, connect the power and test run the copy function. If this works, you can unplug the power cord and reinstall all screws. Your printer should be back in business in 2 to 4 hours. If you have more question, email me, I will walk you through the process. - ricknguyen
Sorry for this dumb question. How do you change the cartidages. Please email me [email protected]
by Anonymous on Dec 29, 2005 at 5:26pm Add comment
Dear Shlyden
No I haven't but do you have cleaning cartridges? That may be all you need. That'll clear out any dry ink in the printer head and/or nozzles. Good luck.

by Anonymous on Dec 30, 2005 at 4:50am Add comment

Did you try the copy function to see if it prints?
by Anonymous on Dec 30, 2005 at 5:00pm Add comment
Yes I tried the copy function and no ink on paper. I was waiting for after the holidays to have it serviced.

by Anonymous on Dec 30, 2005 at 5:47pm Add comment
hmmm, Did you see or hear the printer operate normally except without ink ? I have mp360 and mp370, both had have print head problems before. However I soaked the head in hot water with the ink tanks removed and voila they both came back alive and well for almost 3 months without a problem. May be you should try it before take it in for service! Use a disposable bowl and put 1/4 measuring cup of HOT distill water and dip the print head, the side that you can see the metal part until no more ink come out. Dry it completely with air compressor preferably and print test the thing. Do this with your old print head first and let me know how it is going to come out even with a slight improvement. Good luck and hope to hear from you soon!
by ricknguyen on Dec 30, 2005 at 7:59pm Add comment
The printer works normally except there is no ink on the paper. I 'll give it a shot.........what do I have to lose, right? :)Thanks. I'll let you know if it works.

by Anonymous on Dec 31, 2005 at 4:48am Add comment
Well I tried soaking both print heads and then deep cleaned and nozzle check after printer is just printing the blue color.......should I try resoaking again or what? Thanks for your help.
by Anonymous on Jan 6, 2006 at 9:10am Add comment
You are almost there, at least it did print out in blue. Do not use the deep cleaning as Canon suggest, this will cause other error problems when the waste ink pad filled with waste ink.
You will need an air compressor to blow directly into the tiny holes on the print head after soaked in hot water. You will see ink come out from the inside, just use a piece of paper towel stuff it in there to absorb the ink. Repeat if nessessary until no more ink come out. This shall work, I guarantee it. As the rule thumb, when it show that the ink running low, replace it and do not try to squeeze more prints from that cartridge because it will permenantly the print head. By the way, you can bring it to the gas service station and ask if you can use their air compressor, and have a thermos filled with hot water ready..! Good luck and let me know after you done.
by ricknguyen on Jan 6, 2006 at 7:42pm Add comment
I'm working on soaking but was wondering, should I replace with new ink cartridges before trying again? Thanks

by Anonymous on Jan 8, 2006 at 4:10pm Add comment
You do not need a new cartridge, unless the old one is running low.
by ricknguyen on Jan 8, 2006 at 11:26pm Add comment
Well I tried it and now its not printing anything and I changed the ink cartridges too and nothing. I am very frustrated now.

by lisa702 on Jan 9, 2006 at 2:15pm Add comment
Lisa, you need an air compressor to blow directly into the print head, and also the water that trapped inside. This is the only way that you can clear the clogged ink. I wish I can do it for you if you live in Orange county, california. - ricknguyen
How do you remove the print head to soak it?
I have a MP390 and I think I have problem with the ink clogging up.
The unit goes thru the normal steps, making all the sounds it is
supposed to make but the ink comes out very patchy and then
completely blank even after I replace both tanks or perform all the
typical maintenance such as deep cleaning ...
by dpham on Jan 9, 2006 at 4:12pm Add comment
1/ Just lift the scanning unit upward, the print head shall move to the middle.

2/ Remove both ink tanks

3/ Lift the gray lever or handle, the print head will pop up.

Refer to the privious posts to clean it, remember do not use the cleaning procedure as recommended by the manufacture. - ricknguyen
I tried the air compressor and blew it from the bottom into the printer head until no more ink came out.......there were actual particles floating in the water after soaking so I thought all would be well.....then blew the air thru until no ink.....and BTW I live in Lake County Florida :)

by Anonymous on Jan 9, 2006 at 6:29pm Add comment
Thanks Rick.
Soaking the print head helps but now it only prints every other line. What could be wrong?
by dpham on Jan 9, 2006 at 11:24pm Add comment
You will need an air compressor to blow directly into the tiny holes on the print head after soaked in hot water. You will see ink come out from the inside, just use a piece of paper towel stuff it in there to absorb the ink. Repeat if nessessary until no more ink come out.
by ricknguyen on Jan 10, 2006 at 3:54pm Add comment
I am soo excited! I have black ink and yellow too! Faint but THERE! I used boiling distilled water this time instead of just hot. I'll do it again but have to wait for my husband to reload the little air tank for me! Thank you Rick!

by lisa702 on Jan 11, 2006 at 4:18pm Add comment
I am glad that you did fix it yourself and very proud of you... - ricknguyen
My elation has turned into frustration......did the soak again today, several times actually, and no ink at all is printing....

by lisa702 on Jan 12, 2006 at 3:27pm Add comment
It must be the water still trapped some where in the print head. Make sure that you use air compressor to blow the water out. As you mentioned in the last post that you used a small air compressor, I do not know if the air presure is strong enough to force the water out from the tiny holes. Mine was set at 120 PSI, I was able to remove the water completely.
Can you ask your neighbor or friend to use their air compressor, or bring it to any auto repair shop, I am sure they will let you use their air compressor. - ricknguyen
Hi I'm having same probs with my mp390, after just renewing printerhead. Only get faint pink, no other coulours. Wondering what happened to lisa, and your printer. Dont want to try soaking it as is Brand New printerhead. My printer must be around 2 years old and have already replaced print head once before. Any help welcome. Know if get it serviced will prob end up costing nearly as much as new printer. - Stomped

I have MP370 and have problems with black printing. Tried everything. I don't have air compressor, would hairdryer work get rid of water after doing the soak procedure?
by unknown on Jan 13, 2006 at 9:54am Add comment
OK, I've soaked the head twice -- and got stuff out each time. I did it until nothing more would come out. Then I blew it out very carefully with an air compressor until it stopped blowing bubbles on the inside, and then blew it a little more.

But alas, when I reinstall my ink cartridges it won't print anything -- not black and not any of the colors. What else should I try? - TLC
Forget my last, I did the soak as recommended by Rick and then let it drip dry for 10 mins before geting the wife's hairdryer to it on COOL setting until the last apparant drop of water had gone and bingo, my MP360 is running like a baby. All colours tested and black back to its original quality.

No more non Canon cartridges for me. I blame the Tesco cartridges i have been using for the last six months!

Thanks to Rick from Plymouth, United Kingdom!
by unknown on Jan 13, 2006 at 11:35am Add comment
I soaked the print head again, 3 times with hot water until no more ink came out. I then blew in the holes with my mouth (I am not sure if it even needed). Afterward I left the print head to dry on a sheet of paper towel for a long while. Put it back in and the printer worked like a charm. Thanks Rick.
by dpham on Jan 13, 2006 at 3:52pm Add comment
I've been reading these posts with interest. My MP390 has quit printing black. I noticed a lot of extra ink on the bottom and back side of the print head, so I used a paper towl with rubbing alcohol to clean it off. Now it will print color but no black at all. I'm going to try the hot water and air compressor trick to see if I can restore it.

I have been refilling my ink cartridges. I bought some high quality ink, but wonder if perhaps my ink could be the cause of these problems. Do you have any thoughts or feelings about this?
by TLC on Jan 15, 2006 at 11:58am Add comment
TLC do the soaking thing, on the head itself and inside the the little trough where the cartidges go. Make sure water runs clear, use freshly boiled. When running clear, dry using compressor or hairdryer or both to ensure completely dry then try. I would only use canon ink from now on.
by unknown on Jan 15, 2006 at 12:35pm Add comment
I would try soaking with boiling water as many times as needed. It seems to me that the ink clogged up the print head or nozzle or whatever.
I had my MP390 for maybe a year without problem when I used high quality ink. It started a couple months after I bought some cheap ink off Ebay.
by dpham on Jan 15, 2006 at 2:34pm Add comment
I have a cannon MP390 that worked fine for about a year, but seemingly all of the sudden, it stopped working. The paper will feed on one side (closest to the LCD), but on the other side it gets jammed and won't go into the printer. i've got the top taken off. what next?

by Anonymous on Jan 15, 2006 at 8:09pm Add comment
Check to see any small object fell into the paper path. You may have to turn it upside down and gently shake, this may be the only problem. - ricknguyen
Soak the printheads in diluted alcohol (I used cleaning spirit also) and then leave the printheads in a container full of water overnight.
I have two sets of printheads for the MP390 (as your customer does) so I leave the spares in containers full of water. It ensures that I have clean printheads each time the ones in the printer start to 'foul' due to inks and continuous use.
by Anonymous on Jan 16, 2006 at 11:47am Add comment
The ink is water suluble, so why spend money on diluted water when 100\% water is free from the tap? Hot water works a lot better than diluted alcohol. - moe
I tried soaking again and nothing......My printerhead was new too and nothing.I forget where I bought it from but it was not returnable once removed from the package.

by lisa702 on Jan 22, 2006 at 4:23pm Add comment
I have same problem machine work fine but will not print anything on the paper.
by Anonymous on Feb 12, 2006 at 6:25am Add comment
My printer stopped printing after I accidently pressed "deep cleaning" instead of regular cleaning because of white streaks. I soaked the printer head in about 1/4" of boiling distilled water, then blew it out from the bottom with an air compressor with a special pinpoint adapter. It goes thru the motions as if it is printing, but no print on the paper - nothing, not even a faint print. I do Not have an error msg like mentioned above. Do you still think it may be the printer head? Pls help.
by kmmkeri on Feb 12, 2006 at 10:33am Add comment
Do the water soaking once more, and try to force the water that may be trapped between the housing case and the brown ribbon cable with the air compressor. You should soak and blow the air directly into the tiny holes until no more ink come out from the inside of the print head. - Anonymous
Ok, I have given up on trying to get my MP360 to print (for now). I have before me my friends old, dusty Epson Stylus Photo 1280 that I will use until I can repair the Canon, IF I can get it to Print. I connected it using the same USB cable.(It also has a parallel cable port on the back) Added a printer thru the Control Panel. Since I do not have a disc to install the driver software, I connected it as a Plug & Play. At first, the red ink light was flashing, now it is solid red. I would hate to spend $30 or so on new ink cartridges, if I cannot get IT to print. The print jobs are spooling on the print que, but will not print. The ink in the cartridges is still wet. Please someone...tell me how to get this thing print. - Anonymous
addition to above: I have also changed out the ink cartridges to new ones - still nothing.
by kmmkeri on Feb 12, 2006 at 10:35am Add comment
Thanks for the response. I've been soaking and blowing practically all day, and still nothing. Something else I noticed after the "deep cleaning" is that there is a loud "click" sound when the carriage moves away from the right side, as if it is getting caught on something. I'm wondering if something misaligned the print head? I will soak it overnight and blow dry in the morn. This printer is detrimental to my small business, so if nothing in the morning, will have to break down and buy a plain cheap printer. I did say "small" business - lol.
by Anonymous on Feb 12, 2006 at 7:29pm Add comment
The previous Anonomous was me, kmmkeri.
by Anonymous on Feb 12, 2006 at 7:34pm Add comment
sorry to have troubled you all - mine started printing again once I took a protractor out of the paper feed! hope you all fix yours as easily!
by Anonymous on Feb 13, 2006 at 12:04pm Add comment
My MP390 no longer asks me if I have changed the ink cartidges. Instead it tells me "black volume unknown." I am also having problems with nozzle checks where I am missing some lines on the test and my black ink blocks are striped rather than solid. I have tried cleaning the print head and also aligning the head but nothing has help. Canon told me the circuit board is gone and I need a new printer. It's only 4 months over the one year warrenty. Any suggestions? Thanks, Rose
by unknown on Feb 26, 2006 at 5:22pm Add comment
I have had all of the above problems at one time or another. For paper that won't feed- even if you think that you pulled every possible thing out that could have been stuck, there could be more. Look for cheap parts that have snapped off from the inside too. Check not only where the paper feeds in, but also where the printhead glides by.

About a week ago, a little metal clip that holds clip that snaps in the bottom of the interior cam loose and jammed the print cartridges to the left side. (Sounds like some of the jams listed above.)

After fixing the jam, no black on our print outs and on the top row of color boxes, the blue is half filled in (on top) and half vertical lines. On the bottom row the blue if fine. However, the black box on the bottom is vertical lines.

Soaking now. . . but I think it is odd that sometimes (and predictably) it does print as it should but then sometimes (and predictably)it is incomplete.
[ ] = 1 solid blue box;
[ ]

[ ] on top the top row
[ ]

[ ] on the bottom row

by schlottjl on Feb 28, 2006 at 11:57pm Add comment
I have the same problem with an mp390, when is going to the left side is making a small noise...hissing type, and then the message with the jammed cartridge appears...nothing i can do to the printer after that...I think is a mechanical problem...anyoane solved this one,

Dan - Anonymous

How 'bout this one...

I have an MP360, I coulnd't print black, just like many of the above posts. I tried most of the solutions I could find; hot water soaking, alcohol soaking etc..

I gave up on that, called Canon and ordered a new print head. Today I installed the new print head, a freshly purchased black cartridge and still NO black printing.

Could this be a circuit board problem? Help!
by unknown on Mar 13, 2006 at 9:23am Add comment
i'm having your exact trouble , any luck on yours ? - Anonymous
Had the canon mp390 for 6 months now and have been soaking the parts in hot water every couple of months but this technique no longer works.

Strange thing is that the black type starts off well then a line will be faded out at the begining only to come good at the end of the line. I have been using the test page and the problem is repeatable, it fades out and in at exactly the same places in the same lines over and over each time I run the test print.

I don't print too often so i am not surprised if the inks dry out a bit and i use Calidad Inks instead of canons ( I have probably saved the cost of the printer anyway ).

I did notice that where the 'Home' for the printer head is on the right of the machine there was a lot of black ink pooled, not knowing if this was good or bad i mopped it up with some tissue, anyone know if this pool was meant to be there, i did a lot of deep cleaning in the misguided view that this would clean the print head.

I think I will go back to epson after this, if it was just me having problems I would put it down to the way i treat the machine but it seems to only have a 1 yr lifespan anyway.

by MarkL on Mar 15, 2006 at 11:06pm Add comment
Mark and all other members of this forum,
never use tap wather because it will have the same efect as in a washing machine if U don`t use the right detergent; the impurites in the wather will stick to the inside of the print head; if U don`t have distiled wather boil some...about 2-3 liters...let it cool and then warm it up, than with a 100ml seringe and a straw(tube) at the exactly the same size as the inside of the print head nozel force the wather the same direction that the ink flows(from the inside) in this time U sould be able to see the wather that comes out throw the tiny holes just like a small shower but with hols in a single line. Repeat this at the color nozels until U can see that small shower at every row.
After that with the same seringe and the same straw(tube) push air thru the nozels 2-3 times at every color K M C and Y and let it on an HOT wather base radiator for about 3-4 hours in a plastic bag with zipper sow no dust will stick to the nozel holes.
After the print head is dry, with new ink cartridges perform 2 normal clining operations and a print test page.

If that dosen`t work U need to use a ultra-sound machine that will disolve the ink in U`r print head.

Sorry for my poor english I am from Romania :)

P.S. Never use Alchool in time will affect the print a bad way.

by mariusmaxx on Mar 16, 2006 at 7:42am Add comment
Hello! I have a problem with my mp360. It says CARTRIDGE JAMMED with error 345 and 5100 . Please tell me what to do?? HELP!
I need it for tomorrow..please reply.
I am from Romania too . - Anonymous
Our printer stopped printing -- we use 3rd party ink. My husband researched everything he could on the internet on how to clean print heads, etc. We tried 3 printheads that we had, 2 of which were supposed to be "new" Canon printheads ... sealed in the package. Nothing we tried worked. Hot water soak ... air pump drying ... Finally we bought a new LexMark printer. It works great!

Before throwing the Canon MP390 in the trash, I decided to try one more thing. I got to thinking about the fact that the ink and/or the print head were already dried out, so why was I bothering to dry anything? I soaked the print head in about a 1/4" of denatured alcohol (from Home Depot) for about 10 mins. I also soaked the ink cartridge "heads" in the same container of denatured alcohol for about 3-5 mins. I blotted them with a paper tower and shook them off, and reinstalled them in the printer without thorough drying. I ran 2-3 printer tests, a few head cleaning cycles, a deep cleaning or two, and believe it or not, my printer is working like new. I installed it at our 2nd computer, and it is working just fine. I think the alcohol helped dissolve any ink that was dried up, and provided a "medium" for the ink to flow through in the print head, if that makes any sense.

Hope this works for some of you!

by unknown on Mar 17, 2006 at 8:04pm Add comment
Here is my story. My MP390 B/W head had the same problem as described in many of the posts-- Printer seemed working fine but no black ink out (color was fine). So I bought a sealed "brand new" printer header. This time both were not working.

Wife had tried several ways described in the thread about using alcohol, hot water, etc, except we did not have an air compressor. So, one day wife looked at the stuff and was thinking whether we should throw it away and she found out the little hole on the top of the ink cartridge. What she did was to use a straw (for soda drinking) and blew air towards the hole (tried not to have any opening between the straw head and the top surface of the cartridge; AND keep the cartridge IN the printer head. The amazing thing happened, the black ink from the other end (underneath the printer head, not the cartridge) came out and when I put it back, it WORKED. Since we washed the head for several times, the color part was having the same problem. So, I tried the color side the same way and it worked as well. Now, about two weeks after and two ink cartridge changes, the printer works as new.

So, this is our experience and I am not sure whether it would work on anybody else. But I think this may be one way worth to try.

Cheers - Anonymous
Will try using distilled water as advised and see how that works. Has anyone tried using detergents as well?

On a side note, I went out to buy a new print head today and the guy in the shop said that they didn't carry any of them as they were too expensive but suggested buying a printer that also takes the B24 ink carts, stripping out the print head and dumping the rest of the printer, it seems wasteful but if the printers are on special offer it works out cheaper.

Anyone know what other printers would have the same print head and whether they are interchangeable ?


by unknown on Mar 18, 2006 at 8:20pm Add comment
I have recently been having problems with my print head on my canon mp360. My black print head keeps on smudging all over the place but my colour is fine. I have tried to clean with cotton wool but still no good. Do i need to buy a brand new print head and if so where do i get a cheapone rather than a really expensive one?
by d239202r on Mar 24, 2006 at 3:38am Add comment
My Canon MP390 just started making a gear-stripping-clicking noise. I took it apart, as it is 3 months over warranty, and see that the clicking seems to be the little waste ink pad holder. Anybody know what might be the problem. I am much faster at taking all the stuff off the second time! BTW I have had very good luck cleaning clogged print heads with just some Q tips and rubbing alcohol. Wet the bottom of the head thoroughly and also put some on the little pad where the ink tank contacts the print head.
by unknown on Mar 24, 2006 at 11:49am Add comment
Hi I have an MP360 Printer and I have exactly the same problem Tick tick tick loud noise and cartridges jammed to the right hand side wont come out to the middle.Did you ever fix your problem and is there an easier way??
by Anonymous on Mar 31, 2006 at 3:31am Add comment
My story is quite similar to yours. I tried every suggestion with cleaning the cartridge but rather than my original problem of no black printing, the color disappeared. This was after several cleaning with distilled water, alcohol, etc. Eventually, I destroyed the head from overcleaning and air blowing. I bought a new head but still no joy. I even tried kicking the awful machine several times, printing continuously, deep cleaning continuously, etc. I was about to give up and start shopping for a non-canon printer when I came across the "straw solution". Rather than use straws, I got my air compressor for the job. Air went in from the top and virtually all the ink came out the other end. The printer has been printing all colours and shades since then. Thank you.
by unknown on Apr 5, 2006 at 1:11pm Add comment
I have been trying to sort my printer all day to no avail. It stopped printing half way through a job. I then changed the black cartridge - nothing. It keeps saying black ink low. It will not print at all now. I am not able to instruct the printer to do any maintenance on it at all. It will not respond. Can anyone help please??
by MP390 on Apr 11, 2006 at 5:48am Add comment
My computer won't recognize MP 390 any more. It reads, "USB device not recognized". I re-installed the printer driver several times, but still the same error. I tried it on 2 other computers in the house, but the same issue. I contacted Canon tech support, but no solution. He suggested the problem may be related to EEPROM (?) that needs to be reset by authorized service center. Anyone with similar problems or know of any simple solution?
by unknown on Apr 19, 2006 at 12:25pm Add comment
I plan to leave my mp390 in Florida for seven months without it being used. Is there some sort preventive maintenance to be done so that I won't have problems when I return? Such as dried up print head.
by boca on Apr 24, 2006 at 2:24pm Add comment
I have an MP390 printer which has been working great until recently. A piece of paper jammed while feeding a few days ago. I got the entire piece of paper out, but it says there's a paper jam. I've been able to feed paper straight through the printer, but if I try to print anything it still says that there's a paper jam (even though there's no paper in it whatsoever!). I hate to get rid of the printer over something which seems so stupid. Anyone have any suggestions? Thanks!
by Erol on Apr 25, 2006 at 9:35pm Add comment
I have the same exact problem except that I don't even remember anything being jammed. It says there is a paper jam. I can pass paper through--but it won't print because it says there is a paper jam. Any suggestion? - Anonymous
Hey all sorry for the non-related post but does anyone have any problems with scanning?

My scanner was working fine until about 1 year after warranty when it would scan a black & white image (done in colour scan mode) as yellow and white!

Needless to say, scanning a colour image is completely out of wack too...

It appears that there is nothing wrong with the software settings, the scanning light or the belt-drive.

Have Google-d around for info without much success.

Has anyone come across this problem before? Any suggestions?

Yet another nail in the MP390 coffin... ;-)
by unknown on May 18, 2006 at 5:14am Add comment
I was having the same problem with my Canon MP390 and some inks not printing after the ink cartridge ran out and the hot water and drying the print head worked like a charm! Thanks a million! ~L
by unknown on May 25, 2006 at 4:56am Add comment
My printer just recently ran out of ink from refilling it, so I decided to replace it with new Canon ink tanks. Now I am unable to print in red, just the blue and yellow come out, so I ran everything from print nozzle to cleaning and nothing. Office Depot gladly replaced my ink tanks. Well now, just the yellow is printing, so I ran everything again, and when I need to print in black the red comes out. What is going on? Help. I already got this machine serviced for a jam by my son for $60.
by creyna on May 25, 2006 at 4:10pm Add comment
I just tried this. I took the black ink cartridge out. Found the little hole at the top of the cartridge. Took a straw and making the best seal I could - I began blowing. Hard. Did this about 4 or 5 times. No ink came out or anything.

I put the ink cartridge back in the MP390. Closed everything back up. When prompted by the printer if I had loaded a new cartridge I said yes. Black only.

It worked. It's printing black for the first time in months. No head soaking. Just blowing into the black ink cartridge. I have know way of knowing how long it will work but as for now. It is.

Thanks for the tip...
by Anonymous on May 29, 2006 at 5:48pm Add comment
I had the no print problem and the MP390 did not see my cartridge/print head... tried the soaking and blowing out...nothing. Bought a new print head and Canon cartridges.. installed...sees the head now but no print at all. blew into came print. Cleaned the contacts on print head and printer...nothing. It also will not receive or send faxes... wonder if I should uninstall and reinstall???
by Anonymous on Jun 9, 2006 at 8:56am Add comment
I simply removed the print head with the cartridges still in and with my mouth blew into the holes on the top of black ink cartridge and bingo black ink poured out and now after about two weeks of wanting to get another pinter my printer is printing black ink like a champ. I will inform you if it keeps printing in about a week.

You guys are a real blessing. I didn't soak or anything just did the above and it worked!

thanks and Jesus loves you guys!


P.S. He loves you whether or not you helped me fix my MP 360 canon printer!
by unknown on Jun 13, 2006 at 9:26pm Add comment

The Straw Techniques Works! Fixed my MP360 printer head problem using the Straw technique.

Now it is printing black. Top Stuff
by Anonymous on Jun 17, 2006 at 3:08pm Add comment
My Canon MP390 stopped printing the black ink. I did several cleanings and new ink cartridges but it only got worse. Read the solutions here and tried soaking and then used my sink sprayer to spray out all the ink. Put the cartridges back in and nothing until I read about the straw. I found a half straw and blew into the black cartridge. My printer is now printing well again. I have always used generic cartridges and they work great. - Anonymous
I've been reading the posts about printing blank pages. I have the same problem. I am currently soaking the print head in boiled distilled water. Has been soaking for about 10 mins or so. I'm just about to take it out and use my little compressor to blow through the little slats on the bottom of the print head to get the water out. I actually bought a new print head from Canon, but I'm trying this on my old one. I'll let you know how it works out.


OK. After soaking for about 20 mins and blowing the water out, making sure all was dry, I re-installed the print head, and still printed blank pages. But, the soaking did take a lot junk out of the print head. I then took the print head out, left in the ink tanks, got a straw and blew through the very small hole on top of the tanks until ink came out the bottom of the print head. Now, you've got to blow pretty hard, and make sure you are doing ths over some paper towels or something, because the ink comes out pretty fast. Make sure that the ink is comming out all the slats on the bottom of the print head. I then cleaned off the bottom of the PH (got sick of typing 'print head'), re-installed, and presto, printing as good as new. I didn't even have to do a head cleaning.

Hope this helps someone else out.


by midnight251 on Jun 22, 2006 at 6:14pm Add comment
I've replaced the print head in my printer and put the old cartridges back in. Nothing on the page. I used to get black print with white patches through them so they were unreadable (almost like something was on the roller)and I only got red and blue color print.

I have no idea what to do next other than throw the printer in the garbage!!!

I wouldn't think that I need to clean the brand new print head??

Does anyone have any ideas? Should I buy new cartridges? My color is brand new.


- Anonymous
I can't believe it, but it actually worked!
I was having the streaking of black in text and pictures.
I did the print head soaking in hot water, air compressor dried. Then let it air dry for several hours. Total dry. Went to intall the clean print head, and it was just as bad if not worse. Wouldn't even print color now. My last hope before ordering a print head was to try the straw "technique" of blowing into the top of the ink tanks. You have to blow hard, but the ink will come running out and literally drip from the print head. I wiped the bottom clean after it began to flow. Reinstalled and now it is printing just like the day I got it! Thanks for the tip, worked for me. - Anonymous
went through the same thing, black skipping lines, cleaned with water, then no printing. New print head, still no printing. Blew through the pin holes at the top of the cartriges while still in the print head, now printing perfectly!
by unknown on Jun 24, 2006 at 4:24pm Add comment
Hello everyone,

Had the same problem with an MP390 not printing black. Read all of the above, tried the boiling distilled water trick, and hey presto, I'm printing in black again! Took about 20 minutes of pouring water through the head until it ran clear, then 10 minutes on the windowsill in the sun to dry it out, and now all is well.

Thanks for the advice, you've saved me a small fortune!

by Anonymous on Jul 4, 2006 at 12:39pm Add comment
You will need to check your purge unit capping first.Power the unit on&open the cover,after the printhead moves to the center remove the power plug from the back of the printer.Slide the printhead to the left so you can see the purge unit on the right side.Look for a rectangle cap(looks like a sponge)which is held in by 4 rubber flaps(cap will be fill of ink),remove it &soak it in a plastic cup of warm water for approx 10 min,the pad should turn back to white.Reinstall it & power the unit on & run through a couple of cleanings,the pad should turn back to black,then try printing again.If the cap doesn't turn black then purge unit is defective.
by Anonymous on Jul 6, 2006 at 9:18am Add comment
You will need to check your purge unit capping first.Power the unit on&open the cover,after the printhead moves to the center remove the power plug from the back of the printer.Slide the printhead to the left so you can see the purge unit on the right side.Look for a rectangle cap(looks like a sponge)which is held in by 4 rubber flaps(cap will be fill of ink),remove it &soak it in a plastic cup of warm water for approx 10 min,the pad should turn back to white.Reinstall it & power the unit on & run through a couple of cleanings,the pad should turn back to black,then try printing again.If the cap doesn't turn black then purge unit is defective.
by Anonymous on Jul 6, 2006 at 9:26am Add comment
I have a Canon MP390 and now I have a problem with a jammed cartridge on the right side. Can someone guide me how to take out the cartridge and what could be the problem ???
Thanks in advance
by unknown on Jul 7, 2006 at 7:42am Add comment
I have read thru this forum and don't find my specific problem.

All of a sudden some of the printed black lines have a streak of white. Almost like the old dot matrix printers when one of the pins was not working. This happens one lineout of 5 to 7.

I thought this meant the ink was low, so I put in a new black cartridge, but there was no change.

Where should I start???

This printer has worked fine for a little over a year. Most of that time I have used generic cartridges


by joelpk on Jul 10, 2006 at 12:29pm Add comment
Your knowledge of the mp390 is amazing. All I can get on my display is CHECK PRINTER. What does that mean and what can I do to make it work again?
by unknown on Jul 11, 2006 at 2:19pm Add comment
I am having difficulty printing because I get paper jam messages all the time. Usually the paper goes in halfway and I get the message. Once I cancel the print; pull out the paper, and start over again, I get to print about two pages without any problem, then the problem starts again.

Can someone help. Thanks.
by Anonymous on Jul 18, 2006 at 3:22am Add comment
Thank you so much to those of you who posted the "blow hole" solution to the printhead problem. After first losing the black ink and then the color and talking to Canon support for two long sessions I had started shopping for a new printer. But a few strong straw directed blows through each of the holes on the tops of the cartridges while they were still in the printhead and the printer works like new.

For someone who hasn't seen the thread for this problem here's how I did it. First remove the printhead from the printer with the cartridges intact inside the printhead. Position the printhead over a good pile of paper towels to catch the ink that will come out. Place a straw tightly over one of the small holes in the top of one of the ink cartridges. Blow hard until ink starts coming out of the bottom of the printhead. Repeat for the other cartridge. Clean off the bottom of the printhead by dabbing it on the paper towels. Replace in printer and print away! I hope it's that easy for everyone who needs to address this problem.
by unknown on Jul 20, 2006 at 7:45pm Add comment
I haven't seen my MP390 problem on this thread. Having owned 2 of these printers and having a lot of success with them I purchase a used one pretty cheap. It was working for a while and then the paper started jamming. When I look into the paper feed the roller is on the right side, when the paper starts to feed the roller shifts it to the right where it jams. I cannot see any type of obstruction in the paper feed or the front of the printer. I would appreciate any suggestions or help anyone might have.


by unknown on Jul 21, 2006 at 3:13pm Add comment
Thank you for this tip. It has saved me $300.00AUST ($225.00 US).
The local Canon Service Centre quoted me this price to replace the printhead and purge unit.
I followed your tip, and my printing in both colour and black and white is fully restored.
by Anonymous on Jul 22, 2006 at 6:25pm Add comment

some more good proof of a method: I had been through the same maddening cycle that's much reported here; printer prints without inking page - new print head (£45.50) - same problem persists.. tried everything suggersted here.. then got around to crossmi's (6/13/06) instant solution.. and it worked. Thank you crossmi and the earlier version discoverers of the 'blow hole' method!
by unknown on Jul 23, 2006 at 1:23am Add comment
I have a mp360 and have had the same problems as most on this site. no colour would print at all even after getting new head and new ink. so I tried the blowing through the holes on the top of each colour ink while its still in the printer head. I used next door's compreser. Its a miricle it worked. I did however use some ink but it is better than buying a new printer.
by unknown on Jul 23, 2006 at 7:13am Add comment
Success Report!

I had a piece of plastic tubing on hand (1/4 inch dia - cut real clean and then flared out a little).
First I tried blowing through the ink carts while in the print head - did not work.

Then I did the soak in boiling distilled water twice - the print head only.
Both times , I took it out of the water and and firmly pushed the end of the tubing over the place where the ink goes inside the print head and then blew hard.

With the tubing you can get a firm seal on the print head and you can see what you are doing because I used about 16 inches of tubing.

Working just fine.
by joelpk on Jul 27, 2006 at 1:18pm Add comment
PS to my last post.

I have been using cartridges from and I do not think they were the problem. They cost 1.20 and 1.70 each plus 7.00 PER ORDER.

I have nothing to do with this company. Just thought I'd pass it on.
by joelpk on Jul 27, 2006 at 1:37pm Add comment
My 390 also stopped printing. I changed the ink tanks and cleaned the head and it still just goes through the printing motions and no ink come out. I can run the nozzle check and it prints fine. It will neither copy or print. Any ideas?

by Fireball on Aug 3, 2006 at 3:44pm Add comment
I have had all the above problems r/g the printer not printing. I ordered a new print head from canon and guess what, it prints. HOT PINK!!!!!!!! Thanks to God, I have pulled out my old Lexmark......
by Anonymous on Aug 5, 2006 at 9:16pm Add comment
GO for the straw blowing method. Worked for me with no problemos. Before, printing in black was very patchy and missing in parts. Could only get good quality while printing on high. After blowing down the cartidge while still in the print head, printing is back to normal with full coverage even on draft quality.
by Anonymous on Aug 6, 2006 at 2:15am Add comment
Just bought this printer privately.
Pictures print..........
I can print from pc in blue as as alot of other people I see have on here.
I have tried the cleaning as suggested.but there is still no black printing. I would also like to point out that there is no 'printing noise' for the black, change to blue and it all works....any ideas please? (UK)
by ElaineE on Aug 11, 2006 at 7:29am Add comment
I am having the same problem with my black ink not printing from my pc. But when I use the copy function it puts out great black copies. I checked all my settings and their fine. Any ideas?
by Carlee on Aug 15, 2006 at 4:45pm Add comment
If you have an issue with your printer not printing black. Just take it out give it a good wipe with some spit and it will work great!!. I was worried about soaking the piece since (we) are not sure of what is behind everything. GOOD LUCK ALL!
by unknown on Aug 29, 2006 at 5:01pm Add comment
Burn in hell Canon!
We hate your faulty printers, why can't you make good ones??!?!
by Anonymous on Sep 4, 2006 at 5:24am Add comment
This forum has just saved me a few quid, thanks to all the previous posters.

My MP360 started giving me patchy black printing after a few years good service, it has been used regularly as I run a football team and often need to print multiple copies of newsletters.

I tried the nozzle head cleaning and cleaning cartridges and the situation only got worse, so I was thinking it was time for a new printer.

I then found this page, soaked the printer head in hotish boiled water a number of times until I could not longer get ink blots onto kitchen towel. Dried it with a straw and hair dryer and...there was no black printing.

So I trawled froogle for a new printer, and struggled to find one that would take compatible cartridges for the price I get them for the '360. Lets face it people, how many printers can you find that take £2 black cartridges? A lot of them retail at £20+

I decided to give the water cleaning one more go. This time, a little less soaking, and a good dose of blowing on the head with a straw from both sides and a good shake to clear out the water.

I plugged it all back in and....celebration time, the black was as good as new, and the colours still worked.

Bottom line, if you try the water cleaning and it doesn't work first time, then it might be worth trying it again a couple of times before forking out for a new printer or printer head which cost a fair bit more than a few cups of distilled water.

Fingers crossed now that this has solved the problem for at least a few months as I'll be sad to replace this printer which is relatively low cost using compatible cartridges.

Incidentally, I have been using compatible cartridges for some time now, and this is the first problem I've ever had, in actual fact I was using an official cartridge when the problem first started, BUT, the low black ink warning had been on for some time, and I was trying to finish printing before changing the ink, so it was probably my own fault this problem occurred for keeping in a low ink cartridge for too long.

sorry for the Jackanory and good luck with your own printer problems.

by Anonymous on Sep 12, 2006 at 3:51pm Add comment
New information to Success Report (below)

My success did not last long, BUT, I tried it again and this time I put some how water in the tube before I blew into the tube. It did not appear that very much water came out, but it is FIXED and has remained fixed.


Success Report!

I had a piece of plastic tubing on hand (1/4 inch dia - cut real clean and then flared out a little).
First I tried blowing through the ink carts while in the print head - did not work.

Then I did the soak in boiling distilled water twice - the print head only.
Both times , I took it out of the water and and firmly pushed the end of the tubing over the place where the ink goes inside the print head and then blew hard.

With the tubing you can get a firm seal on the print head and you can see what you are doing because I used about 16 inches of tubing.

Working just fine.
by joelpk on Sep 27, 2006 at 6:02am Add comment
well mine is working now
however I got two posts confuse and I used a straw and the air hose to blow through the tiny hole in the cartride yup you guessed it I am all multi colored and so is the garage
Oh well its working
Thanks all
by unknown on Sep 27, 2006 at 3:15pm Add comment
I am running 2 computers to print wirelesly through my Belkin wireless router which is connected to my Canon MP390. However, I have a 3rd computer that will recognize the printer when told to print, but the printer does not activate. Any suggestions?
by unknown on Sep 27, 2006 at 4:14pm Add comment
Hello everyone I also own a MP390 and my black stopped working but hey the color side works great. I have done all the deep cleanings and still no black ink. Called Cannon and the best they could do for me was reccomend a service tech and a 15 percent discount on another machine. Not going to happen if I cant get this one working!!
I have had this machine a year and a half and its out of course it's out of warranty.
My question is which part is the printer head is it the black casing that the ink blocks sit in or is it something else?
I dont know where i'm supposed to blow or what to soak. The part i'm looking at on the black casing has a green board on the back and looks like microchips on it. I dont want do any more damage, so if someone can help me out here so I dont end up throwing out a machine that has not been used very much, I would really appreciate it.

Thanks, Cali
by Anonymous on Oct 6, 2006 at 1:19pm Add comment
Any chance you can give me a part number on those heads? I can not find them anywhere.
by Anonymous on Oct 6, 2006 at 7:38pm Add comment
Hi just read your msg about the problem you had with your mp390. I'm having the exact same problems. did you find out how to fix it? if so pleeeeese email back and let me know

Jay Smith
by Anonymous on Oct 7, 2006 at 1:04pm Add comment
Hi, my mp390 scans in B&W just fine, but colour scans are discoloured blue. Anyone go any clues as to what is going on here - wnd whether it is fixable? Thanks
by hfinlay10 on Oct 12, 2006 at 6:17am Add comment
I have tried all of the suggestions here to no avail. Continue to have white streaks or lines through parts of the page during B&W printing. Any more suggestions? Anyone want to buy an MP390? :-)
by sargejenn on Oct 12, 2006 at 12:13pm Add comment
I have a Canon S 900 printer. It has suddenly stopped printing. I removed all the ink cartridges and cleand the head with a little windex. Then I ran some warm water through until it ran clear. I do not own an air compressor. Can I use a hairdryer to dry it with? Also. should I replace my ink cartridges even if they are still half full. Any information would be greatly appreciated.
Thank You,
Jette Waterston
by a6a4347 on Oct 13, 2006 at 2:58pm Add comment
yeah, didn''t see this anywere on here so..
But soon as i start the printer, i roll's the rollers, then tries to do something, but just makes a loud clicking noise. Anyidea on what this is? and how to fix?

P.S. it does it when i try to print,copy,fax. But i can scan fine, so i guessing its like a gear, but no idea.
So thanks
by delmlund on Oct 24, 2006 at 4:23pm Add comment
This whole thing with soaking and the straw is absolutely ingenios! Worked like a charm. Thank you SOOOO much!
by unknown on Oct 28, 2006 at 4:19pm Add comment
I would just like to say that after having a few problems with my Canon MP390 ... the black ink not printing to be exact .... I Googled for some help and came across this site. I read the help hints here and did the washing out of the printhead with hot water and the black is now printing!!

So thank you to everyone....I can now go to bed and stop stressing!!!

p.s. by the way I've had my MP390 for nearly 3 years and this was the first for me.
by Anonymous on Nov 2, 2006 at 4:31am Add comment
I was changing the black ink cartridge like i've done a ton of times, and the screen on the printer read "wrong cartridge" and it will not print. I know it is not the "wrong cartridge" because it is a cannon 24, and when i tried to put the old, empty cartridge back in, it still read "wrong cartridge." i've turned the printer on and off a few times, and tried putting in the cartridge repeatedly, but nothing seems to work. What should I do?
by unknown on Nov 8, 2006 at 3:49pm Add comment
Thanks everyone for sharing the straw trick. My MP360 would not print in black and after blowing through the tiny hole using a straw, I was able to.

Note, the hole is very tiny and you can miss it - at least for vision challenged guys like me. It's on the top of the cartridge (on the arrow mark) ==.>
by Anonymous on Nov 19, 2006 at 5:44pm Add comment
It works!!! I was reading until late last night when I found this site, so today at lunch I brought home my straw. I removed the print head and cartridges by lifting the gray lever. I thought I would try just the straw blowing first. I put it on top of the little hole in the cartridge and blew...nothing happened. Then I cut some of the straw off so I was closer and set the whole apparatus on the table and blew real hard. It felt like I had a good seal. I lifted it up and there was a puddle of black ink on the newspaper. Great! For good measure, I blew again and even more ink came out. Wiped it carefully with a paper and towel, put it all back in the printer and it is printing like new.

Thanks everyone. I love this printer since it can do everything and I have learned all its ins and outs and didn't like the idea of having to relearn a new printer; let alone pay out more money for a new printer.

Thank you thank you again!!!
by Anonymous on Dec 2, 2006 at 4:16pm Add comment
Have exactly the same problem. Biggest problem is trying to get the thing apart to find the fault. how do you get into the darned thing?? It seems to me canon will not sell you spares anyway as they want the money for repairs. any help would be appreciated
by Anonymous on Dec 3, 2006 at 3:37am Add comment
Well, I must say now I think your wife is a genius. My MP 390 was printing with white lines through all my black text. None of the built-in diagnostics and cleaning routines seemed to help. The straw thing sounded easy, but I didn't have a straw so I just put my lips over the whole on top of the black ink cartridge (with the cartridge in the print head) and blew. Black ink went all over the place! I gently blotted the excess ink residue off the print head with a tissue and stuck it back in, and now the printer seems to be working fine. Go if I can only figure out how to get the black stains off my hands...
by Anonymous on Dec 9, 2006 at 8:17pm Add comment
Had the same black printing problems with my mp370. Tried cleaning the old print head and still bad black printing. Ordered a new printhead from for $63, shipping included price. Installed the new printhead and it would only print in blue! Finally figured out the brand new Canon printhead was clogged from the factory, probably from sitting in the sealed foil box. Black, yellow and magenta was plugged. Tried the straw method and it worked til I was able to get all the colors to flow. Printer works like new. I am going to try and clean my old printhead and have a spare. My suggestion with a new printhead is to try and blow it out if it works worse or not at all than the one you are replacing.
Hope this helps someone.
by Anonymous on Dec 10, 2006 at 8:15pm Add comment
Ok...I didn't bother reading through the thread...bits here and there.

My Canon cartridges were sitting in my printer for ~7 months and no use. Big mistake. I believe all the colors dried up. Anyways...

My problem WAS that my red was not working and yellow was faint.

Cartridges weren't the problem because I just bought a new refill ink set with needle and filled all the cartridges.

I stumbled upon this webpage and I soaked my printhead in boiling water. I soaked it and rinsed it about 20 times. Then I soaked it and then used compressed air to blow the bottom of the printhead. Then I soaked in boiling water 5 more times. Used a hairdryer to dry the printhead.

Reinstalled everything and bingo, everything worked like new.

THANK YOU VERY MUCH TO WHOEVER'S IDEA THIS WAS...just made my day, Merry Christmas to all.


P.S. I must say those ink refills with the needles are very good! I'm surprised, It's like 5-6 refills for the price of 1 set of new cartridges.

by Anonymous on Dec 22, 2006 at 9:57pm Add comment
I used the "blow-hole" method on my color cartridge yesterday (thank you for the suggestion!) and it worked great! (blue and yellow were printing, red was not). I then printed six 5X7 photos. Today I printed a nozzle check to see how it was working, and red had, well, invaded the other colors. That is, where it should have been blue, purple printed, red printed normally, and where it should have been yellow, a slightly yellower red printed again.

So I did the "blow-hole" method again today, and once again it is printing correctly. Hopefully this is not something that will have to be done every time I need to print in color. It does waste an awful lot of ink, considering the cartridges are already teeny compared to, say, HP. Think I'll try the soak and blast method next time.

Incidentally, I had an HP Inkjet (832C, I think) that just stopped printing yellow ink one day and continued to not print yellow, despite a new cartridge. I had gotten about 5 years out of it and wanted an all-in-one anyway, so I gave it to a friend to use as a B&W. Wish I had known! At least I'd have a backup... Not sure the print heads are removable on lower-end HPs though.
by pc-tlc on Dec 28, 2006 at 9:52am Add comment
Thanks, worked a treat. Soaked it first then blew through vent holes (directly - by mouth) and then worked perfectly. Regards Brian
by Anonymous on Dec 29, 2006 at 3:02pm Add comment

Thank you so much for the information in these threads! I too had the issue of "suddenly-no-black-ink-printing".

So, as you suggested, I took the ink cartridges and the printer head out and simply cleaned the outside slots with a swab wetted with just a little warm water, then wiped dry and clean with a tissue. Also, I swabbed the inside at the holes (I did both Black and all colors). Presto! Good as new!

I use the printer regularly. I would think that if my printer sat for long periods of time without use, I'm sure the results would have been less spectacular!

But yay me! Thanks again Rick!

by Monique on Jan 3, 2007 at 12:38pm Add comment

Thank you so much for the information in these threads! I too had the issue of "suddenly-no-black-ink-printing".

So, as you suggested, I took the ink cartridges and the printer head out and simply cleaned the outside slots with a swab wetted with just a little warm water, then wiped dry and clean with a tissue. Also, I swabbed the inside at the holes (I did both Black and all colors). Presto! Good as new!

I use the printer regularly. I would think that if my printer sat for long periods of time without use, I'm sure the results would have been less spectacular!

But yay me! Thanks again Rick!

by Monique on Jan 3, 2007 at 12:41pm Add comment

Thank you so much for the information in these threads! I too had the issue of "suddenly-no-black-ink-printing".

So, as you suggested, I took the ink cartridges and the printer head out and simply cleaned the outside slots with a swab wetted with just a little warm water, then wiped dry and clean with a tissue. Also, I swabbed the inside at the holes (I did both Black and all colors). Presto! Good as new!

I use the printer regularly. I would think that if my printer sat for long periods of time without use, I'm sure the results would have been less spectacular!

But yay me! Thanks again Rick!

by Monique on Jan 3, 2007 at 1:02pm Add comment
my glassbed on a MP390 shatterd..

can anyone tell me where i can find a replecement for it?


by richarddw on Feb 26, 2006 at 8:13pm Add comment
I have a useless MP390 that wont print black anymore. Tried all the solutions on this site- none worked. I wont be fixing the lemon. I'll sell it to you cheap. Only a year old - as usual. - unknown