asked Apr 27, 2005 at 9:21pm
Unknown Printer

Just installed new epson ink and have red light on

Just installed new epson ink and have red light on. Last ink change I bought non epson ink and the computer said it wasnt epson. It let me change a setting and it worked fine.
I have just installed real epson ink and now I have a solid red light and the power light is flashing?????
Any thoughts or help. It worked fine until it ran out of ink.
Solid ink light means that cartridge hasn't been recognized, access the Epson status monitor through printer properties and check which is the failing cartridge.
by newuser on Apr 28, 2005 at 1:05pm Add comment
the status button is not clickable...??? is there something I am not doing correctly?
Thanks - Anonymous
dadchuck: If you need any further help, be sure and let us know exactly what the model of your particular epson printer is. It can make a difference...Denny Conway
by Denny Conway on Apr 28, 2005 at 1:57pm Add comment
We need to know your printer model, c60, c80, c82, c84, 777, 740, c41/2/3/4 or c46?
by newuser on Apr 29, 2005 at 11:15am Add comment
c82 - Anonymous
I'd suggest going back to non-epson ink, preferably the brand which worked last time. This is rather strange as "real" epson ink should work, as it was designed for the printer, by the manufacturer of the printer. However if it does work on non-epson ink, then by all means use it!
by unknown on Apr 29, 2005 at 3:30pm Add comment
I would except I just spent a bunch of $$$ on the real stuff.
Cost almost as much as the printer. - Anonymous
If Power light AND paper light are flashing and ink light stays solid, it means that a fatal error occoured.

To find out extended error description you should access epson status monitor but you said that the button is grayed out. Try removing Epson Status Agent (not the monitor) and soft-reset the printer as explained here:

After that Epson Status Monitor should be accessible and it should be able to return a better error description. However fatal errors usually occur when the printer carriage is stuck due to insufficient lubrication (try lubricating the carriage guide shaft) or to failing encoders. If you want to check linear scale encoder and paper feed encoder you will find them described in the c82 service manual, available for download in the reference section of this site, paragraphs and
by newuser on Apr 30, 2005 at 2:20am Add comment
Im really frustrated now. I downloaded the program and couldnt get any response from the printer. It now has a solid red and solid green power light on. and new ink.
maybe its time to buy another brand thats not so picky.
Even though this printer is only a year old.
- Anonymous
Anonymous thats "really frustrated now" : Unfortunatly, that "SSC Service Utility" may not actually work on all epson printers and not on all operating systems [that utility only works using a windows operating system]. You can check and see if your particular epson printer is compatible, by going to ...I'm sorry, but I have never used that service utility, but here's some previously posted info that may also help. "NEWUSER Re: Epson Error and power light flashing by newuser (4/5/05 11:10 AM). To reset the error download this utility: . Once installed run the program and configure it, closing the main window and right clicking the icon in the tray area, from there choose Configure and select your printers model. After configuration, select Protection counter -> Reset protection counter, it should be able to clear the error message. If that does not actually work, then the only suggestion I can give is to perform a soft-reset before resetting counter. Remove also the Epson status agent, it detects errors and it may hinder communication with the printer, then reboot your pc. As profile choose the one sscservice didn't use after autoconfiguration, check for printer response. Remember that you should also clean the waste ink pads located at the printer bottom. For a more in-depth procedure by NEWUSER, go to his site at "...Simply resetting that Maintenance Request Error, is only doing part of the job and its possible that you could have additional problems later. The maintenance request error is actually a Waste Ink Ink Pad Error and usually your remedy is to replace the waste ink pad/pads with a new one/ones and then reset the Internal Waste Ink Pad Counter, which of course you already did. If you just reset the counter and don't replace the pads, then your printers old pads will eventually overflow and normally start leaking ink out the bottom of your printer. You can see exploded parts diagrams of most epson ink jet printers and can also check on possible parts ordering, by Compass Micro Inc, at . Some people actually wash the ink out of the old pads, by holding them under running cold water. Then they simply dry them out and reinstall them back into their printer. The choice on what to actually do, is yours to make...If you are unable to get that ssc service utility to work, then you may have to go on-line and actually buy and download the reset procedure, to be able to clear that Waste Ink Counter to reaet correctlt...If we had the actual model of your epson printer, we might be able to tell you if there was any additional information that was available on your printer...Good Luck! Denny Conway
by Denny Conway on May 2, 2005 at 10:52am Add comment
Hello! My printer model is Epson T10. My problem is that, I just replaced the cartridges (Epson cartridge) and I was able to print some 2 pages of text and image. Next day that I will use it again, it says again that the printer is out of ink. The printer status has blinking power light and solid red ink light. I even checked the waste ink pads, but it has not reached the max yet, still, I had it reset. Same problem goes.. Hope you could help me with this. Thank you so much!
by unknown on Jun 13, 2011 at 11:35pm Add comment
Hi - This just happened to my Epson CX7450. Got ink cartridges, put them in, at first lights were ok but the person on eBay whom I purchased the cartridges from said to do about 4 head cleanings. On the fourth one, the red light went on and was flashing. After turning printer on and off a few times, now the green and red lights are on steadily - no flashing.
I can't do anything via Epson program because I get an error message. I took the cartridges out and put them back in --- still red light is on without flashing.
Can you recommend anything to try?
by unknown on Jul 14, 2011 at 4:53pm Add comment
Hey, I have an 'Epson Stylus Photo 1400'

The machine was working fine the other day, but today, when I go to print anything, it tells me to 'Replace Cartridge'... But the printer tells me I need to replace ALL the cartridges, which I know is not the case as they were working fine the other day, also I can see the ink levels right in front of me, they are far from empty. The printer also says the ink cannot be recognised, although we've been using the same ink set-up/printer for the past year or so without any problems.

A few points to mention;

1. It is not Epson ink cartridges we use.
2. We use a continuous Ink system.
3. The power light is flashing green, while the ink drop light is a solid red.
4. The problem persists when we swap ink system to old printer (old printer is exactly the same model, just a year or so older)

I have also taken the cartridges out, cleaned them and replaced them. As it says to do in the Epson troubleshooting guide/website.

Hopefully somebody out there can be of assistance! Thank you in advance and If you need to know anything else, just ask.
by unknown on Nov 10, 2011 at 3:43am Add comment
RecognitionExpress, neither printer recognizes your CIS cartridges it suggests that the chips on the cartridges are not being recognized. Either replace the offending CIS cartridge connections or install Epson cartridges. Hope this helps.
by unknown on Nov 12, 2011 at 2:58pm Add comment
ve bought a new epson 1400 A3 printer and also bought epson continuous ink system i have installed the ink correctly and i have pressed the start button the carage goes through the motions and travels up and down then the red light comes on and green light flashes i have press small button on ink cartrages for 5 seconds as instructed but red light still remains on and green light still flashing can you help me
by unknown on Nov 26, 2011 at 6:17am Add comment
epson t60 centre red light show problem ink comming proper
by unknown on Mar 26, 2012 at 10:02am Add comment
Have just installed epson ink cartridge and red light still on status shows that ink is low, but brand new.
by unknown on Jun 19, 2012 at 4:33pm Add comment
What model printer? Does the status monitor show more than 1 empty cartridge?
by unknown on Jun 21, 2012 at 8:23am Add comment
inherited epsom dx4000 model c241b contained 3 generic compatible colours one epsom black printed in black ok. black ran out replace all with compatible as wanted to print colour, would not print showing not recognised cartridges! replaced black with epsom t0711 to at least be able to print however still showing incompatible will not print at all!!!!!!!!!!!! very very very frustrating, have tried various to correct but still the red light and no print. Please can anyone help before I attatch this printer by a long rope to the back of a very large boat and have it towed out to the middle of the Irish sea!
by stressedepsomuser on Nov 8, 2012 at 4:34am Add comment
I have an Epson 1400 and a CIS system from Hotzone 360. I was having nozzle issues (some were not printing) and while I was trying to fix that, the printer has now gone into solid red ink light.

I have tried the Clog Buster Print Head cleaner with no luck.

What now?
by unknown on Jan 22, 2013 at 8:57pm Add comment
switch off the printer .. remove the cardrige and reinstall .. dont touch the green chip ... worked for me ... damn printer companies ..
by unknown on Apr 6, 2013 at 2:21am Add comment
I strared to change to non Epson ink cartridges. Put two in and printed one paper on my Epson stylus 4450. After that the ink carriage stuck all the way to the right and I have three solid lights on the power button side. Ink monitor says no ink available but can't move the carriage to fill ink.
by unknown on Jun 3, 2013 at 3:00am Add comment
the red light is just staying on continuous, it says i need new ink but i have bought countless inks o the genuine epson ink and it still says the blue needs ink, it is brand new and i dunno wtf to do

its not the ink
its epson stylus DX4450
by unknown on Aug 10, 2013 at 8:42am Add comment
reckless, what does the status monitor on you computer indicate as the problem?
by unknown on Aug 12, 2013 at 3:54pm Add comment
reckless, what does the status monitor on you computer indicate as the problem?
by unknown on Aug 12, 2013 at 3:56pm Add comment
it just says no ink,
on the machine itself it says that the ink is emtyp on the cyan but it isnt, i have bought alot of ink wasting my money to try fix it :(
by unknown on Aug 14, 2013 at 10:35am Add comment
Reckless...Removethe power plug from the wall. Remove the cyan cartridge and look for bent or missing pins in the carriage where the chip on the cartridge would come in contact. Clean the contacts with some alcohol. Don't install the cyan yet. Plug the printer in, power up and let it cycle. When it asks for the cyan cartridge put it in and see what happens.
by unknown on Aug 14, 2013 at 10:43am Add comment
it still shows it as no ink :'/
by unknown on Aug 14, 2013 at 4:34pm Add comment
reckless...If you are sure that you have a good cartridge it would seem as though either the cartridge sensing assembly in the carriage, its connection cable, or the main board are defective.
by unknown on Aug 15, 2013 at 9:48am Add comment
I have an Epson DX7450 and from one day to the next it stopped work (also not scanning). Green power light is on and steady, red ink light the same (not flashing). I tried removing and putting back the cartridges but getting the same result.

The status in printer properties says all is fine.
by unknown on Apr 8, 2014 at 2:53am Add comment
I have an Epson DX7450 that all of a sudden stopped working (also doesn't scan). Power light on without flashing, red ink light on without flashing.
I tried taking out the ink cartridges and putting them back. The printer status in properties says all is fine.

Any ideas?
by unknown on Apr 8, 2014 at 3:00am Add comment
just installed set of 4 genuine ink cartridges but still having the red light blinking.

could there be something wrong with the printhead
by unknown on Aug 13, 2014 at 8:51am Add comment
Sir, My Epson L210 two red are blinking so solve the problem
by unknown on Apr 15, 2015 at 2:39am Add comment
Simply that. Not printed for quite a while and the status shows empty cartridges. Can these dry out, please
by unknown on Jul 29, 2015 at 10:12am Add comment
Hi. I have not used the A3 epson 1400 printer for a while. it now shows all cartridges as empty. Can these dry out? or could there be a different reason, please.
by wighter on Jul 29, 2015 at 10:19am Add comment

t60 fatal error

by yusuf khan on Dec 11, 2015 at 3:54am Add comment

You cannot print when it is in pause. Click [Resume] to print when displayed, or click [Print Queue] and deselect "Pause Printing" in the "Printer" menu

by jalaj on Jan 22, 2016 at 3:00am Add comment

Im having a hard time also in the printer which is L220 EPSON..It has the blinking red light..I need your to solve this about the Ink level of the printer.

by [email protected] on Dec 14, 2016 at 4:05pm Add comment