asked Apr 4, 2005 at 2:14pm
Epson Epson Stylus C42

problems with epson printers

Hi there,

I have been asked by my boss to see if i can fix a problem with his fathers printer, it's an epson c42. the printer works fine on my computer but not his, i have tried re-installing the drivers, my HP laser printer works fine on his computer however my epson c60 won't work on his computer either.

the error message that we're getting just says that the printer is not connected?

i'm a little bit stumped by this one?

anyone got any ideas?

Try another USB port just incase. Is his computer an older one and maybe it would work better on parallel port.
by tiamaria on Apr 4, 2005 at 3:44pm Add comment
thanks for the reply

I have tried all the usb ports and i'm still getting no luck, and there isn't a parallel port available on the printer.

the problem is more that no epson printers will work on this machine, yet when i installed my hp printer it worked fine. so i'm concerened that something has gone corrupt and isn't uninstalling correctly.

I have tried the updated drivers and i'm still getting no success
by 2k on Apr 5, 2005 at 3:35am Add comment
The only thing I can think of would be to completely remove all Epson printer drivers, then reinstall the latest version.
by LincolnR on Apr 5, 2005 at 3:40am Add comment
The problem is caused by some registry values that prevent Windows Plug&Play system to correctly install the printer.

You have to run Regedit and manually clear all the registry values related to Epson Stylus C42 and EPUSB001. Once you have done it, reboot the pc and reinstall drivers but turn on the printer only when prompted by setup utility.
by newuser on Apr 5, 2005 at 11:07am Add comment
Thanks very much for your reply :) i had a sneaky Suspicion it might be a registry issue

i'll give it a go tomorrow afternoon when i'm next up there.

thanks for your help

by 2k on Apr 6, 2005 at 9:00am Add comment
There is ink int the printer but no words come out on the paper!
by Todd on Apr 23, 2005 at 5:06pm Add comment
If you are using compatible cartridge, they are causing your problem. Since they do not seal correctly with printer carriage, air reach the printhead and cause the blank print issue.

Try with original cartrdiges, if they don't work use the cleaning solution on sale in this site:

by newuser on Apr 24, 2005 at 12:17am Add comment
I have an Epson C42+ and recently stopped giving an error saying 'Parts inside are at the end of there service life'. Epson say it will cost ~£100 to get it serviced. Is it possible to over-ride this error and get it started again or is it for the skip?
by LB on May 6, 2005 at 6:05am Add comment
You can reset the protection counter using the SSC service utility. You can download it from here http://inkjetprinterhelp.us/epsonSSC.html and if you need help using the utility try here http://inkjetprinterhelp.us/epsonSSC.html

And to clean the absorber pads try this link http://inkjetprinterhelp.us/c60wip1.html

I hope this helps,

by unknown on May 6, 2005 at 10:34am Add comment
I have an epson stylus 915, it has an error message saying "Parts inside are at the end of there service life". Does the software from inkjetprinterhelp.us for epson support the model of my printer. I have a problem using the softaware. It seems that it does not reset the protection counter.
by unknown on Nov 15, 2005 at 11:15pm Add comment
Hi used my machine last Saturday fine. Monday it was as dead as a dodo, tried changing the power cable and checked the wall socket. Have I overlooked something,is there a way around this, or is it as a local repair guy told me its cheaper to buy new than to repair Any one know please Maori
by maorijohn on Nov 16, 2005 at 8:48am Add comment
I have an Epson Stylus C20SX. When I turn the printer on, the head does not move. Anyone knows how to fix this?


by Joselito on Dec 6, 2005 at 1:58pm Add comment
I have an Epson Stylus C86. The problem is the printer is working but the paper remains blank. I thought the ink cartridges were bad, so I bought some new ones and that didn't work. I also went the Epson's help guide and ran all the tests that they prescribed, still no ink on the paper. What could I be missing?
by Anonymous on Dec 7, 2007 at 4:53pm Add comment
My epson C60 will print on color but nothing comes out on black and white
by Anonymous on Mar 2, 2008 at 6:25pm Add comment
My Epson 1800 won't print! The ink & paper lights are both flashing? Anyone been able to fix this particular problem?
by unknown on Nov 19, 2009 at 8:47pm Add comment
Hello Wally, if the printer gets a lot of use, it may be the waste ink pad full warning. If so, Epson want you to send it in for fixing. Suggest checking out the SSC Utility to see if your model is covered. If so, you can reset the counter and it will continue to function till next time.

JaX - Anonymous
My Epson ink jet 1800 is practically new but beyond the warranty. I haven't used it for several months. I have tried all the jet cleaning etc. but the printer goes through its' cleaning program and toward the end makes an extremely loud grinding sound that lasts for about a minute. I have turned the machine upside down and tried to remove any foreign matter. To no avail. I believe there must be something caught somewhere in the printing machinery. All things are very clean and like new. Probably the printer needs to be disassembled and checked for the foreign object if this does exist. Do you have any similar problems? I have installed off brand replacement ink cartridges. Could this be the problem? If so please tell me or if there is some other cause also please tell me. Thanks.
by unknown on Mar 30, 2010 at 8:27am Add comment
Hello Roland,
I've had lots of Epsons and they all appear to be of similar design. I'd say the 'grinding' noise is probably the carriage drive belt jumping on the drive motor cog. This can happen if there's a problem with the index strip which runs left to right on the carriage track. This tells the carriage where it is on the track. If this strip is damaged, missing, detached or very dirty, the carriage will slam into the end stops and the drive motor will run on. This causes the toothed belt to jump the sprockets giving the noise you describe.
JaX - WaveGuide
Epson R1800 making grinding noise. I had this problem. It was caused by the ink supply station assembly which does a lot of things. In my case it would not unlock the carriage when it should. The carriage is trying to move but can't causing the drive belt to slip on the drive motor causing the grinding sound. I found a replacement unit at "compass micro" for about $50.00. It is not easy to replace but I managed to do it and my R1800 works perfect now. Be sure to download the maintenance manual. It has all the instructions on how to do it. - jrbtrail
Please tell me how to fix my R1800 Photo Ink Jet Epson printer. It has this very loud grinding sound and the tape in the back vibrates violently when I try to run a clean cycle or most anything. The R1800 is practically brand new but has been sitting around with off brand cartridges that worked about 18 months ago but now doesn't.

Thanks if you can help or tell me someone who can fix it without too much $$$ as I am a senior citizen.

Roland Hiltscher
by unknown on Apr 2, 2010 at 9:41am Add comment
Start by cleaning the carriage guide shaft. This will also help you to look for any obstructions. Read here for instructions http://inkjetprinterhelp.us/glide.html
by unknown on Apr 2, 2010 at 1:11pm Add comment
i have an epson printer and it wont print anythin ov my laptop, as any1 got any ideas ov what i cant do 2 get it 2 print,
by Anonymous on May 10, 2010 at 4:46am Add comment
Epson CX5800F Good printing until black ink replaced. spaces in columns, half of numbers missing, scan does not show image,vertical bands in text. I have used head cleaning, nozzle check, head alignment and have reinstall the software. Help.
by unknown on Nov 29, 2010 at 11:18am Add comment
I have an epson r1800 and it will not print 13x19 however it prints 81/2x11 fine. I don't hear the usual sounds the pickups make when putting the paper in the printer when I attempt to print 13x19. It has printed 13x19 fine in the past.
by unknown on Dec 3, 2010 at 9:09am Add comment
Just to hazard a guess based on experience, I'd say that the pickup roller is a bit worn. It's not worn enough to keep it from picking up the lighter, smaller sheets, but worn enough to not be able to move the larger, heavier sheet. You should be able to watch the roller and see it slipping on the 13X9 paper. - moe
printer EPSON INKJET L200 not printing anything blank paper is coming all settings are ok
by unknown on Sep 15, 2011 at 11:09pm Add comment

I have take Epson L200 Printer. In that there is an option for closing the ink by some valve at back side during transportation. I forget to open my valve once i shifted my printer from one place to another and taken the printouts. But after some copies It was not taking the paper and red light is glowing near power button. Please help me in fixing the problem.
I want to know wheter it creates any problem if we are using the printer without opening the valve.

Thanks in advance
by unknown on Nov 7, 2011 at 5:31am Add comment
printer EPSON L200 not printing anything blank paper is coming, all settings are ok
by unknown on Jan 24, 2012 at 11:46pm Add comment
I recently purchased an Epson SX435W wireless printer so that both my wife and could share it. The wireless printing worked well with both computers but when it came to scanning in a picture the only thing we get is a message saying: cannot communicate with scanner. Make sure the scanner is correctly set up and connected with no error indicated.
I have re-loaded the disc three times, down loaded a new driver, updated the original driver and exchanged the printer for another new one as suggested by the man on the end of the Epson help line. The printer sits on a shelf directly above the computer I am using. The programme I want to use for scanning in pictures is Photo Plus x4 by Serif. This worked perfectly with the Epson printer (not wireless) we just passed to our Daughter.
Please PLEASE! What can I do? I need to scan in many pictures to illustrate a book I am writing.
by unknown on Feb 4, 2012 at 12:42am Add comment
Purchase New L200 printer, printer install ok ,ink charging ok , color prints ok , black printout cant print, what is a problem.
by jayant on May 14, 2012 at 11:53am Add comment
i have purchased a epson l200 printer....but the cartridges are not sucking the ink.....because of it i am getting blank pages al time......

by unknown on May 24, 2012 at 10:10pm Add comment
How to chage the ink pads on a 710 artisan printer. Thanks fot your help
by artifices on Jun 13, 2012 at 10:37pm Add comment
The printer's ink pads are at the end of their service life. Please contact Epson support.
by ALISAIFI on Jul 19, 2012 at 12:58am Add comment
OK I will contact them.
by unknown on Jul 19, 2012 at 11:35am Add comment
The Following Message always receives me.

'The printer's ink pads are at the end of their service life. Please contact Epson support'.

Please solve the problems related with the above message.

by ravinimje on Jul 31, 2012 at 1:25am Add comment
I have a epson L200 printer.All are correct but blank page is coming when print any thing.
How to solve it?
Please help me.
by unknown on Aug 21, 2012 at 4:06am Add comment
same problem with Anjan....nothing is being printed on the paper..i have deleted then re-installed the driver but still
it gives me blank print-outs...what could be the problem? its a new printer, just bought it last week was able to print a couple of days ago.
by unknown on Sep 4, 2012 at 5:15am Add comment
My printer will not eat the paper it why should i do .... when he printed it thers nothing happen but my printer is full of ink
by unknown on Sep 20, 2012 at 7:42am Add comment
my printer model is L200.
I have installed the software but then there is nothing(blank page) when i press either print or copy.
yet the computer show my ink tank is fully filled.
may i know wats the problem n wat im going to do?
by unknown on Oct 14, 2012 at 12:25am Add comment

by unknown on Oct 24, 2012 at 5:48pm Add comment
Buy a print head cleaning kit like this http://www.fixyourownprinter.com/kits/epson/K89 warm the cleaning solution and follow the insructions.
by unknown on Oct 24, 2012 at 6:49pm Add comment
i got L200 epson printer...my problem is when i printed color or pictures the colors did not match and there r stripes in the pictures...ive already clean the head i done all that but still the same..help me please
by dhaks on Nov 11, 2012 at 7:47pm Add comment
hi i have problem of Epson sx525wd. west ink pad is full; how can i reset that printer. plese help
by unknown on Nov 11, 2012 at 11:07pm Add comment
hi i have problem of Epson sx525wd. west ink pad is full; how can i reset that printer. plese help
by unknown on Nov 11, 2012 at 11:09pm Add comment
hi i have problem of Epson sx525wd. west ink pad is full; how can i reset that printer. plese help
by unknown on Nov 11, 2012 at 11:16pm Add comment
My epson L200 won't print.the ink and paper lights are both flashing. what is the problem?
by unknown on Jul 13, 2013 at 3:07am Add comment
I have installed the Epson XP-200 printer on my Slackware 13.37 Linux system.
It is using the ESCPR driver and current scanner driver (iscan_2.29.1-5).
It will print from a file just fine and will scan and print equally fine.
1) What it is not doing is scan and create a file when I press the B&W + Color buttons on the printer console.
2) I expected an icon in the system tray but there is none. Should I expect to see one and does it create a means to examine the printers status?
by solari22 on Jul 13, 2013 at 4:46am Add comment
hi i got a epson workforce 1100 from the usa to ireland its a stylus office b1100 in euro countrys but the internal parts are the same main board etc/ my gf pluged it in to the mains here with out a converter from 240 to 110, white smk came from the back of the printer , what is it that has burnt out, there is still power going in to it as the green light comes on but just keeps blinking thanks for u help in advance,
by jay1000 on Aug 31, 2013 at 1:31pm Add comment
My Epson L200 shows error that there is no ink but the cartridge is half full and I am not able to print. What could be the problem. Still yesterday I was taking print out.
by unknown on Dec 25, 2013 at 12:36am Add comment