asked Mar 19, 2005 at 8:23pm
Dell Dell Inkjet 922

Dell aio 922 printer

My printer keeps on saying paper is jammed but there no paper in it and it won't print , when it dosent do that the paper won't go through for it to print . Help !!
What can I do if my printer is telling me print head error?
by unknown on Sep 17, 2006 at 9:28am Add comment
I have the same problem.

When printing from an application or from the main control, it always produces an "Out of Paper" error. But, when printing the test page, or producing a scan/copy, it feeds fine.

It also does not feed serve up the first page as it used to when powered ON. If manually feed, it FF's this page blank before saying no paper loaded.

Wierd for sure.

I even uninstalled/reinstall the printer driver and other printer software from scratch. Same deal.

Earlier, it was producing the "Paper Jam" error, but cleaning the rollers seemed to have cleared that up.

Careful on the hinges. IF the right one breaks, it's impossible to keep the lid sensor lever in place. It gets knocked off each time the cover is closed due to poor alignment. I finally had to just tape the lever down.

by unknown on Nov 3, 2005 at 4:57pm Add comment
My printer says lid open and I have opened it and closed it several times and it continues to read lid open. How do you fix it?
by unknown on Jul 25, 2006 at 3:08pm Add comment
My printer is giving me a similar error message: Cover Open
But its not open. I have tried the toubleshooting options and nothing is available for such error message. Please help me: I am at my wits-end!!! - Anonymous
I accidently dropped my printer one day and when i tried to repair it it came with an error: Print Carrier Stall Check for obstructions. or something along those lines. I have taken the machine apart near completely and cleaned and checked if anything was broken. Nothing seemed to be blocking the path on the bar. when i turn it on it jerks to the left all the way and then returns to the right. nothing looks bent or out of place.... been workin on it for afew dayz so... can anyone help me?
by unknown on Jan 22, 2006 at 7:39pm Add comment
I have the same problem with me printer, it is the same as yours. Did you fix the problem? Pleas help me i tried to do mamny things and it still the same. Also, it makes a noise when i turn the printer on, at it says Prit carrier stall check for obstructions. Error 1200. What can i do please help me. - Anonymous
I have the same problem with my printer, it is the same as yours. Did you fix the problem? Please help me i tried to do many things and it stills the same. Also, it makes a noise when i turn the printer on, and it says Print carrier stall check for obstructions. Error 1200. What can i do please help me!. - Anonymous
Does this printer have a feature that allows the operator to view and choose which pages to print? If so, does anybody know how to set the printer settings for this feature?
by unknown on Sep 26, 2006 at 6:34pm Add comment
my printer say that i have to clear carrier jam. i have cleaned the carrage rail, but that did not help it is still doing the samething, could someone please help me. i would be so greatful
by unknown on Nov 27, 2006 at 5:37pm Add comment
I have an error message reading Carrier Stall - Clear Carrier Jam. I've tried everything. There is nothing in the way. Help! Does anyone know how to fix? Thanks, N.
by unknown on Mar 25, 2006 at 12:08pm Add comment
Clean the carriage rail. This is the round chrome piece that the carriage assy that holds the cartidges rides on. Use a paper towel that is slightly moist.
Be sure to not force anything. Unplug the printer after you get the carts in the middle. Move them to one side and clean and then move them to the other and repeat.

by theprinterman on Mar 25, 2006 at 6:16pm Add comment
Thank you very much Printerman, worked perfectly.

Such a simple fix for an otherwise frustrating problem.
- Miket13
I recently replaced the color cartridge in my Dell 922 All in one. I reeived the message - 'incompatible cartridge'. I reordered the cartridge and the same thing happenend. I verified the cartridge number. I reloaded the printer program. No luck! Any help?
by unknown on Jul 11, 2006 at 4:37pm Add comment
omg it totally worked. thanks printerman.

i just cleaned the chrome rod with a moist napkin, after my printer said there was an obstruction.
by Anonymous on Oct 23, 2006 at 1:45pm Add comment
I unplugged it and plugged it back in, I shook it, turned it upside down, and I even tried playing with the paper sensor. Finally, I figured "I'll fix it or replace it" then GENTLY ran a small screwdriver under the thin rollers just under the chrome bar (lifting the black plastic ever so gently as I went across) and OUT rolled a one-inch nail. (Go figure...)

Thanks very much for this site. Were it not for all of you and sharing the pain as well as the good ideas, I would have had to do without for a much longer time.
by unknown on Apr 2, 2007 at 12:49pm Add comment
Has anyone found a solution to the print head error message. It appears as soon as I turn the printer on.
by Anonymous on Aug 31, 2007 at 7:49pm Add comment
I have a Dell AIO Photo 926 printer. My encoder strip has somehow fallen off. How can I repair this?
by unknown on Sep 27, 2007 at 1:30pm Add comment
Is it a clear strip? Beacause the same thing fell out of mine and my printer isnt working. Im getting that 1200 stall error message. - Blizzy
My strip fell out too.. it says H-05 on it. Where does it go? How do I put it back?

Thanks - Anonymous
My printer was working fine before I went on vacation. When I came back, it wouldn't print. It acts like it's printing but the paper is blank. I thought the cartridge was bad, so I ordered a new one. I just got the new one today and it has the same problem. It sounds like it's printing, but it just spits out a blank sheet of paper. Can anyone help me?
by unknown on Nov 17, 2007 at 4:19pm Add comment
Printer is telling me "left cartridge incorrect"; but the cartridge had been working fine and there was no warning that it was getting low. Now it acts like it's printing, but sheets come out blank. Please help!
by TCM29 on Mar 15, 2008 at 7:28pm Add comment
I also just replaced the color cartridge on my 922, and and message saying "right cartridge incorrect" appeared. Please has anyone ever figured this problem out?!? - unknown
I have a new dell computer with the Vista operating system and the 1720 laser dell printer;however, I also have the AIO 922 dell printer which I like to use for printing color pictures and its copier function. I tried to scan recently and the machine would not scan. What can I do to restore the scan function?
by unknown on Jun 24, 2009 at 2:42pm Add comment
I found that when I switched to Vista, I had the same issue with my Dell 942 AIO printer not scanning. I have not come across a way to fix this, with my printer scanning from the Dell supplied software. Luckily, my girlfriend found a way around the problem. Press the mode button on the printer until you are on scan and hit select. Scroll left until you come to "scan to MS Paint" and press select. (The printer will still not do anything at this point). On your computer click on the Start menu, All Programs, Accessories, and then Paint. Click on the file menu and select "from Scanners or Cameras". You will probably have to adjust the quality depending on what you are scanning. If you have to scan something to a PDF you can use Adobe Acrobat Pro. I hope this helps. Sorry if I over simplified my instructions. - ph9110
does anyone know why my Dell AIO 922 printer says cover open..but it isn't?? Can't print anything, green power button won't turn off, I unplugged power source, USB cord..plug em back in..nothing..HELP PLEASE??
by KY Gal on Aug 11, 2009 at 8:54am Add comment
Can anyone help me with this problem;

I can print with no problem but when I try scanning it doesn't work. I wanted to trouble shoot and went to START ALL PROGRAMS DELL PRINTERS DELL PHOTO AIO printer 922 and what I should also have seen would DELL ALL IN ONE PRINTER but there is nothing there. It disappeared. I know I didn't delete anything and I was scanning 3 weeks ago with no problem. Any clues? Thank you in advance.
by Anonymous on Jan 4, 2010 at 8:45pm Add comment
I am getting a Paper Jam error when there is no paper jam - has anybody figured this one out?
by foxy842 on Apr 20, 2006 at 11:53am Add comment


Did you manage to fix your paper jam problem. I am getting the same message appear, I cannot see any paper jammed!!!

Steve - Anonymous
cut and paste the following fixed my paperjam error message

- Anonymous
What a fantastic website. I hope you've all fixed your printers. I have the same error message, it came on when I moved the cartridges into the middle to change them and now they've locked and won't move. Any ideas on how to get it working again?

Thanks lots.
by Anonymous on Jun 6, 2006 at 2:35am Add comment
Any help is welcome my lovely new dell aio 922 which was working cool up till last night, is now no longer printing in blue did the little test, thing and the yellow - red and blac are there but not the blue line???

Help Please
by unknown on Jun 19, 2006 at 2:55am Add comment
"printer keeps on saying paper is jammed but there no paper in it"

Same here. And my printer isn't so old, about a year i think. what a piece of junk.

if anyone knows how to fix the perpetual dell all in one paper jam error message (which does not allow you to print) please reply.

i have nothing jamming the printer.
by unknown on Jul 21, 2006 at 2:47pm Add comment
I think it is a production error and DELL obviously is not taking the credit.

I advise do not buy printer etc from DELL. I do not want to say anything about their choice of suppliers for laptops and notebooks but for other stuff they are really in trouble.
by Anonymous on Jul 21, 2006 at 3:01pm Add comment
Any idea how to fix printer head error?? PLEASE
by Anonymous on Jul 24, 2006 at 12:31pm Add comment
We fixed our "Print Head Error" on our Dell 922 after two weeks of trying everything. Here's what worked: changing the ink cartridges. One of the cartridges was defective. What a simple solution! Dell even sent us a free replacement cartridge for the defective one. - Anonymous
I have a new printer. the screen always says "cover open" I tried to open and close it several time. but the message does not go away. Because of this message I can not even do the alignment test. Can someone help me?
by unknown on Jul 27, 2006 at 6:43pm Add comment
I seem to be having a problem with the paper feeding crooked, then it jams. I have had this printer for about a year and I don't know why this is happening. My ink is getting low again and I seem to remember the feed acting up the last time I was low on ink. I have tried all suggested remedies and haven't fixed it yet. Any help would be appreciated.
by rondor on Sep 29, 2006 at 3:59pm Add comment
I had the same problem with my Dell 922 printer. I read this somewhere and I will pass it on to you:

The crooked feed and then jam could be caused by a foreign object inside your printer.

Unplug it, turn it upside down and see if anything falls out.

Sure enough a writing pen fell out of mine and then it worked like a dream! Wouldn't hurt to try!

If that doesn’t help, I sure hope you find the problem!!

- Anonymous
I had a similar problem, and was about to buy a new printer when my uncle shook the printer we heard a rattle and then 2 ink pens fell out...that's kids for ya! thanks goes to my uncle for saving me money!

now i am having the apparently 'infamous' paper jam error when there's no paper in the printer. tried the shaking again, didnt work. =) wont print, just keeps saying paper jam! any suggestions???

thanks in advance.
rb - Anonymous
Success!!! After months of my 922 printer displaying "paper jam" when there was blatantly no paper in there at all, I have fixed it! For anyone with the same problem, try this...

lift up the scanner to reveal the cartridge compartment; under the chrome rod on which the cartridges run there are two small gaps about 8cm apart. In the right one should sit the paper sensor which is a small black rod that hooks downwards; the problem I had was my sensor had bent up and out of the gap so all I had to do was bend it gently back into position using a small screwdriver and now everthing works fine!

Hope that makes sense and it works for everyone who has the same problem, Jon
by Anonymous on Oct 3, 2006 at 1:07pm Add comment
Thanks dude! Worked like a charm. - Anonymous
Thanks Pal. I had the same problem. Following your advise, the problem was solved. - Anonymous
AWESOME! You just saved us buying a new printer. Thanks Jon!!! - Anonymous
I tried your suggestion! It worked! Thank you so much! - Anonymous
Thanks Jon. I also tried everything. But this worked. The paper sensor, which is just a little metal tab in the right little slot under cartridge carrier, was out of the slot and stuck on the side. I just used tweezers to push it back in the slot and the printer was like new. JS - Anonymous
Jon, two years ago you posted a solution for fixing a Dell 922 "printer jam" message when there is clearly no paper jam. Thank you for the advice! Exactly as you described, the black "hook" in my printer had been dislocated (probably when a true paper jam had necessitated pulling the paper backwards through the printer) and your fix worked perfectly. Thank you for taking time to share your advice! - Anonymous
Thanks so much. After a frustrating hour when nothing was working I tried this. Though, I broke my sensor off! But...presto, it works again :) - Anonymous

Although I did not have same problem with paper sensor sticking up, I was able to barely see something clear under a small rod. I thought I'd broke it, when a small (inch long) black rod popped off, but it had a piece of tape (thanks to my kids, again) stuck to it registering as paper jam! Thankfully, I took the tape off & out, replaced the rod by popping back in & everything works nicely...NO MORE PAPER JAM ERROR MESSAGE!!!
Yay! - Anonymous
This "black hook" approach worked for me... thank you so much.
Note: i had to move mine kinda up and to the right so that it fit down into the right slot. First time I move it slightly up to get over... but didn't work... then I pushed it down into the slot and it worked... not sure how it got so jacked up (I guess upon a real paper jam, when pulling paper out backwards)...
anywho... thanks a million! - Anonymous
This is the best fix I ever saw.
Thank you. - Anonymous
my printer will not feed the paper correctly....does anyone know how to fix it because i do not want to have to buy a new one!!
Please Reply soon!!
by unknown on Oct 7, 2006 at 11:59am Add comment
YOU FIXXED MY PROBLEM!!!!!!!!!!!!!!!
i had a problem with my printer dell 922 and that is realy helped me
under the chrome that the carts are running on there are two small tips just has to push them in and it's working!!!!!!!!!

by Anonymous on Oct 24, 2006 at 6:36pm Add comment
I had the same problem as others with the Dell 922. The paper would not feed automatically, I had to assist it with my hand each time which was really annoying. The solution for me was to take the rubber band off the feeder roller and turn it inside out. It worked fine after that. I think the band had lost it's grip! Hope this helps
by Anonymous on Nov 7, 2006 at 11:57pm Add comment
My printer says, "Clear the carrier jam," I have checked everything I can think of and it still says it!!! What do I do???
by KGless on Nov 13, 2006 at 5:03pm Add comment
I fixed my problem (sheet feeding in crooked, misaligned, paper jams) by using a cotton swab and rubbing alchohol on the feeder roller in the back, and the main roller under the chrome rail. Seems to work now. :)
by unknown on Nov 14, 2006 at 6:56pm Add comment
I need help my print keeps saying that I have a print head error I don't even know what a print head is, so if you could please, please, please, help me I would really be greatful, THANK YOU.
by unknown on Nov 21, 2006 at 3:11pm Add comment
My 922 came up with that message right in the middle of printing a page. The ultimate fix was replacing the color ink cartridge on mine. The manual said to remove and reinstall the ink cartridges and clean off the contact surfaces-but to no avail. By removing either ink cartridge, I was able to manually print with the only remaining good cartridge installed. Curt - Anonymous
I am now on my second Dell all-in-one, and I a VERY unsatisfied with my purchase. Are these things pieces of junk or what? With my first, I recieved the paper jam error. With this it is the carrier jam. I am done with Dell!
by unknown on Dec 6, 2006 at 5:37pm Add comment
Well, I shook the Dell AIO 942 upside down too and must have jarred the jammed cartridges. I was then able to push them right and then all the way to the left. I hit select and by golly, it's working again.

Thanks Dell ....or should I say NO THANKS for the lack of technical support. Sad that shaking a printer upside down seems to help!

~ rr
by unknown on Apr 3, 2007 at 4:16pm Add comment
If you have shaken your printer and found nothing inside I have the solution for you. I took the printer apart and I noticed that there is a plastic lever that detects when there is paper in the printer. This lever can be bent in such a way that it does not return to its "no paper" position and so you get a paper jam condition.

by Anonymous on May 24, 2007 at 10:25pm Add comment
Yay! This picture totally helped me solve the problem. I was ready to throw in the towel and buy a new printer, but these instructions to fix the lever combined with the picture that showed where the lever was completely solved my "paper jam" message problem!!! The lever had become caught on the black roller part to its left. I used my finger to push it toward the right and it popped back in place. Thanks!!! - Anonymous
I've been trying to print stuff and all i get is " CLEAR CARRIER STALL"

i've checked for any jams, and i just cannot figure it out.


by unknown on May 26, 2007 at 10:40am Add comment
Had to laugh... Tried this forum in desperation, couldn't get paper to feed... Tried shaking it over my head in a last ditch effort, a pen fell out! Works fine now.... :)
by unknown on Jul 6, 2007 at 11:54pm Add comment
Too funny! See? Miracles can happen. Now, you draw a picture with your printer-produced pen and I'll nail it to the wall with the nail that came out of my printer.

Happy for you, Pete.
by unknown on Jul 8, 2007 at 8:47am Add comment
Help! My printer is telling me the Cover is open! But it is not open. And there is no way to open it up! Does anyone know how to fix this?
by Anonymous on Jul 8, 2007 at 2:24pm Add comment
Hmmm.. I just got this printer and I'm getting, My printer is displaying a "1200 - Cartridge Stall" error. as soon as I put it on it makes a big loud noise, it scans fine but doesn't print or copy. I called DELL and they basically told me nothing, check the cartridges it may be the cartridges and if it is they said to order new ones, those bastards!!! Anyone know what the problem is??

by tj1182 on Jul 23, 2007 at 11:45am Add comment
I have been getting the same error message. Let me know if you fix it.

Thank you.

-Gary - Anonymous


by Anonymous on Jul 29, 2007 at 10:25am Add comment
I can't believe this!! I thought "Shake my printer upside down?" Crazy!! well, after reading your post, I remembered I removed a tac board from above my printer. I shook it, no tacs, but the stupid thing works now!!!!! - unknown

I recently got a Dell aio 922 refurbished on-line. The first time I replaced the black cartridge all I get is error 1200 Cartridge stall. I don't want to force anything but the cartridges are stuck under the plastic housing so I can't take it out to check it. What to do?
by grzaho on Oct 6, 2007 at 12:27pm Add comment
I recently performed a clean format of my pc. I had all original DELL software and OS (XP)at hand. I haven't had a problem with any other hardware what so ever on reboot - it even picked up my dsl modem w/o the disk BUT - I keep getting an error about the 922 button blah blah blah and upon exiting the error up pops a window asking me to install this DLBTHPEH Dell injet file. I used the "DELL photo All-in-one printer 922" disk but it cant seem to find the file on there. Tried all the other disks that had various drivers and such on them but still.....empty handed. Any suggestions?

Thanx, HLC
by unknown on Oct 27, 2007 at 12:32pm Add comment
I changed the ink cartridge 3 weeks ago and get error 1200 print carrier stall. I need help or will be forced to take it somewhere and pay alot to get it fixed.

I've checked for obstructions like it said but nothing. It still won't print!

by grzaho on Nov 1, 2007 at 3:32pm Add comment
ok so i just bought new ink cartridges and its telling me that the black ink is low and i don't get prints ok but the black ink is real light..what do i do??????? please if u can help me that would be awesome!!!
by unknown on Nov 5, 2007 at 7:44pm Add comment
I gave up! Printers are so cheap now you'd be better off just buying a new one like I did. I bought a new Lexmark aio for only about $40! The aggrevation wasn't worth it!!
by unknown on Nov 5, 2007 at 10:31pm Add comment
You're lucky if you get a few months of printing out of the printers made now-a-days. The gears(cheap plastic) or the cables break. I waste time and miney trying to fix mine until I just gave up and bought a new one. It isn't working good either!
by unknown on Nov 18, 2007 at 12:33pm Add comment
I am getting a cover open error, any hekp ?
by jimhippensteel on Nov 18, 2007 at 6:56pm Add comment
did you ever get help on this problem? I can't seem to fix mine..HELP?? - KY Gal
Odd forum. Lot's of questions; many more me-too's. Few answers. If your problem was already mentioned, why do you ask again? Others just have to wade through the repetition looking to see if maybe somebody provided a solution.

I get the Open Cover error pretty often. Can't figure out why. I've taken to powering off by pulling out the power cable and reinserting it. The fresh power cycle clears the error, at least for awhile.
by unknown on Nov 24, 2007 at 12:37pm Add comment
My ink cartridge is stalled...Error 1200...They won't move swiftly on the rails. What do I do???
by unknown on Jan 4, 2008 at 2:11pm Add comment
I had to just reach in and pull the cartridge carrier out from the side. It worked
by unknown on Jan 31, 2008 at 3:07pm Add comment
You might also have a blockage from one of the little (aluminum?)mini-gears under the carriage assembly. Printing in my aio 926 froze at 99\% every time, responding with paper jam. I noticed the carriage was almost in the middle of the printer, and did not appear to ever move. I pushed to the sides until it gave way, and one of those little gears was sticking up where the carriage used to be, attached by some spring wire. I pulled it out and all the extra wire, and the carriage moved freely. Printing good after.
by tdvtech on Feb 13, 2008 at 3:35pm Add comment
Yay! I just had the same problem. I noticed when I opened the top that one of those cheap little gears was out of place but I didn't know that I could just pull out the gear and the wire without messing anything up. The plastic on the inside of the gear actually broke. So after I read this I ripped out the loose gear and wire and everything is fine now. Thanks. :) - Anonymous
can any one tell me why my dell 922is printing /copyinf onto the second page plase?
by unknown on Feb 23, 2008 at 5:54am Add comment
My printer will not register that is has paper in it . Sure could use some help.
by larry gov on Mar 8, 2008 at 12:18pm Add comment
It's funny to think that when you buy a dell product, it gives us a one year warranty and after 1 year you will see this problem. My printer keep saying "CLEAR CARRIER JAM" i had tried everything, all the suggestion that i could gather here but none of them works. Is there any other suggestion or should i buy a new printer?

by Anonymous on Mar 11, 2008 at 5:43am Add comment
>>>After replacing the black cartridge, I now get a stalled carriage and Printer Error 1200. Please help me as I'm desperate to copy the Crosword Puzzle for my lovely wife!
by Anonymous on Mar 13, 2008 at 5:17am Add comment
>>>A repeat of earlier request. Printer Error 1200 after replacing Black Cartridge. Please help!
by unknown on Mar 13, 2008 at 5:19am Add comment
by unknown on Mar 17, 2008 at 8:00pm Add comment
Thanks for your help. Discovered that closure on Color Cartridge had become open. Wife fixed. Can now print he Crossword Puzzle.
by Rbaker on Mar 18, 2008 at 3:24pm Add comment
I am also getting "right cartridge incorrect". Bought new colour cartridge & installed it and have been looking at above message since.
Have tried;
*plugging in/ out
*taking out & reinstalling cartridge many times
*shaking upside down
*shouting at it
*praying to vishnu/ buddha/ satan
*spending more time with the stereo in a vain attempt to make the printer jealous...

Help please!
by oiche on May 10, 2008 at 11:27am Add comment

Hi there,
please, I would like to know if you ever solved this problem, because I am having the exact same problem! This is so bogus...someone (dell) is starting to look really shady. - unknown
Did you get a response to your posting? I am having the same problem and can't figure out what to do.
- Anonymous
In answer to a PM:
Was the electric bit on the cartridge not been recognised by the printer. They have a finite life apparently. Cartidge World sorted me a 'new' one which Ive been refilling there ever since. Sorted!! - Anonymous
Help -- my printer feeds the paper only about half way and then continues printing, but the paper doesn't move. I have had this printer for about 3 years, but it only gets light use. I would rather not have to replace it.

by unknown on Jun 19, 2008 at 11:39am Add comment
Well, I didn't have a pen fall out, but when I rolled my 926 over a few times, something rattled around. Sounded like a small plastic fragment or object. Didn't fall out, but must have settled somewhere neutral enough to allow the paper skewing to stop.
by unknown on Jun 26, 2008 at 8:47pm Add comment
Can anyone help...
my dell 922 printer remains dead in the water with the message print head error, I have tried all things in the manual but the message installed the software, disconnected and replaced the cables etc, cleaned and replaced the cartridges, any suggestions please or do I just bin the machine and buy another brand.
Running winxp
by gordon paul on Jul 6, 2008 at 5:07am Add comment
Thank you anonymous..6/27/08.
It was one of the cartridges defective (short), as you say a simple solution, but not posted in the 922 manual. thanks again gordon pau. (Aust)
by gordon paul on Jul 8, 2008 at 9:13pm Add comment
Thank you anonymous..6/27/08.
It was one of the cartridges defective (short), as you say a simple solution, but not posted in the 922 manual. thanks again gordon paul. Aust.
by gordon paul on Jul 8, 2008 at 9:16pm Add comment
I've been using the refill cartridges from cartridge world. I've been managing ok with these cartridges. I last used the printer a couple of days ago and it worked fine. Now it's printing blank. I replaced the cartridges and it's still printing totally blank. I've restarted things and unplugged the printer, but it's still not printing. Any suggestions?
by unknown on Jul 15, 2008 at 2:26pm Add comment
I just had this same issue happen to me about two weeks ago.
It was working fine, and then all of a sudden it starts printing blank pages. I checked the ink cartridges to see if maybe they were dried out or needed cleaning, but no, they were fine.

I also now have an error message that says "Right cartridge incorrect" which won't go away. The orange exclamation mark light continues to flash non-stop. - Anonymous
Printer roller in top feed tray pulls paper in the middle and outside paper ends up crunching up on sides from the tension. I made the attempt to turn it upside down and make sure there wasn't torn paper, or any "foreign" object keeping the roller from pulling the paper in correctly...but no go so far. anyone have any ideas? hollar at me...thanks!
by steves23 on Jul 19, 2008 at 7:34pm Add comment
i had the EXACT same problem but when i really dug in there, it turns out a pen somehow got in there and got lodge, so about 30min later and a little bit of shaking it came out. PROBLEM SOLVED!!!! i could have sworn there was no way something would get in there, but in all honesty check it! - Anonymous
I have just fixed a paper jam on my printer, but now even though I have recently replaced the black cartridge, when the paper feeds it will not print anything. I took the cartridge back out and made sure I removed the tape and I did. Why is it not printing? Thanks for the help!
by darrin on Jul 30, 2008 at 5:53pm Add comment
hi,i can not turn on my 922 printer.i press the power button and nothing.i tried disconnecting the usb,power cord and restart the computer with no success.this all seem to happen after i cleaned the nozzle,and align.can you please help me?marc
by marcus220 on Aug 11, 2008 at 2:48pm Add comment
Out of nowhere my printer has been printing a lot of black solid lines and smeared lines all over the regular printed document, and then started giving me the alignment problem pop-up box. So I've tried cleaning the carts, reinserting them several times, made sure the paper is perfectly being fed in, rebooted it, and it is still doing this. What else can I possibly do to fix this alignment problem? I haven't really had any big problems with this printer considering I've had it for about 4 years now so it's been good to me.
by unknown on Sep 4, 2008 at 11:25am Add comment
My printer wouldn't "read" the new colour cartridge I installed so Dell mailed me a replacement cartridge. It didn't work either, and then the ink cartridge carriage stuck in the open position. I looked for the various bits and pieces you folks suggested cleaning or prodding, but couldn't really figure that out, but I followed the suggestin to give the beast a good shake. Nothing much happened. By that time I figured a new printer was in order, so with that decision made I stopped being gentle and used all my strength to force the carriages back to their lefthand position. Good grief! Now the foolish beast is working again. And obviously using a lot of pressure on the carriage didn't hurt anything.
by Anonymous on Oct 9, 2008 at 10:10am Add comment
i have a dell aio 922 printer and am getting the error 1200: print carrier stall, check for obstructions....did that and nothing....talked to dell and got no where....can someone please help me solve this problem.....

by angelsweet on Oct 12, 2008 at 5:31pm Add comment
I was given a Dell AIO 922 today: the previous owner didn't know if it worked or not (their policy at work is
by unknown on Oct 24, 2008 at 5:32pm Add comment
does anyone know where the hinge cover plate goes? is there a pic of where it goes? thanks for the help. pulled jammed paper out of machine and it came out with it. [email protected]
by unknown on Nov 28, 2008 at 4:14pm Add comment
You are a genius (re. the non-jammed paper)
by unknown on Dec 7, 2008 at 9:52am Add comment
does anyone know where the hinge cover plate goes? is there a pic of where it goes?
by Anonymous on Dec 8, 2008 at 11:30pm Add comment
My Dell 926 printer has a paper jam. It does not read as paper jam,It says load paper, but there is obviously a paper jam. Does the printer open up so I can get it out of the roller ?

Thanks !!
by Anonymous on Dec 26, 2008 at 7:49am Add comment
My Dell 922 AIO Printer won't communicate with my
Dell Inspiron 6000. Please help. Thank you.
by Anonymous on Jan 2, 2009 at 8:43am Add comment
okay so this stupid printer ismaking me so bad i keep getting a carrier jam message ive done everything under the sun shoke it beat it banged it one the table cleaned everything on the inside now im covered in ink pissed off and still nothing the printer cartriges dont even move when i open it and when i push the select button like it tells me its makes this grinding sound and the carrier slams fromside to side so hard the whole thing shakes......any ideas or is my printer screwed?
by unknown on Jan 20, 2009 at 12:46am Add comment
I have purchased a black and color cartridge for my Dell AIO 922 Printer twice. I continue to get the "alignment problem" remove tape from cartridges. There is no tape on cartridges. Any suggestions on how to resolve this very, frustrating problem? would greatly appreciate ANY and ALL assistance.
by unknown on Jan 23, 2009 at 7:16pm Add comment
Hi, I'm getting white lines, a 2nd page prints, distorted first page, some line print almost on top of each other (creating blurs) Any help would be appreciated
by Anonymous on Jan 26, 2009 at 7:17am Add comment
i FIXED IT...if you read below, I was able to fix this error message...

Apparently, my kids (yes, they did it again) had put a piece of clear tape in the paper slot of printer and caught on a rod & registered as paper jam. Once I took tape off & popped rod back in place, printer works just like normal.

thanks to this website for help. awesome! i was beginning to feel helpless!
by Anonymous on Jan 27, 2009 at 3:15pm Add comment
I have the same problem with my A922.. ERROR 1200...
When I turn it on it sounds like it's in a one printer destruction derby.. i turned it on with the lid up and the carriage is slamming into the left side and then slamming back into the right side and then it stops and gives me the error message.. is there supposed to be some kind of sensor in there to tell it when it's near the end of the run?

I tried shaking it upside down...

..I tried cleaning the chrome rod..

I tried taking the ink cartridges out..

Save me PrinterMan.. you're my only hope!
by unknown on Feb 5, 2009 at 9:22am Add comment
I think i have a theory as to what's going on... i noticed there is a plastic strip running parallel to the chrome bar with black lines all along and then clear about where it should stop... i noticed a red glow coming from the side of the printer mechanism too like the light in an optical mouse.. so i figured that this plastic strip must be part of an opto-coupler sensor.. i didn't see a red glow coming from the back of the printer carriage though so i took the whole thing apart and sure enough, there's a plastic disc on the side where i saw the red glow coming from, but when i took the carriage off the rail i saw that there was a glow there too - hmm... i cleaned the sensor out really good and put it back together, but it still did the same thing..... so i guess there must be a fault somewhere on the control board :(... it sounds like it's time for a new printer :(
by unknown on Feb 5, 2009 at 10:08am Add comment
printer is not recognizing! I can copy, but not print...any ideas would be appreciated...all connections are made.
by Anonymous on Feb 5, 2009 at 5:52pm Add comment
I'm having the same prolem. No one seems to know what to do!!!!!!!!!!!!!!!!!1 I've done spent too much $ on this thing!!!!!!!! - Anonymous
I had a message come up that my printer was stalling. The ink cartridges were stuck on the left handside of my printer. I called Dell and did not get an answer, so I just played around with it and tried to physically move the ink cartridges. With a gentle pull the ink cartridges become unstuck and now it works perfectly!
by unknown on Feb 10, 2009 at 3:27pm Add comment
After replacing the black cartridge, I now get a stalled carriage and Printer Error 1200. Please help me as I'm desperate to copy the Crosword Puzzle for my lovely wife!

by gjoyanial on Feb 28, 2009 at 12:07pm Add comment
My printer begins to pull the paper in to print but then the paper gets stuck.
by unknown on Mar 23, 2009 at 6:48pm Add comment
I have exactly the same symptoms as "I just want to sew"; demolition derby or what! The head thrashes to lhs and then rhs; it would take your fingers off it's so violent and then stops and gives error 1200...

Haven't seen this one before. It seems to be intermittent too; I managed to print 3/4 of a page tonight before the derby started! I think it is as you say I just... a problem with opto coupling on the servo strip; I suspect the flat cable feeding the head tho - this is the most likely place for a problem to develop with a break in 1 or more tracks from all that flexing. I wonder if these are available anywhere at a reasonable price coz the printer does a pretty decent job still. Otherwise I think you are right - it may be time for a new printer.
by teknophil on Mar 31, 2009 at 5:29pm Add comment
I just refilled my ink cartridge but my computer and my printer read that the ink levels are still where they were before I refilled my cartridge. How do I get this thing to recognize there is more ink!
by Anonymous on May 6, 2009 at 9:23pm Add comment
I followed the adivce of someone who said to clean the bar. Then I unplugged the printer and the carts moved. It then responded by saying to clear the jam. It was jammed alright, with a small cog and spring. Hope that wasn't important, I got it out and the carts can move fine now.
by unknown on May 13, 2009 at 10:34pm Add comment
My Dell aio 922 was printing blank sheets. I replaced both cartidges and cleaned the chrome bar. Managed to get it to print a copy of page perfectly. Now it is printing blank sheets again. Help?
by unknown on May 25, 2009 at 6:35am Add comment
Lindsay Baby, you made my day!

I was about to through that heap of junk through the window when i read your post. With my hopes set low I unplugged the printer, turned it upsidedown, and out feel a small piece of plastic. Now it at least prints! Still not straight, but hey, it's a start.


by unknown on May 29, 2009 at 2:25am Add comment
Frig, went to use my scanner today and got a 1200 error.

Tried some of the suggestions and still nothing.

Even took the dang thing apart. Nothing.

I'll keep trying a bit longer before I throw this thing out.

Worked good for a couple years at least and was free so, can't complain too much.
by unknown on Jun 5, 2009 at 5:24pm Add comment
My scanner will not work, I recently had a problem with my computer and I had it fixed, they had to remove all my software and my printer/scanner/fax was removed. My printer (Dell Photo AIO Printer 922) works just fine, but my scanner will not scan. I no longer have my disc to reload it, what do I do??? Please help!!!
by AMRasdon on Aug 3, 2009 at 10:11am Add comment
anyone have a solution to "cover open" on my Dell AIO 922 printer? Says it is open..but it isn't..tried unplugging USB cord,power source..shut down computer, restarted..and still says"open"..HELP??
by KY Gal on Aug 12, 2009 at 7:44am Add comment
Same problem here! I can't find a solution to this problem..?? Doesn't anyone know why my 922 says "cover open" isn't..i haven't been able to print anything for 2 weeks now..HELP??
by KY Gal on Aug 15, 2009 at 12:38pm Add comment
Yess!! This worked.

I replaced my printer cartridges and then all of a sudden got the error message "Print Carrier Stall Check for obstructions". I tried cleaning the chrome rod as people suggested and that didn't work. Then I tried shaking it and that didn;t work. Then I realized that the buttons on the print cartridges weren;t pushed down all the way. The printere must have sensed the blue and black things being loose and produced this error message.

Thanks for the help!
by unknown on Sep 6, 2009 at 4:15pm Add comment
can anyone help me with a "cover open" message on my Dell 922AIO isn't open.
by Anonymous on Sep 12, 2009 at 10:44am Add comment
On my Dell 962 printer, I fixed that error by finding the 2 plastic parts (attached to the back of the cover) that push a metal part downward to close a contact, removing the broken plastic pieces and using a 3 or 4 inch C-clamp to hold the cover down at the back started the printer working again. I hope this helps you. Before that I had an empty cartridge error when I installed a new ink cartridge. When I looked at the gold contact dots on the back of the ink cartridge, I discovered that some were missing. Dell replaced them and the replacements were likewise defective. As we say "Easy as Hel_ - Anonymous
On my Dell 962 printer, I fixed that error by finding the 2 plastic parts (attached to the back of the cover) that push a metal part downward to close a contact, removing the broken plastic pieces and using a 3 or 4 inch C-clamp to hold the cover down at the back started the printer working again. I hope this helps you. Before that I had an empty cartridge error when I installed a new ink cartridge. When I looked at the gold contact dots on the back of the ink cartridge, I discovered that some were missing. Dell replaced them and the replacements were likewise defective. As we say "Easy as Hel_ - Anonymous
What is the solution for correcting the "cover open" message error. My printer is locked up and will not print.
by unknown on Sep 21, 2009 at 11:00am Add comment
I pitched my Dell AIO 922 printer/scanner...Dell could not even help me..
I now own the new Kodak ESP 3se AIO and love it!!!!!

- Anonymous
My printer has decided that when I press the "Scan" button, it will sit there, and do nothing. Seems like the only explanation is that this thing is junk. I don't expect any help from DELL though, considering that after having several problems with my computer after purchasing it, having them send techs out to my house, replaced my hard-drive(to no avail), and eventually told me that due to the number of problems I was having they would be sending me a new system. I waited the 14 days, and called them back, asking where my computer was, and they responded as if they had never heard of me. "We can't do that" was their final statement. I will never in my life purchase anything from DELL again, nor will I advise it. As a matter of fact, I will actively campaign against them. Because, as i like to say, "DELL SELLS LEMONS"
by unknown on Oct 5, 2009 at 4:08pm Add comment
DELL 922 AIO Printer

Installed two new ink cartridges and get error message on machince that right cartridge is incorrect. Try to print and pages come blank. How do I fix?

by wearefor66 on Oct 16, 2009 at 8:36pm Add comment
I have a new laptop with Windows 7- is there any drivers or patches that will make this printer work with my new lapop? Apparently the printer is not compatible?

Thanks in advance
by unknown on Jan 2, 2010 at 2:09pm Add comment
My Dell aio 922 ran out of black ink. When I put refilled cartridge in, it gave me a message of "print head error". After taking cartridge back to place where it was refilled, it was checked out. Then when I reinstalled the cartrige, gave me a message of "black cartridge missing".Then I purchased a new cartridge and when it was installed, it gave me the message of "print head error".
I am whits end. I about ready to throw the printer in trash.
Please Help
by unknown on Jan 2, 2010 at 5:05pm Add comment
Error message: Print head error

This type of error message typically happens when the printer head is not clean enough. You could try installing software that is used to clean the head of the printer. You could try clicking on ‘start’ then go to ‘settings’ and then ‘printers’. Select your printer and right click on it and go to ‘properties’. Check to see if there is any such software installed. If cleaning does not seem to work then the other option is to try replacing the printer heads.
by unknown on Jan 2, 2010 at 6:06pm Add comment
thanks - Anonymous
Im glad everyone has had sucess fixing their printers. But my problem is software related. Anyone up for a challange? I keep reloading my software and it says driver already installed and then says it is updating the driver. But when I try to print, it asks me to find a printer and tells me when I select the 922, there is no driver installed for it! It did have the icon down in the quick launch showing status ready, but thats not showing up anymore since I tried to remove the printer and reinstall it completely. I have more than one hard drive installed on my dell dinension 2400. Might be a conflict going on somewhere? Frustrating! Maybe someone has experienced this and has a fix.
by unknown on Jan 8, 2010 at 2:22am Add comment
My printer was working fine until I tried to use it a couple of days ago. I haven't used it in a while since I only use it when I need to print in color (Laser printer for B & W). I bought an ink refill kit like I used to do for my HP printer. Filled the cartridges, and now the paper won't feed. I didn't know if this was the problem, so I bought new cartridges and installed them. The printer will still not feed. The paper starts going in, then it seems like only 1 side is feeding, causing the jam. It does this no matter what kind of paper is used. Is there a way to fix this?
by unknown on Jan 18, 2010 at 11:08am Add comment
I'm just trying to scan some photos. Press the scan button and nothing happens. What am I missing? It's connected to the laptop that is running Vista. Ideas?
by unknown on Feb 19, 2010 at 9:13pm Add comment
I cannot get the housing over the black cartridge to close properly since I installed a new cartridge. Even tried putting the old cartridge in and it won't click close.... but it will if there is no cartridge in there so it's not like it's broken... just won't close with a new cartridge.
by unknown on Feb 25, 2010 at 3:39pm Add comment
I am having the same problem...did you ever solve yours on the 922 printer cartridge problem closing securely ?...thanx, frank - unknown
I tried to register and put the wrong address in and I can not correct it . Please help ASAP.
by Anonymous on Mar 22, 2010 at 2:57pm Add comment
I have replaced a Black ink cartridge for the dell AI 0ne 922 printer and I cannot get the printer to work...

it comes up on scrren showing its still on the reserve tank within the software template... Can anyone tell me what I have to do to reset it to work.... my colour cartridge is very low and at the moment it only prints out in Red .. I could not find any instructions on How to reset the printer be it a switch on the printer itself or within the software...

Also can anyone tell me if they have ever used a refill kit to refill their cartridges... I have also tried this and still get the same message that I am still on reservve tank

I have pressed continue, but it wont accept it or work..

thk you
by unknown on Apr 3, 2010 at 9:00am Add comment
Hi,for above message please reply here... I selected the wrong account when i posted..

I have replaced a Black ink cartridge for the dell AI 0ne 922 printer and I cannot get the printer to work... - dowspx
My printer has several problems:
1) It skips to about 1/3 down the page and then smudges & skips.
2) Most of the time it jams the page unevenly.
3) The power button sometimes won't power off until 3 or 4 tries.

I used a non Dell ink cartridge on the black side and after the 4th cartridge I started having trouble. I've since then purchased Dell ink cartridges but it still does'nt work. I don't want to trash it and I can't afford a pro so if I can salvage it I will. Please help. Thank you.
by alhenry on Apr 7, 2010 at 10:24pm Add comment
Ok what is a print head and how do I fix the "print head error".
by shydamsel on Sep 13, 2010 at 6:06pm Add comment
Problem: Paper jams, prints crooked
Solution: As many users have posted, shaking the printer upside down to try to get foreign objects out works pretty well. In my case there were a bunch of Styrofoam peanuts in there from packing it one time. I had to take it all apart and put it back together.

Problem: Doesn't recognize that there is paper loaded
Solution: After taking apart my printer for the last problem there was one part that I didn't know where it went back in. I believe now that it was the sensor for detecting if paper was in the tray. I left it off to the side, hanging by its wire. There's a small circuit board on it, with 4 stiff wires connecting to it and holding it in place. I took a paper clip and shorted all the wires together - the error went away.

Problem: Tries to print test page every time the printer turns on. Started after completing the previous two solutions.
Solution: ?? It went away eventually. May have been related to changing to Windows 7 and upgrading the driver.

Problem: Windows Vista driver not compatible with Windows 7.
Solution: Windows 7 compatible driver (may want to uninstall and clean up all current drivers [google for cleanup tool]):

Problem: Having trouble scanning.
Solution: Turn on printer. Open Dell All-in-one center on computer. Go to scan tab there and select options, etc. This seemed to work better than choosing to scan from the printer buttons.

Problem: Open document, hit print, printer does nothing. Print job manager on computer says it is printing but nothing ever happens. Hit cancel on job manager, changes status to Printing-Deleting, but still nothing ever happens. Cannot delete job, cannot print anything else.
Solution: Restart computer. Even if you have tried to cancel the job it may still print. Make sure there are no other jobs in line behind it. Try to avoid sending a print job to the printer while it's still finishing another. This seems to cause the error more often, but it can happen randomly.

Problem: Scanner is cropping and only scanning small parts of it. I want to scan the whole page.
Solution: Scan using the Dell All-in-one center. Go under See More Scan Options > Advanced, and choose Select Area to be Scanned (instead of Auto-Crop). Choose your paper size.

Problem: Plugged in and turned on printer. No light on power button, no screen light, no reaction to power button. Only activity is about once a minute the cartridges will move a bit right, then left and click a couple times. Then the roller that normally spits out the paper closest to the output will spin very quickly for a beat (sounds like a scraping noise). No buttons do anything. Power cycling does nothing (plugging-unplugging). Tested on different outlets, attempting to print says Communication is unavailable.

>>Insert standard rage about Dell crap printers here<<
by unknown on Jan 31, 2011 at 6:42pm Add comment
after I click on print it takes 4-5 minites to start printing. This is very annoying when I have a lot to print. Please help. Thanks. glennie.
by albertnell on Feb 1, 2011 at 11:17am Add comment
I am getting a solid black line from the top to the bottom on any page scanned and printed. I do not get any erros, lines or any other problems at all when I just simply print. SO there has to be a problem with the scanner- Can anyone help??
by unknown on Feb 26, 2011 at 10:30am Add comment
I have just re-installed my dell AIO 922 printer after it sat for a good 5 years. I did a test print- knowing I was out of black ink, but am certain that I had plenty of color, and nothing showed on the paper. I realize after setting for so long the ink may have dried up(?) Is there anything I need to be aware of it setting for so long? I hate to buy ink if I may need to have other things checked out.
Thank you for any help. Roni
by roni in idaho on Mar 10, 2011 at 7:29pm Add comment
Out of nowhere my printer has been printing a lot of black solid lines and smeared lines all over the regular printed document, and then started giving me the alignment problem pop-up box. So I've tried cleaning the carts, reinserting them several times, made sure the paper is perfectly being fed in, rebooted it, and it is still doing this. What else can I possibly do to fix this alignment problem? I haven't really had any big problems with this printer considering I've had it for about 4 years now so it's been good to me. I have also realigned several time and same error message pops up on printer.

by dtentcher on Mar 17, 2011 at 3:55pm Add comment
Has anyone gotten any answers on how to fix the solid black line problem yet? - unknown
I turn on my dell 922 it says paper jam with no paper jam, or paper in it at all. all buttons are froze an can't do anything.
by YtwnDnky on Mar 23, 2011 at 9:48pm Add comment
Has anyone been successful make this printer work with Vista OS?
by unclemarc on Apr 21, 2011 at 11:08am Add comment
Has anyone been successful make this printer work with Vista OS?
by unclemarc on Apr 21, 2011 at 11:10am Add comment
I have a big problem with a very high screaming noise from my w5300 Dell laserprinter, when I start to print something.
I can't hear where the noise is coming from, but it's in the back of the printer, I have tried to lubricate all the bearing with no luck, I have tried to change the exit module with no luck.
I can it be the fuser, even I have made the lubricant.

by jsandc on Oct 10, 2011 at 4:24am Add comment
i am trying to scan a document from my dell AIO printer scanner to my dell inspiron 1521 laptop and it wont do anything when i press scan how do i make it scan the document onto the computer so i can save the file?
by unknown on Apr 25, 2012 at 1:02pm Add comment
I have power to my AIO 922 printer, the power light is flashing, but the little window is blank. When I try to print, I get an error suggesting there is a communications problem. My PC can't communicate to the printer. All connections are connected. The only problem I see is that the window on the printer is blank. It will normally be defaulted to "copies - 1". There is nothing in that window. How can I fix this?
by unknown on Jul 21, 2013 at 4:10pm Add comment

this site is old just like my dell 922 but i can't afford another printer or even repair. the gray strip came out and the cartridges are banging. i need to put the strip back in but don't know where it goes or if i need a tiny flashlight. i've had the dell for ten years and like it. i'm sorry it's causing problems. i've dealt mostly with software fixes to get it to work on a new laptop years ago. i also had to do it several times after restoring laptop. i need this printer and it was working fine until this gray plastic strip came out and i see on here or online, it needs to be put back where it belongs. where does it belong

by natalie on Mar 27, 2017 at 1:02am Add comment
by unknown on Jan 2, 2010 at 3:11pm Add comment