asked Mar 15, 2005 at 6:41pm
Hp HP Photosmart 7660

hp photosmart 7660 cartridge cradle is stuck

how would i slove this problem. everytime i turn on my printer the cartridge cradle moves from left to right no problem but on the display screen of the printer it reads that "my cartridge cradle is stuck. clear jam then press ok."
No original belts are available other than ones that have been recycled. The Deskjet 900 series belt is slightly wider, HP P/N C6426-40115, but can be used. You should be able to find one online for $10.

The case will have to removed. It's been so long since I opened up a 7660 that I can't remember specific details on how to remove it other than prying off the control panel overlay being the key.

Replacing the belt is relatively easy. The carriage will have to be removed. I have some photos if you need them. To email me click on the crossed tools to the right of my name and ask for the Photosmart 7660 mechanism photos.
by Bert on Apr 16, 2008 at 9:46pm Add comment
How do you get the cover off to reinstall encoder in back of cradle? hp 7960
by Anonymous on Apr 15, 2009 at 11:05am Add comment
I busted my printer today and I am a bit upset. Somewho I broke my 56/59 cartridge lock down. I had to change my inks, which I did and then printed the calibration paper fine. I then went to print a picture and it jammed and I open the door to find that it was broke right off. Do you have any ideas if that can be replaced or if I am stuck buying a new printer. I love this printer! If I had to buy a new one is there a better printer. My first option is to fix this one if possible. Can anyone help?

by unknown on Dec 13, 2009 at 1:55pm Add comment
I have the same problem. Ink heads move freely, but I still get message.
I am almost 100\% certain my encoder strip is out of position, and need to know if I can repair it myself.

Did you get any replies?
Someone help Please!!!
by bobconley on Apr 20, 2005 at 5:57am Add comment
The encoder strip threads through a slot in the carriage and attaches to a springy hook on the left and a stationary hook on the right.

If the carriage (cradle) will move under it's own power, check for a broken service station (far right). It should retract to allow the carriage to park.

If the service station is broken, there are no spares available form HP.
by Bert on Apr 20, 2005 at 2:04pm Add comment
What does the service station do to "park". The cradle is to the far right, and the dock(?) seems to be in the "down" position. Is it supposed to come "up" to meet the cradle when it moves all the way to the right?
by bobconley on Apr 20, 2005 at 2:14pm Add comment
On a working printer the service station cleans the print cartridge nozzles, using small squeegees, and caps and locks the carriage when the printer is idle.

The service station can fail to release the carriage when printing is initiated, or fail to retract the squeeges and caps properly so the carriage can park (dock) when finished printing. Either one of these situations can cause a "cartridge carriage (cradle) is stuck. clear jam then press ok" message.

I have two 7760s (similar to the 7660) in the scrap pile with broken service stations. I can't say with certainty that you have a service station problem, but my experience with the 7760 centers around it.
by Bert on Apr 20, 2005 at 4:25pm Add comment
I know your post is over two years old, but do you still have the 7760's? - Anonymous
After extensive troubleshooting last night., the service station will release upon startup, that is when I manually retract it, but it wont retract when the carriage wants to park.

That's weird because it suggests the motor is working, but only in one direction. When the carriage wants to park, the motor tries to release the service station to meet the carriage, but it doesn't move.

I can see it trying, like the motor is working, but something is not letting it move. That being said, I can manually move the service station in both directions, so I know there is nothing lodged or blocking the path.

Have you ever seen that, where the motor will work in forward, not reverse, or vice-versa? I cleaned the encoder strip. Does the encoder strip tell the service station to move? What triggers the service station to retract to meet the carriage?

Any advice would be helpful. Still frustrated, ready to buy new printer.
by Anonymous on Apr 21, 2005 at 5:28am Add comment
My experience is limited on this model but on other models, when the service station moves only in one direction, the service station drive motor has been at fault. In techo talk; it is a stepping motor not a simple DC motor.

The encoder strip allows the carriage to determine it's position.

No spare parts are available other than from scrap machines.
by Bert on Apr 21, 2005 at 12:36pm Add comment
Bert. Thank you so much for your time and patience.
All advice and information was GREATLY appreciated!

by Anonymous on Apr 21, 2005 at 12:51pm Add comment
I had the same problem, Cradle would not move. Upon removing the cover one could see the drive belt had come off the motor pulley.
It was bound up around the shaft and motor body. Typical HP offers no replacement belt.

Good Luck

Ike - Anonymous
Hmmm....well, if some of you can try this if you want. Try opening your lid and the cover in the back. Regardless if the power is on, Hold your right finger to a white springy-plastic-looking part all the way to the left. Push and hold it upwards, then get your other hand at the back of the printer and feel a gear behind the part that you're holding with your right finger, move the the gear at least 2x upwards. Then let go everything. and close all componets and try to print. Hope it works for you.

But a for me, i still have a big problem with mine. I looked in where the cradle itself parked where it's supposed to be, is full of dripped ink. How do I clean that stuff? It seem pretty thick now. Can I open the damn thing and start cleaning it with water and alcohol? Or.......what? What should I do? And Sometimes when i attempt to print in times, My cradle slams all the way to the left leaving a loud thump. Now when I print, I wait for it to reset it self after choosing, "ok", And when it says, Printing, I have to open the lid until it swings to the left and right, then I close then it'll print. But when it's making it's closing, the stuck message comes back again. AAAAGGGHHHH......Too much hassle and frustration! Does anybody have the time to help me? Thanks and god bless!

(wanna see how I look like? So, you'll know who're e-mailing to. Just an innocent guy looking for help) (www.thesanfernandoband.net) I'm the guy with the black hat. Not with the glasses)

Thanks again guys!
by unknown on May 2, 2005 at 8:16am Add comment
what white springy thing are you talking about?
dont see one on my printer... - Anonymous
Hi all,
I give up!! I had the same problem. First and last time
that I'll buy a !"[email protected]@£$ HP product. I'll buy an Epson or Canon!!
by Anonymous on May 6, 2005 at 9:48am Add comment
Before you buy an Epson or Canon I strongly suggest you spend some time reading the treads in this forum, and pay particular attention to threads that no one can answer...


There are a lot of Canon and Epson problems no one who hangs around here knows how to fix, or we can't get the necessary software for.

But there are not many unanswered HP questions... Hmmmm...

I'm still sticking with HP, they've had a few lemons, (3820, V40, 5110), but by and large their machines can be fixed.
by Stephen on Jul 18, 2005 at 4:44pm Add comment
Make sure gray cover holding 54-56-59- color cartridge is not popped up, mine was hung up for days tilo i saw it.
by Anonymous on Sep 11, 2005 at 5:17pm Add comment
my color cartridge lid was popped up too. used a screwdriver to fix - Anonymous
i friend of mine washed the circuit board and didnt let it dry completely before plugging it in. 3 transistors blew up! i need to know the value so we can replace it. Hnece the service manual. thanks

by unknown on Mar 14, 2006 at 10:28pm Add comment
Here is what I did to fix my problem. Pulled it apart. One of the ribbon cables had dropped into the path of the cartidge path. The encoder strip had also come off the mount. Once I had everything apart I cleaned the strip (had some ink smudges), reset the clutch (check HP site for directions), tucked the ribbon back up out of the way. With the ribbon down I could move the cartridge by hand but the motor would jam. I think I had a combination problem but all works nicely now.
by Anonymous on May 7, 2006 at 10:42pm Add comment
I have the same problem as the others have mentioned here. When I turn on the printer it reads that "my cartridge cradle is stuck. clear jam then press ok." I opened it up and took a look. I noticed that there is a spring hanging down from the service station. I believe that is the cause of my problem but I don't know where it is supposed to go. Anyone have any ideas?
by Anonymous on Apr 29, 2007 at 7:29pm Add comment
An earlier post said:
Make sure gray cover holding 54-56-59- color cartridge is not popped up, mine was hung up for days tilo i saw it.

the gray one was fine.... I finally resorted to taking the cover off only to find that the BLUE cover had popped up. The cradle had jammed at the far left location and the blue cartridge was totally hidden. Doesn't help that i forgot there are TWO cartridges in the bloody thing.

now if i can only get the ribbon cables back in place....
by unknown on May 9, 2007 at 2:57pm Add comment
D'oh, thank you so much for posting here, and everyone else too, especially the forum hosts, I really appreciate your advice and suggestions. I was trying everything reading down the list but nothing worked until D'oh suggested checking to see if the leftmost printer cap had popped up.

Yep, that was it! My cartridge was stuck on the left side and reaching in with my fingers and working the popped lid back down solved the problem!! =)


- Anonymous
To reinstall the ribbon cables you'll need to pop the carriage off the rail.

You'll need to take the belt off the idler and drive pulleys first.

The encoder strip will need to be rethreaded afterwards.

I suggest you check the DeskJet 5550 threads, the engine is about the same.
by twang on May 9, 2007 at 3:33pm Add comment
My service cradle was stuck - I did everything hp suggested and a few things suggested by folks like you - nothing worked. Then, using a flashlight, I noticed that the plastic cradle had actually snapped off on the back left. The cradle was lying at a slight angle, that's how you'll know. Doubt there's anything to do but buy another printer, sorry to say.
by unknown on May 19, 2007 at 5:20pm Add comment
How about emailing me and I'll see if I can find you a carriage?

Click on my name to contact me, or on the crossed tools beside it to see my profile, there is also an email link on the bottom right of the profile page.

I think the 7660 uses the same carriage as the DeskJet 5550, (56/58 & 57 cartridges).

For 5550 troubleshooting information read:

by Stephen on May 19, 2007 at 5:32pm Add comment
Stephen, I should have specified that I have a photosmart 7960. Any cradles for that? Thanks.
by lalonde2 on May 19, 2007 at 5:40pm Add comment
After doing some research I have found that the 7960 uses a carriage that holds three cartridges, the 7660 uses a two cartridge system.

My spare parts are mostly for DeskJet 5550 printers, the cartridge latches would be the same, but the carriage is definitely different.
by Stephen on May 19, 2007 at 5:53pm Add comment
Stephen or anyone

I broke the lid key latch on my 7960. It was the latch for cartridge 58 but will use any latch I can get. - Anonymous
Anon, not sure if your post was to me or not, but if it was then yes, I still have my old printer, but it is a 7690, not a 7760. Post over to years old? No, not mine. So maybe I'm confused. Check that. For sure I'm confused. That said, anyone want a mint condition 7960 - mint in the sense that it looks great - it just doesn't work? Cheers.

by lalonde2 on Jun 11, 2007 at 1:40pm Add comment
Although your post is 6 months old, I wonder if you still have the 7960. I was in a rush to clear a paper jam and broke the encoder strip and can't find one anywhere. Please let me know.


JJ - Anonymous
Hi JJ. Yes I still have the 7960. The encoder strip is in perfect shape. What would you like to do?

by Anonymous on Dec 24, 2007 at 11:15am Add comment
Hello. I have a HP Photosmart 7660 and the gray cartridge latch 56, 58, 59 is broken. Would anyone have a latch I could purchase and I would appreciate any instructions on removing the old latch and installing a new latch. Thanks.
by greenbheal on Dec 24, 2007 at 1:52pm Add comment
The part is unavailable other than from scrap printers. Create a new thread with a title like "Photosmart 7660 - Need Cartridge Latch" and perhaps someone will help.
by Bert on Dec 24, 2007 at 6:28pm Add comment
Thanks for the quick reply! Are you willing to sell just the encoder strip? If so, how much do you want for it? If not, how much for the printer?

Thanks again.

[email protected]

by Anonymous on Dec 25, 2007 at 11:23am Add comment
Jay, no charge for the encoder strip. I'm not sure I know how to remove it safely, however, so we might be talking about the entire printer. So if you want to cover the shipping costs of the printer, that's all I'll ask. Any advice on removing the encoder strip. though?


And Merry Christmas to you too!
by Anonymous on Dec 25, 2007 at 12:21pm Add comment
If you have a 2 year old kid handy, they're real good at reaching in and pulling out the encoder strip. Alternate method is to get the cartridges into the center and pull the power to the printer. Slide the cartridges to the left. The right side would probably be easier to remove than the left which has a spring on it. Reach in and grab the end of it and gently pull it towards you and it should come off. Then move the cartridges the other way and pull off the left side. Then pull the strip and it should come all the way out.
by moe on Dec 25, 2007 at 12:30pm Add comment
Wow! You're very generous Larry. I'd be glad to pay for shipping of the entire printer. Where are you located? I think if you just take to it to a "Mail Box" or UPS Store, they could pack it up and get it on its way and I'll gladly pay the charges.

Maybe we can talk tomorrow. Either send me your phone # in a personal email ([email protected])or request that I send you my number and we can discuss it.


by Anonymous on Dec 25, 2007 at 12:41pm Add comment
Thanks Moe! Appreciate the info. Have a great Christmas.

by Anonymous on Dec 25, 2007 at 4:01pm Add comment
Hey Guys,

Don't know if anyone is still following this thread, but I had a question same as JJ on 12-24. I got me a 7760 and was clearing out a paper jam and the encoder strip I am guessing is the thin filmy strip hooked on to metal clips on each side came out. I put it back in, but the printer still says the cradle is jammed and won't work. The cradle is moving freely, I don't get it. Been messing with it for hours, Is this printer trash now just like that? I barely used the thing, is there a simple remedy for this.
Any help would be greatly appreciated.

by unknown on Jan 2, 2008 at 8:38pm Add comment
The encoder strip must be attached on the left and right, and threaded though the optical sensor on the back of the carriage, nearly impossible with the case installed.

I have photos on reinstalling the encoder strip but nothing concerning case removal. If you want the photos email me by clicking on the crossed tools to the right of my name. Ask for the Photosmart 7660 encoder strip photos.
by Bert on Jan 2, 2008 at 8:47pm Add comment
Hey Anthony, I had a similar issue with mine (7960). Everything seemd fine but kept getting the cradle is jammed message. I reached in, poked around... and of course broke something... little plastic 2-cent piece of nothing... but there are no replacement parts unless thru this forum or ebay, etc. Maybe someone with better tech knowledge than me can help you. HP tech help is largely useless unless the issue is on their list; the personel don't seem to actually know the printer designs.

by unknown on Jan 2, 2008 at 8:52pm Add comment
It seems like your bar(shaft) inside the printer is dirty and needs a clean and some lubrication. Open the front cover and inside you will see the bar(shaft), your cartridges run up and down this bar. Take a cloth and dip it in a litle alcohol or spirits, then rap the cloth around the bar and clean it. It is not to easy to do becouse the space is so small. Then after giving the bar a good clean, you need to lubricate the bar. This can be done with sowing machine oil, or a similar kind of small machine oil(only a very litle bit)Put the oil directly on the bar, and run the oil up and down. Put a piece of paper on the bottem of the bar so you dont drip oil on the printer. If the dirty bar was creating your problem, then doing this will most certanly fix your problem.
by Anonymous on Jan 4, 2008 at 5:02am Add comment
i need to get a carriage belt for the hp photosmart 7660. please contact me if you have one.

larry canter
by unknown on Jan 12, 2008 at 1:11pm Add comment
I have a cartridge belt for the 7960. Probably won't work with the 7660. If you think it will work, let me know and I'll send it to you.

Larry - Anonymous
I have an HP Photosmart 7960 printer as well, and I'm having an "Ink carriage stuck" issue. The ink cartridges move along the shaft no problem and the ribbon cable is still attached, there is not a bit of foreign matter inside the printer that could be obstructing the mechanism from operating properly. Everything seems to be well cleaned and lubricated.

I think it's an alignment issue. I can move the ink carriage freely back and forth along the shaft, so it's definitely not dirty or non-lubricated. On the right hand side, there appears to be a tray (may be used to clean the print heads which is supposedly supposed to move forward and back.) That's where my problem is. It's not wanting to move forward on its own. I can pull this tray forward manually (takes a bit of effort to get it to come forward or go back by hand), then I turn the printer on, the tray will retract to its original position just fine, but it will not move forward on its own at all. The ink carriage also does not move on its own when the printer is turned on. It'll stay in the same place. I'm thinking it's due to this ink cartridge tray not being able to move forward or that something is knocked out of alignment with the gears. Could anyone give me some pointers to fix it on my own without having me send the printer to a repair shop?

Also, would anyone have a detailed schematic or image of what the carriage and tray mechanism is supposed to look like when everything is aligned and ready to print when the printer is first turned on? Any help on this matter will be much appreciated.
by SonicBlu on Apr 16, 2008 at 7:19pm Add comment
Okay I've been informed that it is an alignment issue and that the belt was broken from within the printer. He's not sure where the belt connects exactly, but that seems to be what I'll be needing to get this printer back up and running again. What type of belt would I need and how would I go about connecting it once I find one? - SonicBlu
Has anyone out there got a U/S 7660 available for parts. I am after a flat flexible cable for this printer and it is impossible to get it here in Oz. The cable is only 90mm long and is a jumper near the left hand end of the card reader. It has the following typed on it: AWM E41447-HCJ 80C 60V 20624 VW-1. If anyone can help it would be much appreciated.
by BrettP on Apr 16, 2008 at 9:57pm Add comment
I might be able to help. I've got a 7960 that is now only useful for parts. Maybe you can email me a photo of the latch you need so I'll have a clear picture (no pun intended) of what you need.
by Anonymous on Nov 5, 2008 at 11:56am Add comment
solve it blue lever (#57)lock was not close stucked on left.
pushed down works!!
by unknown on Jan 19, 2009 at 11:42am Add comment
Mine too did the same thing and mine was due to ink build up as a previous poster responded to. I doused mine with cleaning fluid and it works better than before, at least for now.
by mom2joshcanpark on Jan 27, 2009 at 12:47pm Add comment
just last week i was printing a few pages and the whole "cradle" got stuck on the left side of the printer. i'm not sure how to fix that. till it's fixed i can't do anything.
by Anonymous on Feb 24, 2009 at 3:44pm Add comment
Not sure if this will work, but clean the head in the printer. Mine got stuck on the right side and I cleaned that, it worked, then it did it again but got stuck on the left side, I just kept messing with it and cleaning it and it has worked perfect since.
by mom2joshcanpark on Feb 24, 2009 at 4:36pm Add comment
this is what i had done before i got the "cartridge station is stuck" error.

it was getting ready to print a simple wordpad file, it had turned on and a few seconds after, i quickly pressed the off button. (i have a bad habit of doing that instead of pressing cancel) so anyway, i thought nothing of it since i had always done that and i thought to myself, it's just as if the power had gone out, right?

the next morning, i tried to print something and i got the error.

the cradle with the ink cartridges moves just fine, both left and right and it doesn't jam or slow down but it still says it's stuck.

can anyone help?

if you also need pictures to better help with the situation i'd be glad to send 'em your way.

thanks in advanced,
ruan justin

p.s. my e-mail is [email protected]
by ant1ph0n on Jul 15, 2009 at 8:32pm Add comment
Anyone have any experience with a 7660 that has gone into slow motion? It will print, but it takes 45 minutes to print one page. Any ideas to help this? Thanks!
by unknown on Jul 17, 2009 at 10:31am Add comment
Does anyone out there have an old HP 7660 Photosmart printer with a good ink cartridge latch 57. If so let me know and how much you want for it and if you know how much of a problem it is to repalce it.
C. J.
by C. Shiffer on May 5, 2010 at 5:43pm Add comment
I think I have an extra carriage with that latch on it if you still need one. Just pay for shipping and you can have it since I was just going to to throw it out anyway. Email [email protected]
The photosmart isn't too bad to get into - the officejets are a real pita.
by Anonymous on May 24, 2010 at 3:24am Add comment
I had this issue on my 7960 and after taking the printer apart (tried the hard reset without results) found the encoder strip was rather loose. Tightened the encoder strip by unattaching it on the left side and bending the 'spring' holder just enough to hold the encoder strip taut. Hope this helps anyone with this screwy issue.
by magboy on Jul 9, 2010 at 9:24pm Add comment