asked Dec 6, 2004 at 7:42am
Epson Epson Stylus Photo 1290

Epson Stylus Photo 1290

I've tried replacing the colour ink cartridge, and I'm getting an error message "Installed Ink cartridge cannot be recognized". It isn't an epson cartridge, but they usually work? Both the power & ink lights are on SOLID. I read on another thread, that a previous paper jam could be causing this problem, but it didn't say what the solution was. I did have a paper jam & had to yank the paper out backwards this morning. I can't proceed with any printing at all, as the error message will not go away, despite my attempts at following instructions. Hope you can help.
Abi: You will have to clear up that ink cartridge error message, before you will even know if the paper will feed thru correctly. Once you clear that ink error message and if you then have an actual paper feeding problem, let us know and we'll help you further, if we can...Unfortunatly, there is no way to make your Epson Printer use that Non-Epson Ink Cartridge, if it cannot actually recognize it. Its even possible that some brands of Non-Epson Ink Cartridges may not always be recognized by the newer models of Epson Printers, because of the inexpensive and or incompatable Electrical Chips that are mounted on some brands of Generic or Third-Party ink cartridges. Sometimes you will even get Error Messages up on your Monitors screen, telling you that you are actually using a Non-Epson Ink Cartridge, or that your printer cannot recognize the cartridge that you installed. Sometimes the Ink Level Indicator, on your Status Monitor, will not show an actual ink level, but may indicate a cartridge error or problem instead...JUST TO LET YOU KNOW: Unfortunatly, not all Generic & Third-Party ink & ink cartridges are made the same and none of them actually contain the right formulation of ink, for the Epson Printers [formula is patented by Epson Company]. Some are probably close and seem to be better than others, but some simply can clog-up or even damage the Printhead Assemblies on Epson Printers. Epson Ink Jet Printers are one of the few printers on the market that seem to have so many problems with non-manufactors inks, especially the newer models made in the last couple of years. Its because the Epson Printers use a completely different printhead inking system than most other brands of printers. Most, if not all of the other manufactors, use thermal or bubble jetprint heads and because the other brands use a totally different system, they don't seem to have as many problems using refilled inks or non-manufactor's ink cartridges. Printer manufacters do not make available their ink formulation and in most cases, the formulation is patented. Any difference in the ink formulation can actually cause clogging in the small printhead nozzles or damage other critical components. One individual printhead nozzle is so tiny, that it will not accept a human hair, so you can see why they can get clogged so easily, or even why the nozzles can be so easily damaged...Good Luck! Denny Conway
by Denny Conway on Dec 6, 2004 at 2:57pm Add comment
Epson has a special table reserved in hell for this.
by unknown on Mar 22, 2008 at 4:55pm Add comment
by unknown on Apr 26, 2008 at 8:16am Add comment
Sweta,.. If you have a chip resetter, reset the ink carts. If you don't, buy some compatible in carts and try them. They are not expensive and they have worked great for me.

Go to inkforsale.net where you will find the ink carts for about $3.00 for the black and $4.00 for the color. Get some, they work fine on my 1280. By the way, I've never read or seen anything about a 1290 model. It must be for overseas markets.
by unknown on Apr 27, 2008 at 10:40pm Add comment
paper jammed need repair
by unknown on Apr 28, 2008 at 7:49am Add comment
my epson stylus photo 1290 is not currently showing the ink levels i use only genuine cartridges. i changed the computer recently and now have to use Vista but i downloaded the new drivers from the epson site and installed the printer works fine just cant see how much ink is left in the cartridges
by pdc on Aug 1, 2008 at 4:05am Add comment
The status monitor program is separate from the driver program. See whether you can access and download it from epson's website.
Hope this helps.
by unknown on Aug 1, 2008 at 3:16pm Add comment
by unknown on Aug 1, 2008 at 4:14pm Add comment


by Anonymous on Aug 1, 2008 at 8:40pm Add comment
If there is a red light on, open the cover press the red light, the carridge should come out. Remove and then put back in an ink cartridge, this should get rid of your error.
by Anonymous on Nov 14, 2008 at 12:49am Add comment
I have a epson stylus c62 printer and has been working great i have bought a continous ink flow system for this and this has also been working great untill not so long ago where my red and green light come on static and i have done everything took paper in and out also cartridges in and out turned off and left rebooted pc as i needed to clean the nozzels and this wouldnt work after a couple of attempts and thats when the problem started when i had to reboot the pc as the nozzels would not clean after 2 attempts no data was going to the printer all cables are also fine can you please help thanks
by unknown on Dec 19, 2008 at 5:04pm Add comment
to reset your printer, for when the green and red are flashing:
1-switch off printer itself
2-switch off at socket for 20 seconds
3-hold down both black buttons on front
switch on at mains
4-switch on printer itself
green and red flash together
5-now switch off at mains and leave for 3 seconds
6-while holding down both front buttons again, switch on at mains
both green and red flash together so release
7-quickly hold down the left botton, the one with the scroll
icon above it.
Hold this until it resets itself, - the print head will re
charge and it will be obvious.

restting by unpluggin rather than turning off at mains tends not to work. hope this helps.
good luck
by chloecat on Mar 16, 2009 at 4:33am Add comment
my maintenance red light is staying on and when i switch it on then off the printer head moves but then the red light only comes on and it feeds one sheet of paper through.
there are no paper or any elements blocking the feed.
iv treid resetting it but it doesnt work for this error
can anyone help me please x
by chloecat on Mar 16, 2009 at 4:36am Add comment

Epson RX 680

One ink cartridge is out of ink...
But when we try to replace the ink cartridge we get this error message:
Ink cartridges cannot recognized. Make sure ink cartridges are installed correctly.

When I put the old cartridge back in it says:


Press the OK button to replace the cartridges.

I do this and replace the cartridge with as new one and I get the previous error.

I am using only Epson ink cartridges.
by tmckinney on Sep 18, 2009 at 2:18pm Add comment
i have a problem with my epson stylus t10...it doesn't print but the turn on light(green light is on)...what should i do,..pls someone teach me how to fix it...tnx

by keraldsalva on Aug 2, 2010 at 1:33am Add comment
regarding my printer, the printer's magenta and cyan cartridges are empty. However, I only want to print a document using black ink. Is it necessary that I change the magenta and cyan cartridges before i can print again? your advice is much appreciated, thank you! >w<
by unknown on Aug 21, 2010 at 4:22am Add comment