asked Aug 3, 2004 at 2:08pm
Canon Canon Bubblejet (BJ) 5

Canon BJC-85

My printer has stopped printing even I replaced ink tank and cartridge. According to the Canon, the Waste Ink Tank is Full. I have tried to fix this problem with Canon and this "Printer Repair Forum" which sounds great!!
My printer just keep blinking POWER-GREEN & RESUME-ORANGE with 5 beeps. It won't let me change ink tank or cartride / CARTRIDGE button won't work at all.
My computer says, "PRINTER IS NOT RESPONDING"!!
This is not computer problem!! It is printer problem. I have contacted Canon regarding this. However, they just keep pushing buy a new one. If I really have to buy an another new printer, I WON'T buy Canon again. Cause, when they did QUICK EXCHANGE under warranty, they sent me a RECYCLED one. Printer troubleshooting is keep popping up since then. Now, it has completely stopped working. Can anybody help this printer?
I turn my printer on it beeps 3 times the print head centers with the green light flashing. After 5 minutes the print head parks on the right side with green light solid and error light on. Changed ink cartridge and print head same problem.
by unknown on Jul 13, 2009 at 8:18pm Add comment
I have the same problem as Big Joe Daniels.

Re: Canon BJC-85 by Big Joe Danials
I turn my printer on it beeps 3 times the print head centers with the green light flashing. After 5 minutes the print head parks on the right side with green light solid and error light on. Changed ink cartridge and print head same problem. - hplarkin
I'm having problems with my BJC-85.. itried new cartriges over and over again but the printer will not lay any ink on the paper!
the black cartrige doesn't work at all and i only get a teeny bit of red and nothing else! the printer won't print a solibblock either theres lots of lines where its 'missed' the page.
i've tried cleaning the green holder the cartriges go in, i've tried 'deep cleaning' the heads like it says on the maintenance panel, but nothing! it seems to toally not wanna work! it would really be nice to have this working again it would be ideal for printing invoices in the van! please get in touch! seems a waste for this to go to scrap :)

Kind regards!

by unknown on Sep 7, 2009 at 3:01pm Add comment
This is a waste ink error and can be reset using the following steps.

1: Unplug Power Cord
2: Hold POWER and RESUME buttons
3: Plug in Power Cord
4: Release buttons after the printers starts up
6: Press POWER
7: Release all buttons after the beeps
8: Press CARTRIDGE 16 times
9: Press RESUME
10: Unplug the Power cord

by unknown on Aug 3, 2004 at 11:52pm Add comment
my canon bjc-85 after I re-set it with the ten sugestion given, now the green light keeps flasing and no print.
what can I do.
please help.
thanks - Aich
Thanks a ton! This printer is a reliable workhorse. How disturbing it was to get those 5 beeps. How satisfying it was to follow the directions and reset the timer. Thank You.


Would that not be sweet. Print drawings in the motel room. - Anonymous
I followed the reset procedure and after the beeps (step 7) the printer starts up and gives the error beeps. I try hitting the Cartridge button 16 times and then Resume and nothing seems to happen. When I unplug and start over I am back to where I started with the five beeps again. Did I not follow something? - Anonymous
Thank you so much. The troubleshooting has stopped within 5 mins. Great skills!! Everything work well as a new one!!
by Kay on Aug 4, 2004 at 2:10am Add comment
I get 8 beeps on my printer - what can I do to get it working again? Please help!!
Big Al
by Big Al on Mar 9, 2006 at 10:08am Add comment
by mcprinter on Mar 10, 2006 at 4:37pm Add comment
I have a following error.
My BJC-85 doesn't beep by still getting "Printer not responding." message in canon software (like status monitor with two tabs: Printer status and job status).
I understand that this can be because printer is warming, but nothing happens after.
I've done resetting like suggested above but still the same.
by unknown on Nov 26, 2008 at 4:04am Add comment
l found this Forum by sheer good fortune,about one month ago my bjc 85 developed the same symptoms as Kays,after going back and forward to my vaio pc service department and Canon support team,l got nowhere fast,each department saying it was not their machine at fault, since then l have been typing documents and printing from my local library, great fun.

Yesterday l came across this forum and low and behold, l came across the same problem as with my BJC 85, l then tried the waste error solution and within ten minutes l was back printing again, this was after trying every thing possible including removing driver and adding driver once again.

So l would like to thank the person who provided this method,without l surely would have been looking for a new machine
by unknown on Jul 27, 2009 at 2:24am Add comment
Have a BJC-85 that beeps 8 times on startup. Tried reset procedure but still get flashing green and cartridge lights. See the post that says new printer head, where can I find one?
by unknown on Aug 17, 2009 at 6:29pm Add comment
Hello all,
I also have a BJC-85 that's beeping 8 times with the power and cartridge lights flashing. I'd like to try reinstalling the cartridge but it refuses to return to the centre when I press the cartridge button. Any ideas please?
by unknown on Aug 25, 2009 at 4:17pm Add comment
So happy to find this forum.

When I power up, printer beeps three times and orange error light blinks, power green light is solid. I can print out that nozzle TEST page -- seems to by-pass error. I've changed cartridges. I've un-plugged for 10 mins. and for 15 mins. -- error lights still blinks - any ideas? Andrew in Music City
by apd21 on Jan 27, 2010 at 8:27pm Add comment
Soaking the print head ink cartridge HOLDER overnight in water will often clean out the ink nozzles so it will lay ink on the paper again.

There is some site, perhaps cannon, that tells you what the various number of error beeps mean. If you find it please post it here.

Long live Cannon who makes ind cartridges you can dribble ink into for refill.. Die HP Die!!
by Anonymous on Jan 28, 2010 at 7:02pm Add comment
Error codes for BJC 85.
I use 3 of these printers and have had great success in trouble shooting using this page.

by unknown on Apr 27, 2010 at 11:04pm Add comment
I had exactly that problem. Followed the steps in detail. Fixed the problem. Wow. Great advice! Thank you!
by unknown on Mar 2, 2011 at 7:04pm Add comment
Hi There,

My BJC-85 mobile printer sat unused for several years. Last operation was in the 2006 era. Anyway, I now have a regained use for it and it will not print a test page or any other. I tried both from the PC System properties as well as the 4 beep method while holding the power button. I replace the print head and ink, ran several deep cleanings no avail. It powers up fine, engages a print cycle, draws the paper through as if it was printing, the print head moves back and forth as printing but only produces a blank sheet of paper. Power light and operation seem normal, sound normal but just print a blank sheet of paper. Thanks
by unknown on Aug 15, 2011 at 3:20pm Add comment
How old were the "replacement" ink tanks and print heads that you used ? Did you buy these recently or have these been in storage since 2006 ? How did you store them ? Were they stored in the same place as the printer ? Have you had any very hot summers ?

The solvent in these ink tanks can evaporate over time. In the past I have had trouble with "new" ink tanks that had obviously languished in a shop for a long time. They were in old style packaging.

I have an appartment in Spain. If I go away for any length of time, I put all my spare ink supplies in the refrigerator, so that they don't deteriorate in the hot summers. - KEN66K
Does anyone recognize the following error message?

The printer is offline.
Check that the printer cable is connected and the printer power is on

I have tried restarting the computer and the printer and it use to cure the problem, but now noting seems to work. When it does work it will work fine until one of the devices is shutdown and upon next start-up the problem returns.

Thanks to anyone who thinks they have the answer!!!!
by therealdeal on Aug 24, 2011 at 7:17pm Add comment
go to printer properties, you may see that use printer offline is checked. Uncheck it. Google search printer offline.
by unknown on Sep 10, 2011 at 9:09pm Add comment
I tried the hold resume unplug thing.
it worked on one of my bjc 85 but not the second one.
thanks for the tip. wonder why it didn't work on the second one.
any help is appreciated.
by DrDarryl on Sep 29, 2011 at 7:17pm Add comment
Thanks to this forum I've got my trusty, ANCIENT BJC-85 working again! thank you!! I had planned to replace it but the one I got for xmas is bigger and heavier--so not what I wanted for travel. That prompted me to get the old one working!

I am now wondering if the infrared IrDA (version 1.1) that the printer has built in provides any useable wireless capability these days. How / where could I find out? I work on a MacBook Pro, using Lion.

Thanks for any information.
by unknown on Jan 8, 2012 at 12:26pm Add comment
Hi, I just bought a canon bjc-85 printer used on e-bay. Everything looked good, got it set up on computer. Went to print something, nothing. The paper went thru, a little churning sound, came out blank. Tried to run a test nozzle print, nothing.Paper came out blank. What am I missing? Thanks, Ed
by erp52 on Jan 28, 2012 at 5:38pm Add comment
On the assumption that the ink tanks actually have ink in them, which I presume you have already checked, the next possible culprit is the print head. The nozzles can sometimes get blocked. If cleaning or flushing doesn't work, then try a different print head. These are getting hard to get.
by KEN66K on Feb 6, 2012 at 10:05am Add comment
I believe my waste ink tank is full. Anyone know how to drain/empty the tank without going to Canon to do so?

by phurls on Feb 20, 2012 at 8:53am Add comment
I believe my waste ink tank is full. Anyone know how to drain/empty the tank without going to Canon to do so?

by phurls on Feb 20, 2012 at 9:02am Add comment
My BJC-85 returns a "recharge NiCad battery" error (flashing error light + 4 beeps) when I try to print. I just bought mine on eBay, so I've yet to understand fully what's going on. I imagine the battery is internal and should auto-charge whilst plugged into the mains? Mine's been plugged in for about an hour, but when I unplug, it powers off. Can anyone help?
by unknown on Dec 20, 2012 at 8:06am Add comment
The BJC 85 does not have an internal battery. It uses an external battery pack that attaches to the back of the printer. If you get 4 beeps with a blinking error light and there is no battery attached, the main circuit board is defective.

HOWEVER, if you get 4 beeps and BOTH the error light and green power light are blinking, then it is a bad print head. The error means the print head is malfunctioning and needs to be replaced. - printers to go
Hey, we love our little Canon BJC-85 but today he's not doing his job. When turned on it just sits and the orange light at front just blinks and blinks, I've tried to unplug and replug, power on and off, hit the reset, removed the cartridge and reset it without any effect. It won't currently print out results but it's running reports from a laboratory machine and not through a PC.
THanks to anyone with advice!
by unknown on Sep 18, 2013 at 9:17am Add comment
The belt that moves the csrtridge needs replacementcan i purchase it n what would be the cost
by unknown on Jul 12, 2014 at 3:53am Add comment
Just powered up by old BJC85 (and a similar BJC80), last used in about 2005 and they both worked. One of the BC10 black cartridges worked immediately, and the others BC10 and 3 x BC11s all working fine after alternate "deep clean" and prolonged soak in hot water. Refilled the ink tanks with new ink and they both run like new.

More difficult was finding a Driver for MAC OS-X 10.8. No luck with Canon or Apple, but the wonderful folks at Gutenprint:


came up trumps for both printers. These Mac drivers are basic "printer only" and do not handle advanced printing features, scanning or maintenance which still has to be done through Windows XP.

Brilliant printers and still not surpassed by anything on the market today!
by rleedha on Mar 28, 2015 at 3:05am Add comment
Printer is working fine mechanically, no error messages, goes through the printing process normally, however, only get white pages at the end of print job. Simply put, nothing is printing. I changed the toner thinking it has run out, however, same results. Followed the steps above under waste ink error, to no avail.

by unknown on Feb 22, 2009 at 8:43am Add comment
I have exactly the same problem. Tried all the solutions listed on this site, but still all I get is blank pages. Has anyone come up with any further solution to this? - unknown