unknown

asked May 1, 2004 at 7:08pm
Epson Epson Stylus C84

Epson C84 print issue

I have had the Epson C84 printer for about 6 months now. It worked very well up until now. Fades and Gaps are appaearing on every print, color or monochrome. The pattern of gaps is consistent. I have replaced all the ink cartridges, (used original Epson manufactured cartridges). Still no luck!
I have also tried the Nozzle and Head Cleaning through the Epson software.
Anyone else had this problem? Any suggestions?
epsonc84user: The good news is that your printer is covered by a one year warranty, so check your origional invoice or sales receipt for the purchase date. If its been under a year since you've purchased it, then simply call the "Epson Customer Relations Department" [if you are in the USA], at 1-562-276-1311 and file a Warranty Claim. Epson will normally send you a replacement printer, in exchange for your defective printer...Good Luck! Denny Conway
by Denny Conway on May 3, 2004 at 2:11pm Add comment
The Epson C84 like all Epson printers I have worked on, cleans the heads by moving them to a "cleaning Station" at the far right of the printer. It cleans the heads by pressing a suction piece up under the print head and running a "tube squeezing pump" to apply vacuum to the bottom of the head. The problem that happens with this system is that the tube running from the suction head, through the tube sqeezing pump, and to the waste tank in the back of the printer gets clogged with dried, goey ink and the pump won't pump any more. To fix it, pull the right end cover off the printer. There are no screws, it just has a couple of plastic teeth on the bottom that can be squeezed together and the the cover can be pryed off. You can then see the waste tube running from the pump to the waste tank in back. pull the tube out of the waste tank in the back, it just lays in a channel holding it in the tank. Don't pull it out of the pump assembly. Take a syringe, using rubbing alchohol, clean the tube out by forcing alchohol through the end of the tube with the syringe, until it will come out at the suction cup's foam pad under the head. This takes a while forcing alcohol back and forth with the end of the tube attached to the syringe until all the gunk in the tube is dissolved by the alchohol and cleaned out. When the tube is cleaned out, the cleaning cycle of the printer will work again. Lay the tube back in the channel to the waste tank. It can be pressed back down into the channel with a small screwdriver. I have to do this to my Epson C84 every 6 months. I also service Commercial Epson printers and the cleaning station is one of the more common failures. Hope this helps someone save their printer for another six months of use.
by unknown on Feb 3, 2007 at 12:55pm Add comment
LJS talked about -
a "tube squeezing pump"

Technical description is Peristaltic Pump.

You'll see them on dialysis machines and the like. They work by squeezing small sections of tubing containing the fluid (blood/ink) using cyclic rollers, so the blood/ink is propelled forward. Our guts work the same way, except instead of rollers we use muscles.

JaX
- WaveGuide
I have an Epson c66 and an Epson c86--I don't seem to be able to pry the right side of the printer off so that I can fix the tube. Any secrets? I assumed that they would open up the way you described the c84 did--they DO have the plastic teeth at the bottom that I squeezed together, but I still couldn't pry off the side.
thanks! - jocelie
Hello jocelie,

The end pieces are held with two external and two internal fasteners. The internal ones are of a different design from the external 'arrow head' latch type.

If you open/remove the lid and move the carriage to the left side, you will be able to get to the two internal latches which are holding the end piece in place. These latches look like thin flat lugs situated around the upper inner corners of the end piece. You have to pry these lugs inwards to release the tangs/hooks. All this has to be done while you ease the two external catches out of their retainers. It's easy if you have three pairs of hands and a thin blade!

The left hand end is similar, move the carriage to the right side and the latches are accessible by hand. Before the left end piece will come off, you must release the small moulding that fits round the cable connector. The moulding is released via the slot underneath the printer. Use a stiff flat blade like a steel ruler or a spatula. Push this upwards and release the moulding latch. With that off, the left end piece can be eased off using your third pair of hands and the thin blade to lift the casing from the latches.

Hope this helps.

JaX
by WaveGuide on Feb 4, 2007 at 2:04pm Add comment
ok, this is going to make legitimate printer repair guys CRINGE but, i had a client to fed ex to, and epson wasn't sending the new printer til next week soooooo...

I had the same clogged cleaning station issue as above and honestly, i've never had a problem, 2 years running. until NOW. so, i did the diagnostic and then went to work to fix the clog. we didn't have any rubbing alcohol in the house so i improvised.

when i got to the waste tube, i saw a TON of gunky ink. the tube is long and thin and clear, about 5 inches long and pretty flexible. so, i thought, if i can't FLUSH/DISSOLVE it out, maybe i can PLUNGE it forward and then back up, and out the open end. i thought...this tube is long and thin. now just WHAT would fit in here and be sturdy enough to push the dried ink thru? i turned to my pantry - SPAGHETTI. !!!!!!!

i know, i know...but i'm just an illustrator...so my mind...it works differently.

:-S it WORKED tho! (or so i thought!) it really pushed and cleaned out the tube completely. it took maybe 25 strands of spaghetti, but it really did the job. the trick is to TAKE YOUR TIME OR...the spaghetti breaks. *-O

but, sadly, my story has a sad ending. when all was done, and i thought i did a good thing, i set my printer back up again and it STILL didn't print out, and worse, The BLACK seemed to be out - even though i had just replaced it. :((

my nosy "cliff claven" neighbor asked if the trick is to DISSOLVE THE INK back down into the "box" end of the waste tube, where it connects and not to force it back out the other end. but if you don't have RUBBING ALCOHOL but you do have a syringe, can nail polish remover be used in the same manner? we have a major storm - so, can't run out to get rubbing alcohol. :( fed ex is due here in an hour and storms NEVER stop them.

the upside is that i have a new epson coming - a pro model that will make this lil' 84 look like a peanut but if there's a will...is there also a WAY to get it to print, just one more time and save the day? :)



by unknown on Mar 16, 2007 at 12:39pm Add comment
If you followed the forum, you would know that rubbing alcohol will work because it is 30\% water. Since the ink is water soluble, the 70\% alcohol has zero effect on it. I don't know why everyone thinks that alcohol dissolves ink, but it doesn't.
by moe on Mar 16, 2007 at 12:46pm Add comment
Moe, Epson say their Durabrite ink dries to a water resistant film. If Durabrite really dries out solid, in the drain tube or the head for that matter, water alone seems unlikely to dissolve it. Is that so?
Cheers, JaX - WaveGuide
Warm detergent water from a syringe should clear the tube.
Just remember that the pump needs to be reversed from its suction direction to open it for this to be sent through.
by unknown on Mar 16, 2007 at 3:53pm Add comment
aha! it WORKED! dishwashing liquid and some syringe work and it's printing wonderfully again! :) there is much to be said for fixing it yourself. thanks SO much! :))

by unknown on Mar 20, 2007 at 8:20am Add comment
maybe it's the DETERGENT that cuts it as when i was plunging it thru, and then back out again, it almost seemed to "melt" in the tube when the soapy water hit it. but, now i have new problem - i just replaced the ink cartridges and my INK OUT light just came on.

oh no! did i do something wrong? it actually just printed fine...for a good hour or so. and now....it seems sad again.

by unknown on Mar 20, 2007 at 9:55am Add comment