asked Mar 29, 2004 at 1:26pm
Hp HP CopyJet Color

HP 1220c flashing ink light color ink cartridge

I have a HP 1220c which has given up on me. No matter what I do, the ink problem light flashes and, when I open the lid, the carriage moves to the 'colour cartridge unhappy' position. I can print nothing.

I've tried new colour ink cartridges (and black!) but to no avail. I've looked around the cartridge contacts and everything looks clean and functional.

I have seen this problem on this website before but not recently. My guess is that I'll have to replace the carriage PCA.

Have any of you experts got any ideas, please?
A carriage PCA failure is uncommon. Clean the carriage and cartridge electrical contacts with a cotton swab moistened with water and verify that that the correct cartridges are installed (45 and 78). If these things fail to solve the problem, test the cartridges in a known to be working printer. Many of the Deskjet 900 series use the same cartridge set.
by Bert on Mar 29, 2004 at 4:03pm Add comment
Thanks for that Bert but no joy. I've cleaned both sets of contacts with IPA and checked the cartridges. The problem is the same with two different new colour cartridges.
by unknown on Mar 31, 2004 at 4:42am Add comment
I've got the same problem! :-( I've tried 3 different color cartridges, all of which work fine in the other HP printers I own. Anyone got a clue wassup?

by unknown on May 6, 2004 at 6:39pm Add comment
Specifically which lights are on and are any flashing. Do they change when u open the top cover and so on.
by Printx on May 6, 2004 at 6:59pm Add comment
Yes, sorry... it's the same "ink problem" light discussed earlier in this thread, and when I open the cover, the print heads slide over to the color "unhappy" icon.

I'm experiencing the same problem and same symptoms (and have tried the same "fixes") as Jim, to no avail...

Hoping someone can help! ;-)
by unknown on May 6, 2004 at 11:12pm Add comment
Follow my 3/29/2004 16:03:04 post on this thread. Thats the only way that you are going to isolate the problem. Its not beyond possibility that you have a defective printer but bad cartridges or contaminated contacts is common.
by Bert on May 18, 2004 at 12:08pm Add comment
Well, I finally fixed my problem with my 1220c but it's not going to be a fix you'll like. I replaced the carriage (bit that moves along the bar)(managed to get hold of another duff printer off ebay) - problem solved, printer working fine again - with the cartridges which I couldn't get to work originally. So it was a hardware fault with the carriage PCA after all.

Ref the service manual, have a search through the archived threads ref 1220c - somebody has put the 1220c service manual on an ftp site. That's where I got it from.

Good luck. Jim.
by unknown on Jun 2, 2004 at 3:14pm Add comment
a lot of these problems ca be solved by following the procedure here:

but here's one important thing to check before you replace the carriage or PCA:

the PCA is held to the carriage /cradle by usually one or more screws. sometimes these loosen over time, so while the contacts on the PCA and the ink cartridge look ok, they're not actually making good contact. try removing the pca from the cradle, and reattaching it, making sure you torque the screws down firmly (but don't crack the board). sometimes a small washer or shim helps to get the board closer to the carts.

many times if you look along the top of the cradle/PCA assembly, you will notice that the gap between the board and the cradle is not uniform. this is usually a dead giveaway, and snugging up the screws will usually fix it.

also if you closely examine the cartridges, you may notice that the indentations or scratches on the contacts aren't uniform which may also point to a skewed PCA.

by unknown on Jun 2, 2004 at 3:30pm Add comment
I may want to try this to see if I can get my cyan to work again (tried multiple cartridges, cleaned contacts, etc) but according to the HP manual, accessing the carriage requires recalibraton with a special tool to reset the paper/ink gap. Do I dare remove the carriage and risk not having anything work without recalibration? - stevedecho
Thanks, edufixitguy. I'll try it as soon as I get back from vacation...
by unknown on Jun 3, 2004 at 7:05am Add comment
Hi i had the same symptoms but the cause was that 2 sprung brass pins that make contact with the cartridge had got stuck in there hole so that they wouldnt slide out and touch the cartridge. Does anyone have a pcb for the carridge on this printer?
by mark on Aug 15, 2004 at 2:28am Add comment
It's possible to have multiple defective cartridges. I would test them in a another printer. Any of the Deskjet 900 series with the exception of the 920 and 940 use the same cartridge set.

There are no adjustments necessary if the same carriage is reinstalled and critical screws are not removed. To remove the carriage: Remove the encoder strip, then remove the drive belt form the tensioner, then remove the two screws going through the carriage rod, and push the carriage rod to right to remove it. If the carriage board is defective, there are no spares available from HP, P/N C2693-67036.
by Bert on Jan 19, 2005 at 1:10pm Add comment
Here's the embarrasing mistake I made...

Having the same frustration with flashing light with new cartridge...


Take off the clear-ish blue tape, moron...

Happy printing!

by unknown on Jan 23, 2006 at 1:41am Add comment
The 1220C I have here exhibited poor quality printing. A point well made since it was abused by the users to the point that there was ink just about anywhere in the printer.

Took the whole thing apart (chinese puzzles are fun), and cleaned up the mechanical parts (I purposely left the circuitboard alone).

Reassembled the printer, and it's now in a state where the ink led is flashing at me. When opening the printer it moves to the 'unhappy black cartridge'.

Verified it's age (it should work up to august 2007 according to the box)and cleaned up the contact points in the carriage and on the connector to the circuitboard with contactcleaner.

In reaction to the post made by edufixitguy, I assume PCA stands for Printed Circuit Assembly (i.e. the circuitboard itself) so I unscrewed the circuitboard, cleaned up all assembly points with cleaner and re-set the board making sure that it should have proper grounding.

Tried the solutions on http://h20000.www2.hp.com but unfortunatly this didn't assist matters any.

Unfortunatly I don't have a test printer (either 1200 or 900) readily available, so trying the cartridge in that one isn't really an option. Also obtaining a replacement cartridge for testing is a bit of a hassle. The thing has been replaced already with a 1280, but if at all possible I'd like to reuse this one. Afterall, it only exhibited bad print quality errors. In essence it's still a good printer.

I'm now considering options (including obtaining a test cartridge which is gonna be a bit of a hassle I suppose, but any thoughts on this are welcome.
by unknown on Jun 2, 2006 at 7:06am Add comment
Tested the printer with a different black ink cartridge. Unfortunatly this does not make any difference for the error. The printer still reports an error on the black ink cartridge. Using this ink cartridge in a different printer results in a good print, so the cartridge itself should be good.

By now I also had the entire ink-carriadge loose to verify any malfunction of the contact points on the rear of the thing. There were none, but while it was loose it was cleaned as best as possible. It's been reseated and yet still the 'unhappy black ink' notification is given.

I'm sorely tempted to call HP, but their fixed price and no telephone assistance approach they're currently adopting makes me shirk away from that option for now. Moreso since this printer is currently surplus. If it doesn't work, nobody's waiting for it, but it'd be nice if it did work.

So if anyone has any thoughts on what may be steps I could take further in getting this printer active again, it'd be appreciated.
by unknown on Jun 19, 2006 at 4:18am Add comment
Heck if I know what I did, but it seems to atleast want to print again. Just switched on the printer and somehow it decided that yes... it will not give me an ink error, but instead play nice-nice and actually await a printjob. Tho it does present me with a different issue now. (Nothing is ever that easy)

I've attached the printer both through parallel cable and USB, and in both cases it does the same.

Trying to print a testpage from the 1220C Toolbox software results in the printer printing a page that has a picture of some-sort that's mostly green-ish and red coloration. The picture is the only thing on the page. The printing of the test page works really slowly, but with a bit of patience (about 10 to 15 minutes of patience) it does come out, although it does look like it's missing quite a bit of coloring.

The slow testpage printing already hints that something is wrong somewhere. But since it does print, it seems it's primary systems all are connected properly and are all reporting a 'ready' status.

So a Windows Test Page then... Now that one drops me straight to an ink-cartridge problem. Opening the printercover however lets the carriage slide over to the smiley-face at the utmost right, indicating that there's nothing wrong with the toner cartridges.

At this point the printer doesn't do anything anymore, and I'm forced to completely shut it down. It formfeeds the loaded paper, and switches off. Upon restarting the same error crops up again.

Since it seems this has now dropped out of the realm of the mechanical, and is entering the realm of the communication, I'm guessing the main-board has some sort of issue. Anyone any idea what may be causing this erratic behaviour?
by unknown on Jun 22, 2006 at 6:14am Add comment
MMM, I have the same problem as JvD here. I have tried all the troubleshooting advice available here and at HP site. I shall be taking it apart very soon but in the meantime all suggestions gratefully received.

Basically the coulours were running out so needless to say I changed the 78 cartridge (twice).

Now I get the flashing lights telling me there is a cartridge error whenever I try to send anything from my pc (laptop, via USB).

When I reset the printer and open the cover the carriage slides to the Happy icon and, using the buttons on the printer itself I can get one of the test pages. However as soon as a test page is sent from the PC we go back to the error state.

This has ONLY happened since changing the cartridges which I am fairly sure are ok since i've changed them more than once, I will say though that the prior cartridge was printing without one or two colours for a month or so before I changed it, if that makes any difference at all.

?????????????????????????? - Anonymous
My printer was working fine then suddenly stopped printing in black. No lights flash to warn of low ink. I replaced the black ink cartridge and the printer is still printing in pink. I've cleaned the contacts shook the ink cartridge. When I run a test print it prints some in black ink then sort of fades away. ANyone have any idea what this is?
by ljp on Jul 20, 2007 at 11:39am Add comment
Checkout the link in the post before yours.

An easy way to verify that ink can flow freely from cartridges is to blot their print nozzles on a damp paper towel. You should see a pronounced band of ink on the towel after a second or two. Your color cartridge should show three colors, yellow, magenta, and cyan.

I suspect that you are using a recycled black cartridge(s) that is not not working properly.
by Bert on Jul 20, 2007 at 4:46pm Add comment
An update on my particular situation. This all coincided with a change of cartridge, a refill initially then a proper HP one. It would now appear I have an issue with the old laptop,which I think is getting tired. New mac and desktop print fine, old laptop sends printer bonkers.
by unknown on Jul 22, 2007 at 5:48pm Add comment
I've just had the 1220c/PS flashing light problem for the past few hours after replacing the colour cartridge. None of the above was working. Out of frustration i gave the printer a swift smack and pulled the cartridges along the bar then went online to look at buying a new printer. Just as I did this the lights stopped flashing and we're now printing again. Magic.
by unknown on Apr 9, 2009 at 8:23am Add comment
When I switch on printer on light blinks for a second and nothing else,have checked rear cover with out any susccess wil appreciate any advice as am not technical just home user
by RAYRAYRAY on Jul 1, 2009 at 2:05am Add comment
The upper left locking pin (as viewed from the rear) on the rear cleanout door pushes a lever that tells the printer that the door is locked. Make sure that the pin is extending fully when the door is locked.
by Bert on Jul 1, 2009 at 1:35pm Add comment
When I press the power button, the green light blinks for a second but nothing else happens. I checked rear cover to ensure it's in the lock position.
by unknown on Jul 11, 2009 at 2:19pm Add comment
See my last post. Poke something into the locking pin hole to simulate the presence of the cleanout door and then try turning on the printer.

I remember an instance where the lever that the pin pushes was not working or the main electronics board had failed. The lever movement is detected by an optical sensor on the main electronics board.
by Bert on Jul 11, 2009 at 3:47pm Add comment
Thanks! Cleaning the contact area with a wet cotton bud worked for me!
by unknown on Apr 7, 2011 at 3:11am Add comment