fixyourownprinter.com
  Home    Reference    Forums  
  Printer Repair | Laser | InkJet | Chat | SearchSign In | Sign Up  

Epson R1800 ink dump, now blank

Post to this thread   Post a new message thread

Epson R1800 ink dump, now blank by mamoose83 (4/20/10 5:18 PM) reply + / -
A couple of weeks ago, I used my Epson R1800 to print several 12x12 pages, came out fine. Next day, went to print a few more, white cardstock came out soaked in black ink. did some brief cleanup & clean utility, put in/out cartridges, tried another print, same thing - ink literally running off paper. No error messages were received by the computer. Did clean up again, tried from different program & on just plain 8.5x11 paper, didn't dump the ink (although wasn't much left!), but didn't actually print either, just some roller marks in a few rows. Left it alone for these past 2 weeks - clean & let dry. Got some new cartridges & put in, did a nozzle check & cleaning thru the maintenance screen, printed blank page. Tried to do the simple "print test page", printer goes thru all the actions, but page is BLANK! Went to download the "reset counter" utility from Epson, thinking that might help get me going again, but it said that I "did not need the utility to reset my counter at this time as no parts are near end in my printer". Well, then why aren't they printing on the paper? It doesn't appear that it's "dumping" the ink like before, but the pads are a little damp again in some spots - but the paper is stark white still. Any ideas? Nearest Epson repair center is like 50 miles away & $85 to walk it in their door. HELP!


Post to this thread:

User:
Email:
Notify me if someone responds

Icon:            
Subject:
Message:



© 2012 fixyourownprinter.com, All posts belong to their respective posters