asked Nov 30, 2006 at 1:23pm
Canon Canon C 130

Canon Error 5800 Waste ink Full Pixma MP 130

Out of warranty by 8 days,Canon was not very sympathetic. Does anybody have the Codes to re-set waste inktank full for the Canon Pixma MP 130
Hi--I am having this same problem!! I Love this great little Printer. It's perfect for my personal use! But, I have NO IDEA how to handle this --waste ink absorber---problem.

If you find a solution, will you please let me know--if that would be convenient?


by unknown on Dec 12, 2006 at 4:56pm Add comment
Eureeka I got there :-

1) Enter SERVICE MODE By pressing Menu-Scan-Copy-Scan
2) Enter NVRAM by presing <--- or ---> then OK

Let the whole word know I would like to stop this rip off
by unknown on Dec 20, 2006 at 12:47pm Add comment
FANTASTIC! I thought I was in trouble, Canon didn't want to know and I found your solution - thank you so very much - thank you!! - Anonymous
Hello Mike,
athough your helpful tip is almost 4 years old - it still helps - thank's a lot, my printer is fine again - all the best!
Kurt - Anonymous
Many thanks.

This fixed my problem in minutes.

Tanikiu Bada herea - Anonymous
Excellent, many thanks for advice, printer sorted+++ - Anonymous
I have multipass F60 with same problem does anyone no reset code & instructions - Anonymous
Thank you, thank you, thank you!!!!!!!!!!!! I had tried everything to get rid of the message; however, now that being said will my printer soon stop working and do I have to do something to empty the waste ink tank absorber? Is your printer still working? It seems like whenever I buy a printer I love within about 3-5 years it breaks down and I am sick of spending more money on these things. I do maintenance on it every time I change an ink tank. I clean the rollers and everything. If you have any further information pertaining to this issue I would appreciate it.
Patty - pattycake
Thank you so much for the advice! It worked perfectly! - Anonymous
Mike Thank you!

This is the best little printer I ever owned and when I got the message about the asorber pad I was very upset. I used you solution and it worked thank you !

Colin - colina8369@hotmail
you are a man of the highest regard...thank-you so much.... - Anonymous
Thank you sooooooooooo much. I am very greatfull. - Anonymous
I bought a new printer @ kept the old for nearly a year finnally desided to check on line @ found answwer Thankyou foryour help @ Internet - Anonymous
Thank you so much !!!
You save me money what I almost spend on a new printer...AGAIN !

Thanks a lot ! - unknown
‚ ‚肪‚Æ‚¤�A‚±‚Ì‚½‚Ñ‚Í�A‚ ‚È‚½‚Ì‚¨‚©‚°‚Å�A‚Æ‚Ä‚à‚½‚·‚©‚è‚Ü‚µ‚½�A‚©‚ñ‚µ ‚Ⴕ‚Ä‚¢‚Ü‚·�B

- unknown
perfect fix - cannot believe that Canon would not divulge this in the owner manual - works great - Anonymous
Many, many thanks, your solution to this problem worked for me too.

Canon simply said to me "chuck it away and buy a new one! "

How disgusting when in this world of "Free Markets" we just chuck everything away for the least minor problems.

So much for saving our planet from wasteful consumption of our natural resources. What a joke the Western politicians are.

- Anonymous
Thank you very ,very much.

Wesley. - Anonymous
It is great! just took a few seconds to fix it !! Thanks a lot!! - Anonymous
Hello Mike,

as you seem to be "god" on this subject....

I tried your instructions, but menu-button gives me message "invalid key/set".
what is next??
hope to hear from you

Sjoerd - unknown
Have tried. But, I am unable to enter the service mode by pressing Menu-Scan-Copy-Scan - have tried pressing one fater the other as well as all at the same time.
What am I doing wrong? - unknown
Thankyou Mike... worked like a dream... many thanks Brian - unknown
Thank you, thank you, thank you. Took TEN SECONDS to fix this.

Thank you!!!!!!!!
by unknown on Jan 4, 2007 at 6:39pm Add comment
Thank you this solve my problem. However, if the waste absorber is fill will this cause damage, if you don't replace the pads.
by fayebuff on Oct 2, 2007 at 6:55am Add comment
I have canon error 5000 with my Pixma MP 130, help me please
I have set ABS-M Leve to 0, but it's not work...
by abdu on Aug 22, 2007 at 1:31am Add comment
1 press menu
2 PRESS scan copy scan to enter service mode
3 use > to go to NVRAM ACCESS
4 set ABS-M LEVEL TO 0
6 Set press STOP to EXIT

DONE !!!! - Anonymous
Mike Dias thank you for the information on how to fix the 5800 code error.It was very helpful for me,in ten seconds the printer was working again.Thank a lot. Alomar
by alomar on Aug 23, 2007 at 5:09pm Add comment
have canon error 5000 with my Pixma MP 450,
by Anonymous on Sep 25, 2007 at 10:37pm Add comment
have canon error 5800 with my Pixma MP 4500, help me please
by Anonymous on Sep 25, 2007 at 10:39pm Add comment
The printing quality is very good, now it tells me that the waste ink is full. I called Canon and they said that I have to buy another printer. They have no idea how to reset it, the ignorant game.
Some help needed to reset it, I would appreciate it very much. - JPG
Canon Error 5800 Waste ink Full Pixma MP 510. how to service mode?
by unknown on Sep 26, 2007 at 10:08pm Add comment
have canon ip4300 ink tank error, help me please
by Anonymous on Oct 8, 2007 at 3:00pm Add comment
have canon ip4300 ink tank error, help me please
by Anonymous on Oct 8, 2007 at 3:03pm Add comment
Great, Thank You. Worked like a charm
by Anonymous on Oct 9, 2007 at 3:18am Add comment
God bless you Mike!!!!!
by Anonymous on Oct 11, 2007 at 7:28pm Add comment
Hi, you can try this. It worked for me. If it does, please pass this on to as many people as you can help:

Turn on the printer press menu
press scan, copy, scan to enter service mode
use> to get to nvram
set ABS-M level to 0
Set ABS-P level to 0
Press stop to exit..........Done
by Anonymous on Oct 22, 2007 at 2:12pm Add comment
When I turn on the printer, the Error 5800 light comes on. It will not allow me to go to the Menu or anything else. How do I get around the error 5800 and go to the menu? - Anonymous
Your code saved me from buying a new printer scanner. I also used a long surgical clamp with q tips (8) to reach inside the printer to absorb the waste ink from the tanks. Good to go for now. Thanks CW - Anonymous
I have the error 5800 but when I try the solution above as soon as I press the Menu button up comes the message Invalid Key/Set, and it won't go past that.
by unknown on Oct 27, 2007 at 10:25am Add comment
Forget the Menu button and start at the Scan button. There isn't a Stop button so just press the On/Off button, wait a few seconds and then press On/Off to restart. - Anonymous
Where is this ink absorber and what am I supposed to do with it
by Pat Hillier on Oct 28, 2007 at 8:15am Add comment
by CELESTINO on Oct 28, 2007 at 10:24am Add comment
la mia stampante mi da l"errore 5800 cosa devo fare grazie - Anonymous
error 5800.when I press the menu the message showing In valid key/set.when I press other buttons the same message showing.
Please help me.
by unknown on Nov 5, 2007 at 6:04am Add comment
I have a similar error, however using the fix suggested above does not work - it does not take me to the menu!

Any suggestions would be greatly appreciated.

by unknown on Nov 21, 2007 at 5:56am Add comment
The MP510 seems not to recognising cartridges...firstly the cyan in my new printer couldn't be recognised unless loosened & then replaced. This happened several times until it refused to be recognised at all. So we bought a new cyan cartridge, which has worked fine for 2 weeks...BUT now the yellow can't be recognised. What's happening?
If one cartridge can't be recognised the whole machine wont work, which is very inconvenient when we mainly need only black for documents!

HELP ME Mr.Anonymous!
by unknown on Dec 7, 2007 at 9:52pm Add comment
by Anonymous on Dec 23, 2007 at 10:17am Add comment
my ink absorber is full but cant get into servce mode as says there is an invalid key! help
by Anonymous on Jan 16, 2008 at 10:22am Add comment
My MP 130 says "waste ink absorber" full! How do I correct?
by Anonymous on Jan 23, 2008 at 5:08pm Add comment
by unknown on Mar 6, 2008 at 7:26am Add comment
Have done everything but my Canon pixma 130 keeps saying: check printer (5200). What is 5200 and how do I fix it? Please help.
by Anonymous on Mar 7, 2008 at 12:54am Add comment
thanks a lot
by Anonymous on Apr 13, 2008 at 3:44am Add comment
I was in the middle of doing some photos via my Canon MP 130 when I got that dreaded message,"waste-tank,full,needing service"--etc,etc!
I had visions of more expense at this time of year because I just love this easy-to-use yet very adequate printer--BUT--on discovering this marvellous advice,within a couple of minutes,I'm up and running again!
I don't know if it'll last or if it just means a patched-up job but whatever,I'm able to continue,hopefully,in order to finish my Christmas bits!!

THANK YOU SO VERY MUCH once again,truly!

Karen x
by wednesday16 on Dec 9, 2008 at 11:06am Add comment
thank you very much
by Anonymous on Dec 16, 2008 at 3:46am Add comment
Well, a big thank you!
Your instructions worked.
You have helped save me money and that is one less machine in a landfill site too.
Canon told me I would have to send it to my nearest Canon repair depot- 400 miles away.
PC World told me it could not be repaired, that I would have to buy a new printer.
Best wishes and thanks again.
by Anonymous on Dec 16, 2008 at 10:26am Add comment
Thanks for the help. It fixed the "waste in absorber full" message. My question, however, is what is the purpose of this message and does something need to be done? It feels like resetting your cars warning signal just to make it go away, but the problem was never addressed. Does anyone have a clue?
by unknown on Mar 12, 2009 at 1:10pm Add comment
Thankyou for easy solution - your bloods worth bottling!!! Jd
by Anonymous on Mar 13, 2009 at 9:03pm Add comment
The re-set works fine but the resevoir pads may still need cleaning.
1. Prise off the right front scallop shaped plastic fascia by releasing the long tongue that dissappears into the paper ejection mouth. There's a small protruding tag you can hook a long screwdriver or knitting needle point into to tease it way.)
2. This reveals two front screws that match two rear screws which allow the whole right hand side to come away.
3. The Print Head is at rest over the resevoir absorbing pads. Push it back along the track out of the way.
4. Get some thin tweezers to lift out from the lipped rubber tray the two lozenge-like pads that soak up drips from cartridges.
5. Soak or clean them in meths, alchohol ( I use the pink stuff that comes with re-fillable cartridge ink) or ink solvent until they are clean and resemnble castor-sugar sweets.
6.Tease the lozenges back into the tiny rubber trays - curling back the retaining edging - and reassemble. Cross fingers, turn on, re-set codes and print or copy away.Tuck out of sight screws left over.
by unknown on Mar 16, 2009 at 6:44am Add comment
Man, it sounds pretty complicated. What in the heck do they think the average consumer is going to do when they run into this problem. Obvious ploy to get us to buy or repair.... I'll let you know if or when I will attemp this ;-( - Anonymous
Fantastic, Followed the instructions, Message Gone, Pads Clean, Printer can stay, yippee!!!! - Anonymous
Is this a real solution???? This sounds weird. Has anybody out there tried to clean the reservoir??? - Anonymous
It worked instantly to perfection.
1. Turn off the canon printer.
2. Hold button Resume/Cancel (red triangle in the circle), click on POWER - an indicator light green.
3. Release the button Resume / Cancel keeping POWER.
4. Click Resume/Cancel 2 times, keeping POWER, and then release all the buttons.
5. When the indicator recorded GREEN - click Resume / Cancel 4 times!
6. Turn off the printer POWER button.

We are printing and rolling, once again.
A great and helpful website, thanks
by Anonymous on Mar 16, 2009 at 9:12pm Add comment
Thanks, it worked. How do you find the solutions like that? You guys are smart - Anonymous
Oh my gosh thanks so much! It worked. The message told me to contact the service center the waste absorber was completely full. I thought I was going to have to buy a new printer. Thank you so much!!!
by Anonymous on Mar 29, 2009 at 12:13am Add comment
excellent, worked a treat - thanks
by Anonymous on Apr 21, 2009 at 1:25pm Add comment

I have the error 5800 but when I try to press the Menu button up comes the message Invalid Key/Set, and it won't go past that.The same happens if I press the copy/scan button.

I tried turning the machine off and them holding the stop/reset button as suggested above and again nothing happened.

When I turn on the printer, the Error 5800 light comes on. It will not allow me to go to the Menu or anything else. How do I get around the error 5800 and have this fixed?

Help! Many thanks,

by Lagarto on Apr 22, 2009 at 8:21am Add comment
is there a way to reset the canon ip 1500 waste ink absorber code?
by Anonymous on Jun 3, 2009 at 6:34am Add comment
1.- With printer OFF press the POWER button, keep the pressure on.
2.- Twice, press the RESUME button and take your finger off the POWER button. This should position the cartridges to be removed.
3.- After removing cartridges, turn off the POWER.
3.- Disconnect the electrical cord off the printer.
4.- With a finger pressuring the POWER button connect the electrical cord to the printer.
5.- While pressuring the POWER button press the RESUME button, twice. Take pressure off from the POWER button. A steady green light indicates you have a NEW PRINTER (a copy) attached to your computer and ready to work.
6.- After testing and using the NEW PRINTER, use the right button of the mouse to delete the old one and to RENAME the NEW PRINTER.
- Anonymous
Great advice - many thanks
by Anonymous on Aug 18, 2009 at 1:56am Add comment
Printer is STUBBORN - will not print This is the bizarre sequence I am getting now. I have exhausted almost all online suggestions

Sequence: ON = LED "1" to print document - no document sent
Ignore it for a few seconds now says
Printer ready (Driver 1.01)
Press "print"
Message on screen "ready"
start printing = shows blinking lights signals ready
shows E3 (paper jam) - no paper in machine
Alarm on color ink
Shows on monitor Paper Jam again
Shows color ink alarm (ink is running low = new cartridge in machine) wait a few seconds
Now shows document ready to print alarm off no error message
Command "Print" and E3 shows as error.

It growls and grumbles as you would expect. responds to all commands (BUT DOES NOT PRINT) Shall we get the dirge ready?
by cywrite on Aug 21, 2009 at 1:28pm Add comment
Great advise. Wasn't sure what to do. Done in 5 minutes.Thanks a lot.
by Anonymous on Aug 31, 2009 at 4:09am Add comment
Fix works. Cover is hard to pry off, though.
by Anonymous on Sep 11, 2009 at 6:19am Add comment
nada responde na minha impressora fica o tempo todo piscando o visor com a mesma mensagem e não consigo midar nem apertar nenhum botão pois nao funciona
by Anonymous on Sep 17, 2009 at 6:43am Add comment
WOW! I am so glad i found this. I love this printer and was so upset. All the same things happened to me as everyone else has posted about calling cannon and trying to get it repaired. I had even picked out another printer that was gonna cost me $200.

Then on one last whim, I googled and found this forum. The trick got the error message to leave, and I too was skeptical about putting a bandaid on the problem. So I followed the advice listed on 3/16/09 about cleaning the pads. Well I didn't even have to unscrew or pry anything out! All I did was open the printer up, the ink cartridges slid over to the left and I could see the little black pads on the right side. So I scooped them out and took them to the sink.

A trick I use to get ink out of clothing that ALWAYS WORKS (even on white scrubs) is ordinary pump style hair spray. The cheap brands work great. A couple of squirts on the stain, I throw them in the wash and poof! they come right out. (sometimes if they have been washed and dried I have to do this a couple of times. So I found one of those medicine cups like on the top of a bottle of pepto, filled it 1/3 full with hairspray and let those little ink absorbers soak, and rinsed them a few times, and they are as good as new!

This web site was a money saver - just saved myself $200. From now on, I will google anytime I have a technical problem.

by RadChick on Sep 27, 2009 at 8:53pm Add comment
Thank you, Radchick. I couldn't find my name so I left a number...
I have a 150 and had been turned down at repair shops. I didn't want to chuck it just yet and was getting ready to call the local computer repair schools as they sometimes want equipment for their students to work on. I don't claim victory over the dreaded ink problem, but I will try again at your inspiration.
A neighbor donated a Brother but some of the features like hidden paper feed and a barely visable LED that needs a flashlite are unacceptable design problems. We are joined at the hip with these printers....
by unknown on Sep 28, 2009 at 6:33am Add comment

I did what Radchick (9/27/09) did: I popped the top as if I were going to change an ink cartridge, was able to see the 2 absorbers in their trays, got some needle-nosed pliers (and a flashlight) and pulled them out, soaked them in alcohol, rinsed them in hot water, soaked them in more alcohol, rinsed them in hot water again, dried them, then put them back in their rubber trays.

I then did what Mike Dias did (10/20/06):

1) Enter SERVICE MODE By pressing Menu-Scan-Copy-Scan
2) Enter NVRAM by pressing <--- or ---> then OK

Now I have clean Waste Ink Pads and no more messages about them.
by Anonymous on Sep 28, 2009 at 3:39pm Add comment
I ve cleaned the waste ink tank and everything else, i ve reset the MP130 but now the printer prints only blank pages. What sould be the problem?
by unknown on Oct 5, 2009 at 3:31am Add comment
merci pour les information ,mais mon problem lorsqu j appuis sur menu je voi ce message (invalidkey/set)aide moi s.v.p
by unknown on Oct 12, 2009 at 2:55am Add comment
how can i solv that
by unknown on Dec 12, 2009 at 6:24am Add comment

by cywrite on Dec 15, 2009 at 12:52pm Add comment
you saved me buying a new printer! i was told it would cost almost as much to get it service. I am so excited to have a working printer again. thanks a bunch.
by Anonymous on Jan 5, 2010 at 5:26pm Add comment
BIG THANKS!!! This saved my day and now it's fully working. Again, really thank you!!!
by unknown on Jan 25, 2010 at 10:16am Add comment
Alas I think there's only one solution.
1. Switch it off.
2. Unplug it from the mains.
3. Throw it out the window.
4. Buy an Epson.
by unknown on Jan 25, 2010 at 3:30pm Add comment
I have Pixma MP450 printer with a "Waste Ink Full" message. It will not do anything, and all I see is the On/Off button and the yellow alarm light blinking alternatively. I cannot get it to go into menu mode or any other mode. I have turned it on and off and have unplugged it and plugged it back in.

Does anyone have a solution?

Best Regards,
Ron Green
by Anonymous on Feb 5, 2010 at 11:51am Add comment
I've cleaned the pads as recommended above but the message is still "check printer (5800)". None of the keys work, I just get "invalid Key/Set" when I press anything - so I can't access the menu to reset the printer. I've read the threads above but can't see an answer to this problem on the MP130?
by Tiff on Feb 9, 2010 at 5:19am Add comment
Your printer lost it's way mechanically.
Open cover,shift manually cartridge to right.
1.Put sheet in feeder,pull maaincord out (back of printer)
2.Left inside you see plastic circular flexible positioningdisc attached to shaft transporting the paper.Very carefully turn it round by fetching it on the edge untill the sheet in the feeder is mechanically pulled inside ;you can hear it transport.
3.If the paper is pulled inside halfway,close the cover.
4.Attach maincord on the back.

You now brought the printer in mechanical startposition where it can pick up electrically.

5.Press on/off and wait. - Anonymous
how can i re solve if my pixma mp130 Canon Error put in cartridge
by unknown on Feb 24, 2010 at 8:22am Add comment
How to reset printer after cleaning out the waste ink (tanks). Thanks
by gordonh on Feb 25, 2010 at 2:41pm Add comment
by Anonymous on May 9, 2010 at 10:47am Add comment
My Pixma MP130 prints, but blank white paper comes out.
seems everything is alright, how to fix this?
by Anonymous on May 27, 2010 at 10:49pm Add comment
Sorry, I cannot provide you a better solution you have experienced. Also, mine (5 year-old) has never come blank parers. Cheers! - Anonymous
WOW.. this was awsome!!!! thank you thank you
by unknown on Jun 25, 2010 at 7:32pm Add comment
thanks great help
by unknown on Dec 3, 2010 at 7:51am Add comment
error 5800 pls help me to fix these pls pls pls
by edzneggie on Feb 21, 2011 at 9:22pm Add comment
Wow it is not 2012 and my little Canon Pixma MP130 is still going - JUST - and I have just used this info to keep it working a bit longer THANKS
by unknown on Mar 5, 2012 at 8:12pm Add comment
I cant get to the Menu when I turn on the printer it says "check printer" 5800
by unknown on Mar 26, 2012 at 11:58am Add comment
Perfect, thanks for the tip.
by unknown on Jun 30, 2012 at 9:56am Add comment
Do you have a fix for canon MP228 'ink absorber is full' and '5b00' errors? I've done my best cleaning the ink waste pad inside, dis-assembling and re-assembling it again. Fix here won't work on it, please reply asap, thanks!
by unknown on Jan 9, 2013 at 12:09pm Add comment
I am getting message on my Canon Pixma MX860 printer that the waste ink absorber pad is full. Is there a way to get rid of that message?
R. Roos
by unknown on Jan 22, 2013 at 8:21am Add comment
I have cannon printer MP250 I have ink all over the place and an error message that says #5800. It wont print anymore.. can anyone help me? I saw it says press menu but my printer doesnt have a menu button
by trinawhitman on Feb 1, 2013 at 10:17am Add comment