fixyourownprinter.com
  Home    Reference    Printer Repair Kits    Cartridges    Fusers    Specials    Forums  
  Printer Repair | Laser | InkJet | Chat | SearchSign In | Sign Up  

Epson 1280 Prints Blank Pages After Cleaning Head

Post to this thread   Post a new message thread

Epson 1280 Prints Blank Pages After Cleaning Head by mrd31486 (11/13/13 8:17 AM) reply + / -
I am in the process of starting a DTG build based on an Epson 1280 printer. I removed and cleaned the print head, and am not able to get anything to print. Ink is passing through the head on cleaning cycles, and the carriage moves as if printing, but all I get are blank pages.

I have come to the conclusion that I may have installed the head while is was still wet and created a problem for myself.

It seems that the fuse "F1" on the main board relates to the print head, but that checks out fine.

I also, however, see what appears to be another fuse next to that labeled "F2" that is open.

I am not seeing this "F2" in the service manual, or any other documentation I have found so far. I have no idea what to replace it with. I am assuming it's a fuse just based on the label that's printed on the board. Does anyone have an idea?


printer sx210 allin one by podger78 (11/14/13 7:35 AM) reply + / -
only issues blank pages printer goes all through motions but blank pages come out all clean new ink cartridges etc looks like printer not receiving message from printer beam me up scotty


Post to this thread:

User:
Email:
Notify me if someone responds

Icon:            
Subject:
Message:



© 2012 fixyourownprinter.com, All posts belong to their respective posters